Author Topic: Master Brick wird mit 2.2.0 nicht mehr erkannt  (Read 2796 times)

Robin

  • Guest
Master Brick wird mit 2.2.0 nicht mehr erkannt
« on: April 09, 2014, 18:32:05 »
Hallo zusammen,

ich habe gerade einen meiner Master Bricks auf die neue Firmware Version 2.2.0 geflasht. Jetzt wird er allerdings an meinem Lenovo t61p nicht mehr erkannt. Wenn ich ihn am Raspberry Pi mit aktivem USB Hub anschließe, dann wird er allerdings erkannt und die Kommunikation mit den Bricklets funktioniert auch. Jetzt habe ich wieder ein Downgrade auf die Version 2.1.2 durchgeführt und er wird auch am Laptop wieder erkannt.
Das Problem ist grundsätzlich auch schon in der Beta Phase der neuen Firmware aufgetreten, die ich auf einen Master mit Ethernet Extension aufgespielt habe, weil die DHCP Probleme bei mir doch wieder nach einiger Zeit (vermutlich nach Ablauf des Lease) auftraten. Ich habe damals den Quellcode selber kompilliert um die LED zu deaktivieren. Deshalb dachte ich, ich hätte vielleicht irgendeinen Fehler gemacht aber daran lag es dann wohl nicht. Ich habe das Problem dann natürlich auf die lange Bank geschoben, weil dieser Master sowieso nicht an meinem Computer betrieben wird.
Ich vermute, dass das mit der Anhebung der USB Hotplug-Detect Grenze zusammenhängt. Eventuell ist die Versorgungsspannung meines Laptops zu gering, die des USB Hubs reicht aber aus.

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #1 on: April 09, 2014, 18:42:37 »
Oha, das ist nicht gut. Kannst du die angehängte Master Brick Firmware einmal mit deinem Laptop testen?
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

Robin

  • Guest
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #2 on: April 09, 2014, 18:52:49 »
Hallo Borg,

danke für die schnelle Antwort. Der Master Brick wird im Brick Viewer allerdings immer noch nicht angezeigt. Ich habe vorhin zwar noch nicht danach gesehen, aber im Gerätemanager taucht er auf jeden Fall ohne Fehler auf.

Edit: Ich habe den Computer nochmal neu gestartet um sicherzustellen, dass die aktuelle Version des BrickD und BrickV ausgeführt wird. Leider ohne erfolg.
« Last Edit: April 09, 2014, 18:58:51 by Robin »

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #3 on: April 09, 2014, 18:59:23 »
Dann liegt das Problem nicht an der Spannungsgrenze. Taucht der Master Brick auf wenn du im Brick Daemon Disconnect -> Connect drückst? (Dadurch wird nochmal ein Enumerate ausgeführt)

Edit: Auf welchen Versionen sind denn der brickd und brickv bei dir aktuell? Alles auf den gerade veröffentlichten Versionen?
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

Robin

  • Guest
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #4 on: April 09, 2014, 19:11:19 »
Der BrickV und BrickD sind auf jeden Fall aktuell. Die habe ich noch bevor ich den Brick geflasht habe aktualisiert. Ich habe gerade einfach mal die Ubuntu Partition gebootet und es da ausprobiert. Siehe da: Es funktioniert, obwohl ich weder BrickV noch BrickD aktualisiert habe. Auch nach dem Update lief noch alles. Der Master wird auch noch mit der 2.2.0er Firmware erkannt. Da muss also irgendwas unter Windows schief laufen.
« Last Edit: April 09, 2014, 19:13:14 by Robin »

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #5 on: April 09, 2014, 19:15:34 »
Mh, kannst du unter Windows mal einmal Version brickd 2.0.9 ausprobieren?

http://download.tinkerforge.com/tools/brickd/windows/

Damit können wir dann einschränken ob es an der neuen brickd oder an der neuen Master Brick Version liegt.

Edit: Was sagt eigentlich das brickd log und Windows? http://www.tinkerforge.com/de/doc/Software/Brickd.html#logging
« Last Edit: April 09, 2014, 19:20:44 by borg »
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

Robin

  • Guest
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #6 on: April 09, 2014, 19:21:12 »
So habe ich gerade gemacht. Zur Sicherheit werde ich gleich noch mal einen Neustart durchführen, es hat allerdings bisher keine Besserung gebracht. Beim Disconnect werden unter Windows die Bricklets auch nicht nur kurz angezeigt. Allerdings ist mir aufgefallen, dass wenn man den Master trennt, man sich mit dem BrickV verbindet, den Brick wieder einsteckt und auf das DemmDemm wartet und dann auf Disconnect klickt der Disconnect deutlich länger dauert als sonst. Irgendwas scheint da also übertragen zu werden. Auch ein Downgrade des BrickV hat das Problem nicht gelöst.

Edit: An das Logfile hatte ich auch gerade gedacht. Hier ein Auszug:
Code: [Select]
2014-04-09 19:16:42 <Error> Could not find USB device (bus: 15, device: 2)
2014-04-09 19:16:42 <Warning> Ignoring USB device (bus: 15, device: 2) due to an error
2014-04-09 19:17:00 <Error> Could set configuration for USB device (bus: 15, device: 2): LIBUSB_ERROR_NOT_FOUND (-5)
2014-04-09 19:17:00 <Warning> Ignoring USB device (bus: 15, device: 2) due to an error
2014-04-09 19:20:40 <Error> Could set configuration for USB device (bus: 15, device: 2): LIBUSB_ERROR_NOT_FOUND (-5)
2014-04-09 19:20:40 <Warning> Ignoring USB device (bus: 15, device: 2) due to an error
2014-04-09 19:20:57 <Error> Could set configuration for USB device (bus: 15, device: 2): LIBUSB_ERROR_NOT_FOUND (-5)
2014-04-09 19:20:57 <Warning> Ignoring USB device (bus: 15, device: 2) due to an error
2014-04-09 19:22:10 <Error> Could set configuration for USB device (bus: 15, device: 2): LIBUSB_ERROR_NOT_FOUND (-5)
2014-04-09 19:22:10 <Warning> Ignoring USB device (bus: 15, device: 2) due to an error
« Last Edit: April 09, 2014, 19:23:54 by Robin »

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #7 on: April 09, 2014, 19:29:39 »
Kannst du die angehängte Firmware nochmal ausprobieren?
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

Robin

  • Guest
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #8 on: April 09, 2014, 19:47:47 »
Das hat es leider auch nichts gebracht. Ich habe den BrickD jetzt mal im Debug Modus gestartet. Vielleicht kannst du ja damit etwas anfangen. Ist zwar auf dem CMD gestartet und deshalb wahrscheinlich grausig formatiert aber anders bin ich da leider nicht dran gekommen.

Code: [Select]
C:\Program Files\Tinkerforge\Brickd>brickd.exe --debug
Starting...
2014-04-09 19:40:57.548901 <I> <other|main_windows.c:811> Could not start as ser
vice, starting as console application
2014-04-09 19:40:57.564501 <I> <other|main_windows.c:587> Brick Daemon 2.1.0 sta
rted
2014-04-09 19:40:57.564501 <D> <event|event.c:56> Initializing event subsystem
2014-04-09 19:40:57.564501 <D> <event|event.c:140> Added generic event source (h
andle: 184, events: 1) at index 0
2014-04-09 19:40:57.564501 <D> <hardware|hardware.c:37> Initializing hardware su
bsystem
2014-04-09 19:40:57.564501 <D> <usb|usb.c:191> Initializing USB subsystem
2014-04-09 19:40:57.564501 <D> <event|event.c:140> Added USB event source (handl
e: 1, events: 1) at index 1
2014-04-09 19:40:57.564501 <D> <event|event.c:140> Added USB event source (handl
e: 2, events: 1) at index 2
2014-04-09 19:40:57.564501 <D> <usb|usb.c:217> libusb requires special timeout h
andling
2014-04-09 19:40:57.564501 <D> <usb|usb.c:242> libusb does not support hotplug
2014-04-09 19:40:57.564501 <D> <usb|usb.c:287> Looking for added/removed USB dev
ices
2014-04-09 19:40:58.391303 <D> <event|event.c:140> Added generic event source (h
andle: 500, events: 1) at index 3
2014-04-09 19:40:58.391303 <D> <other|main_windows.c:349> Starting message pump
thread
2014-04-09 19:40:58.391303 <D> <other|main_windows.c:273> Started message pump t
hread
2014-04-09 19:40:58.391303 <D> <network|network.c:244> Initializing network subs
ystem
2014-04-09 19:40:58.391303 <D> <network|network.c:131> Opening server socket on
port 4223
2014-04-09 19:40:58.406903 <D> <network|network.c:207> Started listening to '0.0
.0.0' (IPv4) on port 4223
2014-04-09 19:40:58.406903 <D> <event|event.c:140> Added generic event source (h
andle: 536, events: 1) at index 4
2014-04-09 19:40:58.406903 <D> <event|event.c:216> Starting the event loop
2014-04-09 19:40:58.406903 <D> <event|event.c:140> Added generic event source (h
andle: 196, events: 1) at index 5
2014-04-09 19:40:58.406903 <D> <event|event_winapi.c:529> Starting to select on
4 + 0 generic event source(s)
2014-04-09 19:40:58.406903 <D> <event|event_winapi.c:119> Started USB poll threa
d
2014-04-09 19:40:58.406903 <D> <event|event_winapi.c:124> Resumed USB poll threa
d
2014-04-09 19:40:58.406903 <D> <event|event_winapi.c:181> Starting to poll on 2
USB event source(s)
2014-04-09 19:41:29.934558 <D> <other|main_windows.c:212> Received device notifi
cation (type: arrival)
2014-04-09 19:41:29.934558 <D> <event|event_winapi.c:539> Sending suspend signal
 to USB poll thread
2014-04-09 19:41:29.934558 <D> <event|event_winapi.c:209> Received suspend signa
l
2014-04-09 19:41:29.934558 <D> <event|event_winapi.c:231> Suspending USB poll th
read
2014-04-09 19:41:29.950158 <D> <event|event_winapi.c:580> Select returned 1 gene
ric event source(s) as ready
2014-04-09 19:41:29.950158 <D> <event|event_winapi.c:615> Handling generic event
 source (handle: 500, received events: 1) at index 3
2014-04-09 19:41:29.950158 <D> <usb|usb.c:287> Looking for added/removed USB dev
ices
2014-04-09 19:41:32.817764 <D> <usb|usb.c:119> Found new USB device (bus: 15, de
vice: 2)
2014-04-09 19:41:32.817764 <D> <usb|usb_stack.c:187> Acquiring USB device (bus:
15, device: 2)
2014-04-09 19:41:32.817764 <D> <event|event.c:140> Added USB event source (handl
e: 3, events: 1) at index 6
2014-04-09 19:41:32.817764 <D> <event|event.c:140> Added USB event source (handl
e: 4, events: 1) at index 7
2014-04-09 19:41:35.594568 <E> <usb|usb_stack.c:298> Could set configuration for
 USB device (bus: 15, device: 2): LIBUSB_ERROR_NOT_FOUND (-5)
2014-04-09 19:41:35.594568 <D> <event|event.c:168> Marked USB event source (hand
le: 3, events: 1) as removed at index 6
2014-04-09 19:41:35.594568 <D> <event|event.c:168> Marked USB event source (hand
le: 4, events: 1) as removed at index 7
2014-04-09 19:41:35.594568 <W> <usb|usb.c:134> Ignoring USB device (bus: 15, dev
ice: 2) due to an error
2014-04-09 19:41:35.610168 <D> <event|event_winapi.c:631> Handled all ready gene
ric event sources
2014-04-09 19:41:35.610168 <D> <event|event.c:192> Removed USB event source (han
dle: 4, events: 1) at index 7
2014-04-09 19:41:35.610168 <D> <event|event.c:192> Removed USB event source (han
dle: 3, events: 1) at index 6
2014-04-09 19:41:35.610168 <D> <event|event_winapi.c:529> Starting to select on
4 + 0 generic event source(s)
2014-04-09 19:41:35.610168 <D> <event|event_winapi.c:124> Resumed USB poll threa
d
2014-04-09 19:41:35.610168 <D> <event|event_winapi.c:181> Starting to poll on 2
USB event source(s)

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #9 on: April 09, 2014, 19:53:15 »
Jetzt wird es komisch ;D. Ich hab in beta2 alles wieder rückgängig gemacht was mit USB zu tun hat.

Ich gucke nochmal alle Änderungen durch.
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #10 on: April 09, 2014, 20:08:51 »
So, letzter Versuch für heute. Kannst du die angehängte Firmware nochmal testen? Hab noch eine Stelle gefunden die ich auskommentieren konnte ;).
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

bastir

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #11 on: April 09, 2014, 20:26:23 »
Hallo,

habe das gleiche Problem heute an meinem Hauptrechner gehabt.
Die von borg zur Verfügung gestellte Beta3 Firmware hat bei mir geholfen.

Falls es hilft, hier die Hardware:
Dell Latitude 6430
Windows 8 Pro 64Bit
16GB RAM

Danke für die beta.

Grüße
Sebastian

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #12 on: April 09, 2014, 20:31:16 »
Danke für die Hilfe!

@Robin: Verwendest du auch Windows 8 64 Bit?

Ich werde dann jetzt schnell eine 2.2.1 Release machen und die USB Änderungen dort wieder rausbauen. Dann können wir da morgen in Ruhe nochmal testen. Interessant wäre es jetzt noch herauszufinden was ihr beide gemeinsam habt, damit wir das Problem auch reproduzieren können.
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

Robin

  • Guest
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #13 on: April 09, 2014, 21:14:05 »
Hat bei mir jetzt auch funktioniert. Danke für den schnellen Support. Ich verwende Windows 7 32 Bit.

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Master Brick wird mit 2.2.0 nicht mehr erkannt
« Reply #14 on: April 09, 2014, 22:42:59 »
Das ist komisch, ich hatte es hier erst unter xp einmal getestet und photron hatte es eben einmal unter 7 ausprobiert. Bei beiden gab es keine Probleme (mit 2.2.0).

Eventuell liegt es daran das wir es beide male nur in einer VM getestet haben, dann müssen wir das wohl nochmal auf unterschiedlichen nativen Windowsen ausprobieren.

Auskommentiert hab ich jetzt in 2.2.1 nur ein Zeile die eigentlich Supsend to Disk Probleme fixen sollte: https://github.com/Tinkerforge/bricklib/commit/7f7914836500674e15dfb97fcb3156d8a7e321b3

Die Zeile war schon seit 7 Monaten im git :o.
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!