Author Topic: RS485 durch USB 2.0 - RedBrick  (Read 1340 times)

davidcomboni

  • Newbie
  • *
  • Posts: 4
    • View Profile
RS485 durch USB 2.0 - RedBrick
« on: November 04, 2016, 18:21:34 »
Hallo community,

Ich versuche ein Red-Brick mit einem RS485 Schnittstellenwandler zu verbinden, aber der USB treiber wird nie initialissiert. Dann habe ich eine tastatur angeschlossen, aber diese wird auch nicht erkannt.  Ich bin ziemlich neu zu tinkerforge und Red-Brick, aber muss man zuerst der USB2.0 aktivieren?  Wie kann ich der USB einfach testen?

Ich habe mit dem command "lsusb" folgendes raus (eine Maus ist angeschlossen):

tf@fcu-1:~$ lsusb                                               
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 

Der Stack beesteht aus (reihenfolge von unten nach oben):
- Step-Down Power Supply mit 12Vdc Anschluss
- Red-Brick mit micro SD und image version 1.8(full)
- Ethernet Master Extension (mit PoE)
- Master Brick 2.1


photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.475
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #1 on: November 04, 2016, 18:41:38 »
Der USB Host Anschluss am RED Brick muss nicht aktiviert werden.

Das lsusb die Maus nicht auflistet ist komisch.

Stecke mal bitte die Maus ab und und wieder an und lass dir dann die letzten 20 Zeilen Kernel Log auf dem RED Brick anzeigen:

Code: [Select]
dmesg | tail -n 20
Am besten postet du die Ausgabe hier.

davidcomboni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #2 on: November 07, 2016, 11:14:21 »
Ok, Red-Brick eingeshaltet Maus gesteckt und folgendes kommt raus:

Code: [Select]
[   17.700923] [drm] Initialized mali_drm 2.1.1 20101111 on minor 1             
[   17.997065] Version test w5500 : 00                                         
[   20.552289] Version test w5200 : 03                                         
[   20.552304] Found W5200                                                     
[   28.201798] Version : 03                                                     
[   28.201860] iinchip_socket_sethwaddr():671=40:d8:55:2:a4:b6                 
[   28.201964] w5x00: MAC [40:d8:55:02:a4:b6]                                   
[   28.203560] w5x00: socket(0) Tx(0x4000,0x3fff,0x8000) Rx(0x4000,0x3fff,0xc000
)                                                                               
[   28.203646] w5x00: socket(1) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.203724] w5x00: socket(2) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.203803] w5x00: socket(3) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.203890] w5x00: socket(4) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.203967] w5x00: socket(5) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.204044] w5x00: socket(6) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.204117] w5x00: socket(7) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   28.208648] w5x00 spi register succeed                                       
[   28.439751] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   28.439773] nuke: ep num is 0                                               
[   52.416512] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   52.416534] nuke: ep num is 0                                               

photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.475
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #3 on: November 08, 2016, 11:07:39 »
Das sieht nach einem Hardwareschaden aus.

Auf der Unterseite des RED Brick sitzen unter dem USB-A Stecker zwei kleine schwarze Bauteile. Eins mit 4 Beinchen (siehe Bild) und eins mit 6 Beinchen. Ich erwarte, dass das mit 4 Beinchen fehle.

Wenn das der Fall ist, dann melde dich bitte bei info@tinkerforge.com und verweise auf den Thread hier.

davidcomboni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #4 on: November 08, 2016, 17:45:33 »
Tja, es sieht so aus als ob das Problem sich selbst geloest hat.  Nach dem ich deine Antwort gelesen habe, habe ich der Red-Brick untersucht (Die 4 Beinchen sind da) und die Abstandshalter rausgenommen, Red- Brick rausgesteckt und wieder rein.  Dieses mal aber ohne Unterlegscheiben. 

Dann habe ich es nochmal probiert, und dieses mal wurde die Maus und die USB-RS485 erkannt.  Also ich denke mal, dass das Problem in der Position Unterlegscheiben lag.  Diese sind fuer ein Paar stellen des Red-Bricks zu dick und koennen die Elektronik beruehren.

Code: [Select]
tf@fcu-1:~$ lsusb                                                         
Bus 002 Device 002: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0 
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub             
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub             

Code: [Select]
[   26.832688] w5x00: socket(1) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.832764] w5x00: socket(2) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.832835] w5x00: socket(3) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.832910] w5x00: socket(4) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.832985] w5x00: socket(5) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.833061] w5x00: socket(6) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.833136] w5x00: socket(7) Tx(0x0,0x0,0x8000) Rx(0x0,0x0,0xc000)           
[   26.837609] w5x00 spi register succeed                                       
[   27.451024] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   27.451046] nuke: ep num is 0                                               
[   32.139358] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   32.139379] nuke: ep num is 0                                               
[  133.155006] usb 2-1: USB disconnect, device number 2                         
[  134.745943] ehci_irq: port change detect                                     
[  134.901716] ehci_irq: port change detect                                     
[  134.961589] The port change to OHCI now!                                     
[  135.261597] usb 2-1: new low-speed USB device number 3 using sw-ohci         
[  135.451844] input: PixArt Microsoft USB Optical Mouse as /devices/platform/sw
-ohci.1/usb2/2-1/2-1:1.0/input/input2                                           
[  135.452950] generic-usb 0003:045E:00CB.0002: input,hidraw0: USB HID v1.11 Mou
se [PixArt Microsoft USB Optical Mouse] on usb-sw-ohci-1/input0                 

CChris

  • Full Member
  • ***
  • Posts: 107
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #5 on: November 11, 2016, 11:58:30 »
Ja, das ist mir auch schon aufgefallen, dass die manchmal zu bereit sind und Kontakte an der Elektronik herstellen können.

Nur ohne hat man immer wieder mal das Problem, das sich die platine leicht verbirgt, wen man einen Stapel zusammen schraubt... :-/
Man muß hier also schon recht gut aufpassen

photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.475
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #6 on: November 11, 2016, 12:10:00 »
Das Problem mit den zu großen Unterlegscheiben in aktuellen Mounting Kits ist bekannt, sorry. In älteren Mounting Kits waren die Unterlegscheiben kleiner.

Wir sind dran und das Problem sollte in Kürze gelöst sein.

davidcomboni

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #7 on: November 15, 2016, 18:07:00 »
Vielen Dank fuer den schnellen Support!  :D

ric5sch

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #8 on: November 16, 2016, 07:34:35 »
Unterlegscheiben, ich verwende die aus Kunststoff (elektrisch isolierend und weicher als die metallenen).

Nic

  • Hero Member
  • *****
  • Posts: 1.419
  • Pano.photogr. - Just for fun: Delphi, C#...
    • View Profile
Re: RS485 durch USB 2.0 - RedBrick
« Reply #9 on: November 17, 2016, 17:00:09 »
@davidcomboni

Zum RED kompatible Hardware bitte schließlich in diese Liste eintragen:
http://www.tinkerunity.org/wiki/index.php/DE/RED_USB