Author Topic: Barometer Bricklet 1.0 liefert keine Temperatur-Updates  (Read 564 times)

peter_tau

  • Newbie
  • *
  • Posts: 27
    • View Profile
Barometer Bricklet 1.0 liefert keine Temperatur-Updates
« on: December 10, 2018, 15:26:14 »
Hallo,

ich habe ein Stapel bestehend aus MasterBrick 2.1 / MasterBrick 2.1 / Ehternet Extension w/o PoE 1.0 in genau dieser Reihenfolge im Einsatz und nutze dabei ein Barometer Bricklet 1.0, das auch Temperaturmessung ermöglicht.

An und für sich läuft der Stapel stabil. Allerdings kommt es nach einigen Tagen vor, dass der Barometer Bricklet 1.0 keine Temperatur-Updates mehr liefert. Die Temperatur "friert" auf einem bestimmten Wert ein. Alle anderen Bricklets einschließlich des vom Barometer Bricklet 1.0 gemessenen Luftdrucks kommen weiterhin an.

Alle Bricks und Bricklets befinden sich auf dem letzten Firmware-Stand von November 2018.

Hat jemand einen Hinweis, woran dieses Einfrieren liegt? Sind Einschränkungen beim Barometer Bricklet 1.0 bekannt, die mit dem neuen Barometer Bricklet 2.0 behoben sind?

Viele Grüße
Peter

borg

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 3.142
    • View Profile
Re: Barometer Bricklet 1.0 liefert keine Temperatur-Updates
« Reply #1 on: December 10, 2018, 15:57:50 »
Das ist sehr seltsam. Hab gerade in den Source Code geschaut, die Temperatur wird immer gleichzeitig mit dem Luftdruck mit einem I2C-Read aktualisiert.

Wenn die Temperatur einfriert, hast du bereits versucht dich in diesem Zustand mit dem Brick Viewer auf dem Stapel zu verbinden? Wird dort die Temperatur noch korrekt angezeigt?
Wir sind die Borg, Widerstand ist Spannung durch Stromstärke!

peter_tau

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: Barometer Bricklet 1.0 liefert keine Temperatur-Updates
« Reply #2 on: December 10, 2018, 16:06:36 »
Das werde ich beobachten. Nach einem Neustart des Stapels ist der Effekt jedenfalls verschwunden.