Author Topic: Imu brick wird nicht im brick viewer angezeigt  (Read 392 times)

mali93

  • Newbie
  • *
  • Posts: 4
    • View Profile
Imu brick wird nicht im brick viewer angezeigt
« on: February 12, 2019, 12:20:19 »
Die Imu 2.0 ist mit einem Raspberry pi verbunden. Ich habe versucht ein Firmware update mit dem brick-flash Befehl durchzuführen, jedoch ist dies fehlgeschlagen.
Meldung:
Writing firmware: 100%
Verifying firmware: 0%
Error: Could not write firmware: Verification error
Seit dem funktioniert nichts mehr. Ich habe mir anschliessend den Brick Viewer auf dem Laptop installiert und mit dem Pi verbunden. Der Servo-Brick wird angezeigt, der Imu-Brick jedoch nicht.
Wie soll ich weiter vorgehen?

batti

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 983
    • View Profile
Re: Imu brick wird nicht im brick viewer angezeigt
« Reply #1 on: February 12, 2019, 13:06:22 »
Hallo,

was für eine Schnittstelle wird denn zum flashen ausgewählt?
Kann es sein, dass du eine falsche wählst? Das würde erklären warum das Verify fehlschlägt.

mali93

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Imu brick wird nicht im brick viewer angezeigt
« Reply #2 on: February 12, 2019, 13:30:10 »
Vielen Dank für die rasche Antwort.
Ich habe es mit /dev/ttyACM0 versucht. Für den Servo-Brick hat dies funktioniert. Wird die Imu nach einem solchen Fehlversuch nicht mehr im Brick Viewer angezeigt? Es leuchten auf jeden Fall keine Led's mehr, auch wenn der Brick aus- und wieder eingesteckt wird.

batti

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 983
    • View Profile
Re: Imu brick wird nicht im brick viewer angezeigt
« Reply #3 on: February 12, 2019, 13:44:58 »
Bricks müssen ja mittels Erase Button in den Bootloader gebracht werden. Wird dieser beim Starten eines Bricks gedrückt (zum Beispiel durch Reset erzeugt), so löscht der Controller seine Firmware. Dann leuchten auch keine LEDs mehr.

Der Brick wartet dann auf eine neue Firmware.

Sonst probier bitte nochmal den Brick in den Bootloader zu bringen und ihn erneut zu flashen. /dev/ttyACM0 klingt prinzipiell nach dem richtigen Port.

mali93

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Imu brick wird nicht im brick viewer angezeigt
« Reply #4 on: February 12, 2019, 14:04:33 »
Habe versucht in den Bootloader zu kommen mit erase gedrückt halten und kurz reset drücken und dann erase wieder loslassen. Beim Flashen wieder die selbe Fehlermeldung bekommen. Habe dann versucht beim Einstecken erase gedrückt zu halten um in den Bootloader zukommen. Auch so hat es mit dem Flashen nicht geklappt.

mali93

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Imu brick wird nicht im brick viewer angezeigt
« Reply #5 on: February 12, 2019, 15:05:24 »
Habe den Brick direkt mit dem Laptop verbunden und so hat es funktioniert. Verstehe nicht warum, aber ist ja auch egal :)
Trotzdem vielen Danke für die Hilfe