Author Topic: Mesh Netzwerk nicht stabil  (Read 534 times)

Rio

  • Newbie
  • *
  • Posts: 2
    • View Profile
Mesh Netzwerk nicht stabil
« on: March 08, 2019, 16:04:39 »
Hallo,

leider habe ich ein Problem mit dem Aufbau eines Mesh-Netzwerkes mittels der WLAN Extensions.
Konkret habe ich 5 Stapel, zu je 1x Master, 4x Stepper, 1x DIO4V2
Aktuell wurde das gesamte System über ein USB-Kabel betrieben welches mittels USB-Hub verteilt wurde. Also meine Software hat sich alle Stapel gesucht und alle get/set-Befehle zugewiesen. So weit, so gut.

Als Modernisierung des Systems soll der ganze Spass jetzt über WLAN laufen. Deswegen habe ich überall die Wlan-Extension draufgesteckt. In der Beschreibung steht ja dass man das als Mesh-Netzwerk konfigurieren kann, was ja dem Aufbau von "usb --> usb-hub --> Stapel" relativ nahe kommt.

Der Testaufbau sieht so aus, dass ein Rootnode bestehend aus Master+Wlan per USB an einem PC hängt. Diesen Rootnode habe ich entsprechend konfiguriert und der Zugriff darauf über die IP des PCs funktioniert problemlos.
Bei den anderen Stapeln, habe ich die Felder "Router SSID" und "Router Password freigelassen" und alle anderen Einräge genauso wie beim Rootnode ausgefüllt. Diese Stapel sind nicht mit einem PC verbunden.
Das Problem ist jetzt dass das Meshnetzwerk sich scheinbar permanent resettet. Wenn ich beim Rootnode den WLAN-Status beobachte schwankt dieser zuerst zwischen "Got IP" und "Mesh Online". Die "Connected Nodes" schwanken permanent zwischen 0 und 3 (aktuell nur 3 stapel).
Nach einigen Minuten steht der Rootnode permanent bei "Mesh Local", aber die "Connected Nodes" schwanken immernoch aller ca. 3 Sekunden. Es wirkt so, als würde die bestehende Verbindung sofort wieder beendet werden.
Im Brickviewer werden die Mesh-Stapel auch nicht angezeigt, nur der Rootnode.
Auch die grünen Status-Leds pendeln zwischen langsamen Blinken sobald die Verbindung aufgebaut wurde und schnellem Blinken sobald sie neu gesucht wird.

Hat einer jemand eine Idee woran das liegen könnte?

Edit: Was mir auch gerade noch aufgefallen ist, ist das scheinbar der ganze Stapel kurz resettet wird sobald eine Verbindung aufgebaut wurde. Zumindest gehen alle blauen LEDs ganz kurz aus. Und dann geht die Netzsuche wieder los.
Die einzelnen Stapel resetten sich jedoch zeitlich unabhängig voneinander, also es liegt nicht an der Spannungsversorgung.

Danke im Vorraus,
Rio
« Last Edit: March 08, 2019, 16:12:27 by Rio »

Rio

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Mesh Netzwerk nicht stabil
« Reply #1 on: March 12, 2019, 14:25:37 »
Hallo,

da ich für das Resetten des Mesh-Netzwerks keine Lösung gefunden habe, habe ich alle Stapel als einzelne Clients verbunden. Das geht zwar, aber leider ist Wlan scheinbar nicht besonders geeignet zur parallelen Ansteuerung von mehreren Motoren. Das ganze funktioniert sehr unzuverlässig. Auch 0,5sek Pause zwischen den einzelnen set/get-Befehlen brachte kaum eine Besserung.
Vermutlich wäre es also notwendig einen Raspberry Pi o.Ä. als "Vermittler" zu integrieren, an dem die einzelnen Stapel über USB angeschlossen sind.

Somit hat sich das Topic hier erledigt. Bleibt einfach bei USB...never touch a running system :)