Author Topic: brickv 2.4.1 und IO16 Error  (Read 352 times)

Loetkolben

  • Hero Member
  • *****
  • Posts: 1.178
    • View Profile
brickv 2.4.1 und IO16 Error
« on: April 02, 2019, 22:13:30 »
Beim click auf die IO16 Lasche kommt das


Code: [Select]
Traceback (most recent call last):
  File "/usr/share/brickv/async_call.py", line 68, in async_event_handler
    function()
  File "/usr/share/brickv/plugin_system/plugins/io16/io16.py", line 125, in get_monoflop_async
    next(self.init_async_generator)
  File "/usr/share/brickv/plugin_system/plugins/io16/io16.py", line 148, in init_async
    self.init_values(port, self.init_value, self.init_dir, self.init_config, time, time_remaining)
  File "/usr/share/brickv/plugin_system/plugins/io16/io16.py", line 177, in init_values
    if dir & (1 << i):
TypeError: unsupported operand type(s) for &: 'builtin_function_or_method' and 'int'


Der Loetkolben

photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.439
    • View Profile
Re: brickv 2.4.1 und IO16 Error
« Reply #1 on: April 03, 2019, 11:13:29 »
Ist im git Repo behoben. Es wird in Kürze Brick Viewer 2.4.2 geben.

Danke für den Hinweis!

Loetkolben

  • Hero Member
  • *****
  • Posts: 1.178
    • View Profile
Re: brickv 2.4.1 und IO16 Error
« Reply #2 on: April 03, 2019, 19:29:39 »
Da helfe ich doch gerne.  ;D

Aber fuer alle anderen Bricklets die ich nicht am Stack habe testet ihr das bitte nochmals.

BTW: Kann es sein, dass man unter Linux (Debian 9) keinen Unterschied zwischen normal und "Fusion GUI Style" sieht? Man sieht immer den neuen Stil.
In der Windows Version kann man da klar den Unterschied zum neuen Stil erkennen.

Danke.

Der Loetkolben

photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.439
    • View Profile
Re: brickv 2.4.1 und IO16 Error
« Reply #3 on: April 04, 2019, 11:32:50 »
Welchen Desktop (Gnome, Mate, KDE, ...) verwendest du denn auf Debian 9? Normalerweise wählt Qt sich automatisch dem zum Desktop passenden Style aus.

Der Fusion Style ist an keinen speziellen Desktop gebunden. Das war auch einer der Gründe diesen als Option anzubieten.

Da wundert mich, das Qt den von selbst zu wählen scheint.

Loetkolben

  • Hero Member
  • *****
  • Posts: 1.178
    • View Profile
Re: brickv 2.4.1 und IO16 Error
« Reply #4 on: April 04, 2019, 14:35:52 »
Desktop? - So was kenne ich nur von Ubuntu CDs.  ;)

Ich nutze "openbox" als Windowmanager. Das war es schon.  ;D
"fbpanel" noch als Tool zum arangieren der Fenster. Schlicht, schnell unkompliziert.  ;)
Wobei aber durch die installierten Programme einige Gnome Pakete installiert worden sind.


Der Loetkolben

rtrbt

  • Tinkerforge Staff
  • Administrator
  • Jr. Member
  • *****
  • Posts: 80
    • View Profile
Re: brickv 2.4.1 und IO16 Error
« Reply #5 on: April 04, 2019, 15:26:40 »
Dann verwendet Qt bei dir vermutlich immer den Fusion Style. Der ist der Standard wenn Qt nicht sieht, dass du KDE oder etwas Gtk-basiertes laufen hast. (Siehe hier)