Author Topic: Compilefehler mit g++ 9.1.0  (Read 3212 times)

remotecontrol

  • Hero Member
  • *****
  • Posts: 591
    • View Profile
Compilefehler mit g++ 9.1.0
« on: August 04, 2019, 17:47:26 »
Hallo zusammen,

ich nutze ein Linux System mit Arch Linux, welches immer recht neue Pakete hat.
Jetzt wurde wohl auf g++ 9.1 aktualisiert und da bekomme ich folgenden Compile-Fehler:
Code: [Select]
bricklet_sound_pressure_level.cpp: In Funktion »void sound_pressure_level_callback_wrapper_spectrum_low_level(DevicePrivate*, Packet*)«:
bricklet_sound_pressure_level.cpp:320:129: Fehler: Zugriff auf die Adresse des gepackten Elements von »SpectrumLowLevel_Callback« führt möglicherweise zu einem nicht ausgerichteten Zeigerwert [-Werror=address-of-packed-member]
  320 |  sound_pressure_level_callback_wrapper_spectrum(device_p, callback->spectrum_length, callback->spectrum_chunk_offset, callback->spectrum_chunk_data);
      |                                                                                                                       ~~~~~~~~~~^~~~~~~~~~~~~~~~~~~
bricklet_sound_pressure_level.cpp:323:91: Fehler: Zugriff auf die Adresse des gepackten Elements von »SpectrumLowLevel_Callback« führt möglicherweise zu einem nicht ausgerichteten Zeigerwert [-Werror=address-of-packed-member]
  323 |   callback_function(callback->spectrum_length, callback->spectrum_chunk_offset, callback->spectrum_chunk_data, user_data);
      |                                                                                 ~~~~~~~~~~^~~~~~~~~~~~~~~~~~~
bricklet_sound_pressure_level.cpp:323:91: Fehler: Zugriff auf die Adresse des gepackten Elements von »SpectrumLowLevel_Callback« führt möglicherweise zu einem nicht ausgerichteten Zeigerwert [-Werror=address-of-packed-member]
[code]
Dabei ist [font=courier]callback->spectrum_chunk_data[/font] markiert.

Ich compiliere die Bindings als C++ (nicht rein C) mit den Optionen
g++ -c -std=c++11 -g  -Wall -Wignored-qualifiers -Wparentheses -Woverloaded-virtual -Wsign-compare -Werror

Hat bisher auch immer gut funktioniert, nun gerade nicht mehr.

So ganz klar ist mir nicht, warum der neue Compiler hier meckert:
der Header hat 8 Bytes, dann kommen 2x2 und dann der chunk_data, was zumindest zu einer auf 4 Bytes alignten Adresse führen müsste.

Nehme ich das -Werror raus, komme ich durch, intensiv testen konnte ich aber noch nicht. Nur wundert mich diese Warnung dennoch.
« Last Edit: August 04, 2019, 18:59:46 by remotecontrol »

rtrbt

  • Tinkerforge Staff
  • Administrator
  • Full Member
  • *****
  • Posts: 121
    • View Profile
Re: Compilefehler mit g++ 9.1.0
« Reply #1 on: August 05, 2019, 16:03:15 »
Moin,
Ich bin dem mal nachgegangen, das Problem ist nicht das Alignment innerhalb der Strukturen, sondern das der Strukturen selbst (also Packet, PacketHeader und den konkreten wie z.B. SpectrumLowLevel_Callback). Da sie als packed markiert sind, geht der Compiler (richtigerweise) davon aus, das sie nicht auf 4 Byte alignt sind und gibt die Warnung aus. Abgesehen davon gibt es tatsächlich Fälle, in denen die Paketstruktur so ist, dass Arrays an "krummen" Adressen liegen, z.B. beim RS232 Bricklet.

Das sauber für alle Compiler zu fixen dauert noch etwas, falls du auf x86 oder einer anderen Architektur, die unalignte Zugriffe unterstützt, unterwegs bist, kannst du die Warnung erstmal mit -Wno-address-of-packed-member unterdrücken. Ich melde mich sobald ich das repariert habe.

rtrbt

  • Tinkerforge Staff
  • Administrator
  • Full Member
  • *****
  • Posts: 121
    • View Profile
Re: Compilefehler mit g++ 9.1.0
« Reply #2 on: August 06, 2019, 11:01:22 »
War doch einfacher als gedacht. Habe dir die gefixte Version mal angehangen, bei mir gibt g++ 9.1 die Warnung nicht mehr aus.

remotecontrol

  • Hero Member
  • *****
  • Posts: 591
    • View Profile
Re: Compilefehler mit g++ 9.1.0
« Reply #3 on: August 06, 2019, 18:12:30 »
Compiliert wieder wie vorher - Danke!
Die Lösung sieht einfach aus.