Author Topic: IMU 2 - Messergebnisse passen nicht überein  (Read 1515 times)

jgmischke

  • Full Member
  • ***
  • Posts: 203
    • View Profile
IMU 2 - Messergebnisse passen nicht überein
« on: August 14, 2019, 15:12:43 »
Ich benutze das IMU 2 für eine Teleskopsteuerung.

Dabei habe ich folgendes Problem:

Anzeige des Gravitationsvektor mit dem brickv ( neueste Version )  :
Der Z-Ẃert ( Brick liegt fest auf dem flachen Tisch ) wackelt so zwischen 9.8X und 10.1X m/s hin und her.

Anzeige des gleichen Vektors in C, Ausgabe mit Curses:

Alle Daten verändern sich überhaupt NICHT. ( So wie man es jetzt auch erwarten würde). Schwankungen wenn überhaupt nur immer um +/- 1 der letzten Stelle. Z Achse also auf 980.

Woran liegen die Schwankungen im brickv
« Last Edit: August 14, 2019, 15:38:08 by jgmischke »

photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.467
    • View Profile
Re: IMU 2 - Messergebnisse passen nicht überein
« Reply #1 on: August 14, 2019, 15:44:55 »
Kann ich hier nicht nachstellen. Mein IMU Brick 2.0 hier auf dem Tisch, zeigt einen absolute stabilen Gravitiy Vector.

Hast du die aktuelle Firmware 2.0.14 auf dem Brick?

Hast du Brick Viewer und den C Programm gleichzeigt laufen und sieht da die Unterscheide in den Werten, oder lässt du die nacheinander laufen?

jgmischke

  • Full Member
  • ***
  • Posts: 203
    • View Profile
Re: IMU 2 - Messergebnisse passen nicht überein
« Reply #2 on: August 14, 2019, 15:51:44 »
Peinlich peinlich.

Wer lesen kann ist im Vorteil. Ich hab runtersrollen müssen, DA ist dann auch der Grav Vektor.

Und da wackelt NIX: Gewackelt hat get_acceleration, da aber eben auch unter beiden Programmen gleich.

Sorry!!!!

« Last Edit: August 14, 2019, 16:20:54 by jgmischke »