Author Topic: Red-Brick Mobile Internet  (Read 869 times)

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Red-Brick Mobile Internet
« on: August 18, 2019, 13:29:58 »
Hallo,
ich habe an den Red-Brick einen Surfstick von alcatel angeschlossen.
Alcatel IK40V 2AALDE1
LTE Kategorie:   LTE-Modem der Kategorie 4 (3GPP Release 8)
Downloadrate   bis 150 MBit/s
Uploadrate   bis 50 MBit/s
LTE 800, 900, 1800, 2100 und 2600 MHz
abwärtskompatibel zu:   HSDPA, HSUPA, UMTS, EDGE, GSM

Von meinem Provider "Simply" habe ich auch die nötigen Zugangsdaten erhalten.
Wenn ich nun den Stick anschließe, den Red-Brick über localhost mit dem Rechner verbinde, komme ich im Brickviewer auf das Menü Mobil Internet. Dorst steht allerdings bei Modem: No Modem available.

Das Heiß, der Red-Brick erkennt den Stick nicht, obwohl sich eine funktionierende SIM-Karte darin befindet.
Könnte mir jemand helfen, wie ich hier weiter machen kann?
Vielen Dank!



rtrbt

  • Tinkerforge Staff
  • Administrator
  • Full Member
  • *****
  • Posts: 112
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #1 on: August 19, 2019, 11:52:58 »
Moin,
Interessant wären die Ausgaben von lsusb und dmesg. Da gerade dmesg auf der seriellen Konsole des RED-Bricks sehr unübersichtlich ist, kannst du die Ausgabe mit
Code: [Select]
dmesg | tail -n 30 filtern.

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #2 on: August 19, 2019, 19:45:41 »
Hallo,
also das Ergebnis von dmesg ist: s. Attachment.
Ich vermute hier fehlt der Treiber für den alcatel-Surfstick.

photron

  • Tinkerforge Staff
  • Administrator
  • Hero Member
  • *****
  • Posts: 2.467
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #3 on: August 19, 2019, 20:18:26 »
Führ den gleichen Test mit "dmesg | tail -n 30" bitte noch mal durch, ohne das dabei der Stick angeschlossen ist.

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #4 on: August 20, 2019, 19:41:38 »
hallo,
also nun habe ich den Befehl "dmesg | tail -n 30" an der Red-Brick Console eingegeben, wobei der Stick nicht angeschlossen war. Das Ergebnis sieht so aus:

[   18.534611] nuke: ep num is 0                                               
[   20.741231] Warning: this sunxi disp driver will see significant redesign.   
[   20.741251] Applications using /dev/disp directly will break.               
[   20.741259] For more information visit: http://linux-sunxi.org/Sunxi_disp_dri
ver                                                                             
[   20.741322] [DISP] layer allocated: 0,101                                   
[   60.250019] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   60.250039] nuke: ep num is 0                                               
[   61.467978] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   61.467998] nuke: ep num is 0                                               
[   89.093673] WRN:L1355(drivers/usb/sunxi_usb/udc/sw_udc.c):handle_ep0: ep0 set
up end                                                                         
[   89.093692] nuke: ep num is 0                                               
tf@red-brick:~$                         

rtrbt

  • Tinkerforge Staff
  • Administrator
  • Full Member
  • *****
  • Posts: 112
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #5 on: August 21, 2019, 11:10:24 »
Moin,
Wenn du den Stick angeschlossen hast, tauchen die ganzen USB-Resets auf. Du kannst mit lsusb (poste mal die Ausgabe davon) mal nachprüfen ob das wirklich der Stick ist, Bus 0X Device 01 sollte der entsprechende Hub-Chip sein, Bus 0X Device 0Y dann der Stick. In den Resetmeldungen siehst du dann "usb X-1:" das ist der Hub und dahinter "USB device number Y", die sollte der aus lsusb entsprechen.

Da die Resets vermutlich an den Stick geschickt werden: Wie ist dein Aufbau insgesamt? Wie versorgst du ihn mit Strom? Welche Image-Version hast du auf dem RED-Brick?

Vermutlich ist das (noch) kein Treiberproblem, da das USB-Device ansich ja nicht korrekt auftaucht. Der Treiber würde erst im nächsten Schritt geladen werden.

Backdraft007

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #6 on: August 21, 2019, 14:12:28 »
Schau mal mit dem Brick Viewer auf den RED unter Settings->Network, ob es dort bei Interfaces eins gibt, ala ??? : wired.
Dann einfach mal auf Connect klicken.

Mein Huawei Stick wird auch nicht als Mobiles Modem erkannt, sondern als normales Netzwerk-Interface.

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #7 on: August 21, 2019, 14:42:54 »
Hallo,
Sorry, der Befehl Isusb wir an der Console nicht erkannt. Ich habe für die Verbindung zum Stick
die COM 22 Schnittstelle des Red-Brick ausgewählt. Ein Abbild der Console bzw. der Program-Versionen befindet sich im Anhang.

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #8 on: August 21, 2019, 14:44:06 »
und noch 2 Anhänge

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #9 on: August 21, 2019, 14:46:01 »
und noch eein Anhang

rtrbt

  • Tinkerforge Staff
  • Administrator
  • Full Member
  • *****
  • Posts: 112
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #10 on: August 21, 2019, 14:52:56 »
Der Befehl heißt lsusb mit kleinem L nicht großem i. Abgesehen davon solltest du dein Image mal auf 1.14 aktualisieren (oder zumindest damit mal testen).

Backdraft007

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #11 on: August 21, 2019, 19:14:58 »
Definitiv erstmal das Image aktualisieren. Da gab es viel Änderungen seit der 1.8.

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #12 on: August 21, 2019, 21:58:53 »
Hallo,
erstmal vielen Dank für euere schnelle Unterstützung. Das Red-Brick-Image
"red_image_1_14_full.img" habe ich herunter geladen, aber wie bringe ich das jetzt auf den Red-Brick?

rtrbt

  • Tinkerforge Staff
  • Administrator
  • Full Member
  • *****
  • Posts: 112
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #13 on: August 22, 2019, 10:24:55 »
Am einfachsten mit Etcher, hier wird erklärt wie das geht. Damit wird allerdings alles auf der Micro-SD-Karte überschrieben, d.h. du solltest ein Backup von Daten, die du auf dem alten Image geändert hast, ziehen, oder alternativ eine andere Micro-SD-Karte benutzen.

Tracker

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Red-Brick Mobile Internet
« Reply #14 on: August 24, 2019, 22:15:00 »
Hallo,
die neue Imageversion 1.14 habe ich inzwischen installiert. Ich erhalte aber immer noch die Meldung "No Modem available". Das Ergebnis vo lsusb ist:
lsusb                                                               
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub     
Bus 001 Device 003: ID 1bbb:0195 T & A Mobile Phones               
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub     
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub     
tf@red-brick:~$
Hmmm, damit kann ich jetzt nicht sehr anfangen.               
Übrigens, die Verdindung zum WLAN-Router funktioniert.