Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Loetkolben

Pages: [1] 2 3 ... 13
1
Hallo zusammen,

das Update vom Brickviewer 2.4.4 auf 2.4.6 erforderte 2 weitere Pakete:

Quote
brickv hängt ab von python3-tz; aber:
  Paket python3-tz ist nicht installiert.
 brickv hängt ab von python3-tzlocal; aber:
  Paket python3-tzlocal ist nicht installiert.

Das ist kein Problem.  :D

Nochmals meine Bitte: Ich wuensche mir im Brickviwer einen Downloadmechanismus auf die aktuelle Version. Den generic Link mit "...latest.deb" kann ich mir nicht merken und immer erst den Browser auf den Remotemaschinen hochzufahren ist nicht immer moeglich.


BTW: Habe ich noch einen Bug gefunden? Siehe Screenshot.

Wenn man ohne Connect auf "Search for Updates" clickt kommt ein endloses "Discovering".


Der Loetkolben

2
Wie hier angekuendigt wollte ich fragen wann ungefaehr das Image 1.14 erscheint?


Der Loetkolben

3
Beim click auf die IO16 Lasche kommt das


Code: [Select]
Traceback (most recent call last):
  File "/usr/share/brickv/async_call.py", line 68, in async_event_handler
    function()
  File "/usr/share/brickv/plugin_system/plugins/io16/io16.py", line 125, in get_monoflop_async
    next(self.init_async_generator)
  File "/usr/share/brickv/plugin_system/plugins/io16/io16.py", line 148, in init_async
    self.init_values(port, self.init_value, self.init_dir, self.init_config, time, time_remaining)
  File "/usr/share/brickv/plugin_system/plugins/io16/io16.py", line 177, in init_values
    if dir & (1 << i):
TypeError: unsupported operand type(s) for &: 'builtin_function_or_method' and 'int'


Der Loetkolben

4
Hallo zusammen,

habe hier 2 Geraete die mit der Sonoff Bridge zusammenarbeiten.

Gerne wuerde ich den Bewegungssensor und die Wandtaster mit dem Remote Switch Bricklet 2.0 empfangen. Da tut sich aber gar nichts.

Kann jemand bitte weiterhelfen.

Danke

Der Loetkolben

5
Hardware / Air Quality Bricklet (Accuracy: low) springen die Werte.
« on: February 26, 2019, 18:28:57 »
Hallo zusammen,

habe gestern mein Air Quality Bricklet in Betrieb genommen. FW war schon aktuell.
Die Anzeige "Accuracy: low" ist dementsprechend zu erwarten.
Meine Frage ist aber: Wie stark darf der Wert denn springen.

Es liegt also auf meinem Schreibtisch. Nichtraucher und Abends sind die Fenster zu.

Start IAQ Index:
Werte beginnen um die 20,
nach 10 Minuten gehen sie auf 0 und bleiben dort fuer lange Zeit. Ich denke mir, dass meine Luft ja perfekt ist.  ;D
Irgendwann huepfen sie in die Region um die 40. Na gut.

Dann kommt die Nacht, der PC und der Stack laufen weiter.
Heute morgen pendeln die Werte um die 100.
Ich denke mir ein Lueften kann helfen. Und siehe da die Werte steigen auf um die 150:o ::)
Genau die andere Richtung als erwartet.

Ist das alles normal bei "Accuracy: low"?
Ich habe je erwartet, dass die Werte springen, aber dass in einem geschlossenen Raum ueberhaupt "0" angezeigt wird und beim Lueften die Werte hochschnellen verstehe ich ueberhaupt nicht. Wie funktioniert das Ding? ::)


Der Loetkolben

6
Hardware / Wo bekommt man RGBWW (Warm White) Panels?
« on: February 26, 2019, 17:43:29 »
Hallo zusammen,

ich bin auf der Suche nach RGBWW (Warm White) Panels.
Reine RGB Panels bekommt man ueberall, aber wo bekommt man so was mit eben RGBWW LEDs? (Mit weisser Platine (PCB) waere es noch idealer)

Ha da jemand eine Idee/Info?

Der Loetkolben

7
Allgemeine Diskussionen / Haltbarkeit Cookies fuer den Warenkorb?
« on: February 21, 2019, 14:09:58 »
Hallo Tinkerforgeteam,

wie lange wird eigentlich der Warenkorb erhalten, wenn nichts mehr hinzugefuegt wird? Ich hatte einen Warenkorb zusammengestellt und wollte einige! Zeit spaeter noch etwas hinzufuegen und er war dann leer.

Wie lange halten die Cokies und wenn das Problem nicht bei mir liegt warum kann man die nicht 12h Stunden halten?

Viele Gruesse

Der Loetkolben

8
Hardware / Alternativen zu Temperatur/Luftfeuchte Sensor TH-6148?
« on: February 21, 2019, 14:03:52 »
Hallo zusammen,

gibt es Alternativen zum Temperatur/Luftfeuchte Sensor TH-6148?

Z.B. mit mehr WAF fuers Wohnzimmer oder mit fester ID (z.B. per DIP Schalter) oder fuer rauhere Umgebungen (ohne Display und mit Dichtung)?

Wuerde mich ueber kompatible Infos freuen.  :D


Der Loetkolben

9
Hallo zusammen,

ist es moeglich durch (Auto-)Scheiben mit dem Distance IR Brickelt zu messen?

Kommen da ueberhaupt irgendwelche vernueftigen Werte zurueck?
Wie sieht das bei Tag/Nacht/Sonneneinstrahlung/Winkel zur Scheibe aus?

Viele Gruesse

Der Loetkolben

10
Hardware / Nutzung von "XMC14XX48" und "XMC11XX24"?
« on: February 19, 2019, 15:31:12 »
Hallo zusammen,

warum werden die beiden Unterschiedlichen "Zwischenprozessoren" genutzt?

Wenn ich das richtig gesehen habe werden bei den beiden Prozessoren "XMC14XX48" und "XMC11XX24" die gleiche Anzahl/Funktion an Pins benutzt? Warum dann der unterschiedliche Einsatz?


Der Loetkolben

11
Hallo zusammen,

was fuer einen Unterschied/Vorteil gibt es zwischen dem "Air Quality Bricklet" und den einzelnen Bricklets "Barometer Bricklet 2.0", "Humidity Bricklet 2.0" und "Temperature Bricklet 2.0"?

Wenn wir mal Preis und Anzahl der Steckverbindungen aussen vor lassen ist es nicht so einfach die Bricklets zu vergleichen. Gerade beim "geringen" Preisunterschied vom "Air Quality Bricklet" zum "Barometer Bricklet 2.0" stellt sich die Frage warum dieses Einzelbricklet gibt und was daran dann so gut sein muss.

Ich tue mich schwer zu entscheiden was denn das richtige Bricklet fuer mein Projekt ist.
Ein wenig mehr Entscheidungshilfen, sei es durch vergleichbare Datenangaben oder kurze Erlaeuterungen, waeren fuer die Brickletauswahl in diesem Bereich sehr hilfreich. (Beim einem IO-Bricklet ist das einfacher.  ;D )

Waere da fuer eine Info/Hilfe/FAQ sehr dankbar  :D

Ich glaube es waere fuer uns nicht zielfuehrend sich in die letzten Bits des Handbuch zu quaelen, welches man nur versteht, wenn man Wetterkunde studiert hat.

Mal so ein paar Fragen die sofort beim Vergleich ins Auge stechen:

Luftdruckbereich:
Air Quality Bricklet: ?
Barometer Bricklet 2.0: 260 - 1260mbar


Genauigkeit:
Air Quality Bricklet: ±0,12mbar (700-900mbar bei 25-40°C), ±0,6mbar (gesamter Messbereich)
Barometer Bricklet 2.0:
Genauigkeit (0-65°C vor OPC)    ± 1,1mbar
Genauigkeit (0-65°C nach OPC)    ± 0,2mbar

Was ist OPC?

Auflösung:
Air Quality Bricklet: 0,0018mbar
Barometer Bricklet 2.0: 0,0075mbar / 6,25cm

Was bedeuten hier die "6,25cm"

Features:
Humidity Bricklet 2.0: Der Sensor kompensiert die gemessene Luftfeuchtigkeit intern mit dem Temperatursensor. Ein per API schaltbares Heizelement, welches direkt im Sensor integriert ist, kann dazu genutzt werden um bei extremer Feuchtigkeit den Sensor zu trocknen.

Hat das Air Quality Bricklet auch so eine Kompensation?
Wie viel verbessert dies den Wert?
Hat schon mal jemand diese beiden Bricklets nebeneinander liegend ausgewertet?
Wenn ich heize, wird doch aber die Temperatur verfaelscht?


Ich glaube das bei weiterem Vergleich noch weitere Fragen zu den unterschiedlichen Bricklets auftauchen.

Der Loetkolben

12
Allgemeine Diskussionen / Embedded World 2019 26.-28. Februar 2019
« on: November 08, 2018, 14:57:39 »
Hallo zusammen,

gleiche Stelle, gleiche Welle. :-)
Auch dieses mal wieder der Hinweis auf die embedded-world 2019 wo man sich zusaetzliche Ideen fuer die Tinkerforge Anbindung holen kann.

Es gibt fuer Besucher eine /interessante/ Seite: Diese hier:-X  Wer es breit tritt wird mit Arduino 1.0 bestraft.

Weiter mit Werbung fuer diejenigen die weiter weg wohnen:
Die Deutsche Bahn hat vor ein paar Tagen wirklich viele guenstige Tickets auf den Markt gebracht: 1 Million Extra-Tickets: Super Sparpreis ab 19,90 Euro. Es gibt wirklich viele!
Edit: Ende der Aktion war 21.11.2018

So nun Schluss mit der Werbung. Laufen ist teurer! Vielleicht sieht man sich ja dort.  ;D


Der Loetkolben

13
Hallo zusammen,

ein Debian Upgrade von 9.4 auf 9.5 am 26.7.2018 auf ein frisch aufgespieltes RED-Brick Image 1.12 war nicht erfolgreich. Anbei die Anleitung in welcher Reichenfolge man das Upgrade hinbekommt.

Wuerde mich ueber ein Feedback freuen.

Danke

Der Loetkolben


Code: [Select]
apt-get update

#  Debian von 9.4 auf 9.5
apt-get upgrade

Downloading of Packages
...
Preconfiguring packages ...
(Reading database ... 204167 files and directories currently installed.)
Preparing to unpack .../base-files_9.9+deb9u5_armhf.deb ...
Unpacking base-files (9.9+deb9u5) over (9.9+deb9u4) ...
Setting up base-files (9.9+deb9u5) ...
Installing new version of config file /etc/debian_version ...
(Reading database ... 204167 files and directories currently installed.)
Preparing to unpack .../dpkg_1.18.25_armhf.deb ...
Unpacking dpkg (1.18.25) over (1.18.24) ...
Setting up dpkg (1.18.25) ...
(Reading database ... 204167 files and directories currently installed.)
Preparing to unpack .../libperl5.24_5.24.1-3+deb9u4_armhf.deb ...
Unpacking libperl5.24:armhf (5.24.1-3+deb9u4) over (5.24.1-3+deb9u3) ...
Preparing to unpack .../perl_5.24.1-3+deb9u4_armhf.deb ...
Unpacking perl (5.24.1-3+deb9u4) over (5.24.1-3+deb9u3) ...
dpkg: error processing archive /var/cache/apt/archives/perl_5.24.1-3+deb9u4_armhf.deb (--unpack):
 trying to overwrite '/usr/bin/perldoc', which is also in package perl-doc 5.24.1-3+deb9u3
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../perl-base_5.24.1-3+deb9u4_armhf.deb ...
Unpacking perl-base (5.24.1-3+deb9u4) over (5.24.1-3+deb9u3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/perl_5.24.1-3+deb9u4_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


# Zur "Kontrolle" nochmals ein "Upgrade"
apt-get upgrade

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libperl5.24 : Depends: perl-modules-5.24 (>= 5.24.1-3+deb9u4) but 5.24.1-3+deb9u3 is installed
 perl : Depends: perl-base (= 5.24.1-3+deb9u3) but 5.24.1-3+deb9u4 is installed
        Depends: libperl5.24 (= 5.24.1-3+deb9u3) but 5.24.1-3+deb9u4 is installed
        Recommends: rename but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


# Ein reines 'apt --fix-broken install' bringt keine Loesung. Warum das so ist, kann vielleicht ein Debian Paketmanager sagen.
# Vor dem 'apt --fix-broken install' muss man aber einige Pakete von Hand installieren. Die sind aber schon da.

cd /var/cache/apt/archives/

dpkg -i perl-base_5.24.1-3+deb9u4_armhf.deb
dpkg -i perl-modules-5.24_5.24.1-3+deb9u4_all.deb
dpkg -i perl-base_5.24.1-3+deb9u4_armhf.deb
dpkg -i perl-doc_5.24.1-3+deb9u4_all.deb

apt --fix-broken install
apt-get upgrade


# Fertig!


#  Das "recommended" Paket "rename" habe ich nicht installiert. Saehe so aus:
## wget "http://ftp.de.debian.org/debian/pool/main/r/rename/rename_0.20-4_all.deb"
## dpkg -i rename_0.20-4_all.deb

14
Hallo zusammen,

ich bin mir nicht sicher ob ich schon mal angesprochen hatte, aber ich haette gerne einen Downloadlink im Brickviewer, wenn eine neue Version vorhanden ist.

Ich arbeitet auf Linux Systemen wo teilweise kein Browser installiert ist.

Das downloaden geht dann so:
- Linux Brickviewer meldet "Update verfuegbar"
- Windows PC Browser anschmeissen und download Seite aufrufen.
- Per Copy&Paste den Link auf die Linux Maschine uebertragen und
- per wget die Datei runterladen.
- Dann installieren.



Das installieren muss ja nicht automatisch sein, aber wenigstens der Download.

Natuerlich waere es schoen, wenn nicht die "latest" Datei geholt wird, sondern die Datei die den richtigen Versionsnamen hat. Aber ein Generic Link auf die "latest" Datei waere schon mal ein Anfang.

Danke.

Der Loetkolben.

15
Hallo zusammen,

ist das jetzt Werbung die ich hier mache? Ich denke nicht so ganz.  ;D

Zwei Dinge: Zum einen die Frage ob das Tinkerforgeteam ggf. vor Ort ist?
Zum anderen gibt es fuer Besucher eine /interessante/ Seite: Diese hier:-X  Wer es breit tritt wird mit Arduino 1.0 bestraft.


Der Loetkolben

Pages: [1] 2 3 ... 13