Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Equinox

Pages: [1] 2 3 ... 18
1
Hardware / Re: Problem mit LCD 128x64 Bricklet (Touch)
« on: March 18, 2019, 13:11:33 »
Quote
Ich würde erwarten dass das Bricklet dann vielleicht irgendwelche Klicks sieht die gar nicht da sind o.ä.?

Das ist auch meine Vermutung. Allerdings habe ich im Moment in den Callbacks keine Log-Nachrichten eingebaut :( Wären vmtl. auch zuviele ...

2
Hardware / Problem mit LCD 128x64 Bricklet (Touch)
« on: March 15, 2019, 21:36:31 »
Hallo,

ich benutze das "LCD 128x64 Bricklet" mit mehreren Tabs. Es kommt bei mir ab und zu vor, dass sich das Display nach einem Tab-Wechsel pausenlos "refreshed", und zwar mit unterschiedlichen Tabs. Es reagiert dann auf keine Berührung mehr. Es sieht so aus, als ob man sehr schnell zwischen den Tabs wechseln würde. Meistens fängt es sich auch nicht mehr.
Kann es sein, dass das Bricklet da ein Eigenleben entwickelt und ständig irgendwelche Events für einen Tab-Wechsel sendet?
Zuerst dachte ich, dass sich da mein Programm irgendwie verhaspelt (was ich auch jetzt noch nicht ausschließen kann) und habe es neu gestartet. Heute habe ich aber das Programm laufen lassen und habe nur den Stapel kurz vom Strom getrennt. Danach war alles wieder gut. Ich denke deshalb, dass es nicht an meinem Programm liegt, da es sich sonst auch nach dem Neustart des Stapels noch in dem "verhaspelt"-Zustand befunden hätte.
Hat sonst noch jemand dieses Problem? An was kann das liegen und was kann ich dagegen tun?

P.S.: Die Variable, welches Tab gerade selektiert ist, setze ich nur in den Callbacks "guiTabSelected" und "guiButtonPressed" und die Methode zum aktualisieren des Displays wird auch nur mit dieser Variablen aufgerufen. Ich vermute deshalb, dass der Callback "guiTabSelected" ständig mit unterschiedlichen Tabs aufgerufen wird, auch wenn gar kein Berührung vorliegt.

3
Ich fürchte, ich muss meine Theorie/Interpretation revidieren  :(
Im Moment habe ich 10.81°C, 50.5% rel. Luftfeuchtigkeit und der IAQ Index ist 43.
Schade, jetzt bin ich wieder ziemlich ratlos  >:(

4
Ganz einfach: Das Bricklet ist auf Entzug  ;D
Wie? Kein Alkohol? Das können keine guten Bedingungen sein!  ;)

5
Kann ich machen, komme aber frühestens am Wochenende dazu.
Aber vielleicht fehlen deinem Sensor einfach nur ein paar Reize? Anders gesagt: Kann es sein, dass bei dir die Bedingungen einfach zu konstant sind?
Hast du schon einmal versucht, den Sensor für eine halbe Stunde vors Fenster zu hängen? Dann wieder rein und 2 Stunden später vielleicht wieder raus?
Wenn ich borg richtig verstanden habe, dann braucht der Sensor möglichst unterschiedliche Werte, damit er sich kalibrieren kann.

6
Ich war tatsächlich mit dem Wert 249 unzufrieden (im Sinne von "der ist völlig falsch"), weil ich den Wert als 'Luftqualität' interpretiert habe. Da der Sensor bei mir im Wintergarten ist, gehe ich davon aus, dass die Luftqualität (im Sinne der VOCs) wegen der Pflanzen dort sehr gut ist. In die Berechnung gehen aber nicht nur die VOCs ein (wäre für mich vmtl. geeigneter), sondern eben auch Temperatur und rel. Luftfeuchtigkeit.
Wenn ich den Wert aber als 'Arbeitsklima' in einem Büro interpretiere, dann ist der Wert durchaus einigermaßen nachvollziehbar bzw. plausibel. Zum Zeitpunkt, als 249 angezeigt wurde, waren tatsächlich ca. 10°C und 80% rel. Luftfeuchtigkeit (und vmtl. keine VOCs). Für einen Büroraum sind das schon schlechte Werte (unter diesen Bedingungen möchte ich zumindest nicht in einem Büro arbeiten).
Bez. "Accuracy": Ich habe am Freitag die 2.0.4 installiert. Danach war das Verhalten genau wie von borg beschrieben. Es hat mit 25 angefangen bei "Unreliable" und wurde dann besser. Seit spätestens Sonntag Mittag habe ich "high".

7
Hallo Loetkolben,

du meinst das Foto mit Marilyn Monroe?
Das würde doch zu meiner Interpretation ungefähr passen:
Bei 25°C, einer rel. Luftfeuchtigkeit von 20% und keine VOCs ergibt das einen IAQ  Index von geschätzt 40. Ich hätte ihn da zwar auch höher vermutet, aber grundsätzlich sind das doch keine schlechten Arbeitsbedingungen, oder?

8
Hallo,

nach etwas Forschen interpretiere ich den IAQ Index so:
Wichtig ist das 'I' in IAQ. Wobei ich das nicht nur als 'Indoor' sehe, sondern genauer als 'Büroarbeitsplatz'. Sprich: Der Index gibt an, wie gut die Bedingungen für die Arbeit in einem Büro sind. Dabei wird von bestimmten Idealwerten ausgegangen, z. B. 40% oder 50% rel. Luftfeuchtigkeit. Je stärker ein Wert vom Idealwert abweicht, umso schlechter wird der IAQ Index.
Wenn jetzt z. B. die VOCs OK sind, aber es werden 80% rel. Luftfeuchtigkeit bei 10°C gemessen, dann sind das keine guten Bedingungen für eine Arbeit im Büro und der IAQ Index ist entsprechend schlecht.
Zumindest scheinen für die bei mir mit der 2.0.4 berechneten Werte für den IAQ Index mit dieser Interpretation einigermaßen sinnvoll zu sein.

9
Hallo,

erstes kurzes Zwischenergebnis mit der 2.0.4:
Beim IAQ Index habe ich jetzt keine Sprünge oder Ausreißer mehr. Die Kurve sieht gut aus.
Allerdings verstehe ich die Werte immer noch nicht  :( Im Moment habe ich einen IAQ Index von 249 bei "Accuracy High". Schade dass Bosch nicht veröffentlicht, wie sie den berechnen.

10
Allgemeine Diskussionen / Re: die gegenwart. bzw.: die zukunft ...
« on: March 09, 2019, 17:38:47 »
Hallo,

Quote
man muss sich abmühen, wenn man tinkerforge-hw verwendet

Seltsam ist, dass nur du dieses Problem hast.
Die meisten anderen, inkl. mir, kommen sehr gut damit zurecht.

Quote
schert sowieso keinen, was oder worauf ich hinauswill.

Stimmt.
Das liegt aber vor allem daran, dass dein Gejammer einfach völlig unverständlich, weil auch uNLesBAr, ist. Beachtung der Groß- und Kleinschreibung wäre ein erster Schritt. Und dann, wie borg schon sagte, solltest du deine Gedanken mal sortieren und auf den Punkt bringen.

11
Hallo,

Quote
Ich hab jetzt erst eine Firmware (2.0.4) gebaut welche die automatische Kalibrierung nicht alle 12 Stunden speichert oder diese beim Neustart lädt.

Empfiehlst du, gleich auf die 2.0.4 umzusteigen oder mal die 28 Tage Kalibrierungszeit der 2.0.3 abzuwarten?

12
Allgemeine Diskussionen / Re: die gegenwart. bzw.: die zukunft ...
« on: March 06, 2019, 15:21:10 »
Hallo,

Quote
für mich sind diese fragen wirklich essentiell.
vielleicht auch für andere, wenngleich ich befürchte, eher nein.

Korrekt. Völlig unerheblich.
Außerdem kann ich Leute nicht ernst nehmen, die sich über schlechtes Design usw. beschweren aber die Groß- und Kleinschreibung ignorieren.

13
Hallo,

die Genauigkeiten sind so definiert:
Code: [Select]
    BrickletAirQuality.ACCURACY_UNRELIABLE = 0
    BrickletAirQuality.ACCURACY_LOW = 1
    BrickletAirQuality.ACCURACY_MEDIUM = 2
    BrickletAirQuality.ACCURACY_HIGH = 3

Wenn du erst jetzt auf Version 2.0.3 umgestellt hast, dann ist das Verhalten nach dem Update aus meiner Sicht erklärbar bzw. normal. Erst ab dieser Version ist '28 Tage' möglich und der Default:
Quote
Seit Firmware-Version 2.0.3 nutzt die automatische Hintergrundkalibrierung Daten der letzten 28 Tage. Wir empfehlen daher das Bricklet für 28 volle Tage laufen zu lassen bevor die Werte als vollständig zuverlässig angesehen werden können.
Damit völlig neu kalibriert wird, muss das Bricklet danach vom Strom getrennt werden.
Ich warte mal die 28 Tage ab und schau dann, was es für Werte liefert.

14
Hallo,

die Funktionsweise ist mir auch völlig schleierhaft.
Ich habe das Bricklet bei mir im Wintergarten installiert und dachte auch, dass dort die Luft wegen der vielen Pflanzen ja perfekt sein müsste.
Aktuell zeigt es einen Wert von 210 an, bei einer Luftfeuchtigkeit von 54% und einer Temperatur von 18°C, wobei die "Accuracy" "high" ist. Schwankungen auf unter 20 und über 250 kann ich aber durchaus feststellen.
Bei solchen Bedingungen erwarte ich allerdings auch Werte von deutlich unter 100.

15
Hallo,

Quote
Das Update der Firmware hat jetzt funktioniert, aber das Air Quality Bricklet wird noch immer an Position "Z" angezeigt.
Quote
Der Bug dort liegt im Bootloader des Air Quality Bricklets, da kann der Brick Viewer leider nichts gegen machen.
Auch in der Firmware 2.0.3?
Nach ein paar Connects/Disconnects habe ich festgestellt, dass es manchmal auch korrekt angezeigt wird. Meistens aber an Position "Z".

Pages: [1] 2 3 ... 18