Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - FlyingDoc

Pages: [1] 2 3 ... 31
1
Der erste Versuch und ein Volltreffer. ;D

Mit
Code: [Select]
sc config "Brick Daemon" depend=tcpip funktioniert es.

2
Bei jedem Systemstart tritt der Fehler auf.

3
Hallo TF Team.
Ich wollte es schon ewig melden, habe es aber lange verpasst, da ich arbeitsmäßig und familiär ziemlich gebunden bin im Moment.
Bei meinem Laptop habe ich folgendes Phänomen.
Beim Start von Win 10 kann der Daemon keine Verbindung aufbauen.
Ich habe heute mal in die Log geschaut warum und  habe folgendes gefunden.

Code: [Select]
2019-08-22 21:51:08.044366 <E> <event_winapi.c:228> Could not write to USB ready pipe: WSAECONNABORTED (71010053)
2019-08-22 21:52:09.341898 <I> <log_winapi.c:173> Log Viewer connected to info pipe
2019-08-22 21:52:23.436638 <E> <event_winapi.c:261> Could not read from USB ready pipe: WSAECONNRESET (71010054)

Die Verbindung funktioniert erst, wenn ich den Daemon Dienst neu starte.

Code: [Select]
2019-08-22 21:53:48.196921 <I> <main_winapi.c:209> Received stop command
2019-08-22 21:53:48.196922 <E> <event_winapi.c:261> Could not read from USB ready pipe: WSAECONNRESET (71010054)
2019-08-22 21:53:48.197252 <E> <event_winapi.c:261> Could not read from USB ready pipe: WSAECONNRESET (71010054)
2019-08-22 21:53:48.197274 <E> <event_winapi.c:261> Could not read from USB ready pipe: WSAECONNRESET (71010054)
2019-08-22 21:53:48.197308 <E> <event_winapi.c:261> Could not read from USB ready pipe: WSAECONNRESET (71010054)
2019-08-22 21:53:48.200701 <I> <main_winapi.c:489> Brick Daemon 2.4.0 stopped
2019-08-22 21:53:49.534941 <I> <main_winapi.c:376> Brick Daemon 2.4.0 started (as service)
2019-08-22 21:53:49.555603 <I> <libusb:winusbx_init> libusbK DLL is not available, will use native WinUSB
2019-08-22 21:53:49.556743 <I> <libusb:windows_init> UsbDk backend is not available
2019-08-22 21:53:49.596024 <I> <usb.c:194> Added USB device (bus: 1, device: 4) at index 0: IMU Brick 2.0 [6wVmVp]
2019-08-22 21:53:49.941343 <I> <log_winapi.c:173> Log Viewer connected to info pipe

Ich vermute mal, das mein Rechner einfach zu schnell startet und etwas noch nicht geladen ist was der Daemon beim USB benötigt.

Vom Start bis zum Login Screen sind es rund 10 Sekunden.
Vielleicht kann man das Problem ja beheben in dem man vor dem Verbindungsversuch testet ob die benötigte Treiberkomponente schon im Windows geladen ist. :o

P.s.
Könntet iht die Länge des Logfile begrenzen. Mir hat der Daemon meine Platte mit dem Logfile völlig vollgeschrieben.
Also alles wenn eine bestimmte Größe erreicht ist die ältesten Beiträge abschneiden.
Das waren dann mehrere GByte. ( Kein Scherz)
Und da hatte ich nur eine 256 GByte Systemplatte.
Jetzt 1 TByte. ;D
Er Protokolliert ja alles. Und wenn jede Sekunde ein Fehlereintrag kommt geht das ratz fatz. ;D
Ich habe mich gewundert warum meine Systemplatte irgend wann bis auf das letzte Byte gefüllt war.
Da schliesst man ja nicht sofort drauf.

4
Hardware / Re: Ethernet-Brick funktioniert nicht mit Red Brick
« on: May 15, 2019, 12:04:43 »
Erstens muß die Ethernet Extension direkt auf den Red Brick.
Zweitens findest du die Extension dann nicht in dieser Liste , sondern direkt beim Red Brick Reiter unter Settings im Reiter Network. ;)

5
Allgemeine Diskussionen / Re: parallele Verbindungen zum Brick
« on: February 16, 2019, 20:59:50 »
Nein. Du kannst mehrere gleichzeitig verbinden.
Alle Clienten erhalten dann auch das gleiche Callback wenn es configuriert ist.

6
Anfängerfragen und FAQ / Re: Update des Red Brick hängt immer
« on: February 03, 2019, 20:42:50 »
WIelange hast du denn gewartet. Es dauert wirklich eine gefühlte Ewigkeit bis es durch ist.

7
Anfängerfragen und FAQ / Re: Start RED Brick
« on: January 19, 2019, 19:59:14 »
Das das Feld auf Disconnect wechselt hat noch nichts mit der Verbindung zum RED zu tun.
Das bedeutet einfach nur das du zum lokalem Brickdemaon Verbindung hast.

So. Weiter.

1. Hast du im Red schon die SD Karte mit dem IMG ( also quasi die Festplatte mit Betriebssystem)
2. Wenn der RED an ist, müsste die Grüne LED auf dem RED blinken.
Das zeigt an das dir Deamon auf dem RED läuft. Sonst siehst du ihn nicht im Brick Viewer!
Auch wenn der RED läuft.

8
Ich habe wie du empfohlen hast den 2.3.0 installiert.
Jetzt funktioneren die Callback wieder.

Danke. 8)

9
Ich arbeite gerade an beiden Varianten.
Mit neuem Image (da muß ich aber noch viel anpassen) und mit dem Versuch den Daemon zu aktualisieren.

Dabei kommt folgender Fehler.
Quote
2019-01-14 17:33:21.309458 <I> <main_linux.c:291> Brick Daemon 2.3.2+redbrick started (pid: 2023, daemonized: 0)
brickd: symbol lookup error: brickd: undefined symbol: libusb_free_pollfds

Ich habe den Daemon nach eurer Anleitung mit
Quote
# On RED Brick
wget http://download.tinkerforge.com/tools/brickd/linux/brickd_linux_latest+redbrick_armhf.deb
sudo dpkg -i brickd_linux_latest+redbrick_armhf.deb

aktualisisert. Der Daemon startet aber wie schon beschrieben nicht.

10
So. Nach dem ich Zeit zum Testen hab, die Italiener haben gerade bei uns das gesamte Netzwerk im Betrieb geändert, habe ich festgestellt, das es an der RED Img Version liegt. Beim 1.8er gehen die Callback nicht.

11
Habe gerade festgestellt , das wenn ich das Bricklet an einen einzelnen Master stecke, geht alles.
Da muss ich den Stapel mal auseinander nehmen und einzeln testen.

12
Hab ich gerade getestet. Kein Erfolg. Auch ein andere Anschluß geht nicht.
Und die Pins sind alle OK.

13
Hallo TF Team.
Erst einmal ein gesundes und erfolgreiches Jahr 2019!

Ich habe folgendes Problem.
Ich hab die IDI4 V2 in mein Programm eingebunden und bekomme den Callback nicht zum laufen.
Ich benutze die aktuellen Bindings. DIe Firmware ist auch aktuell.
Fehler werden nicht produziert.
Der Callback wird aber nicht ausgelöst.

Ich habe dann den IDI im BrickViewer V2.3.16 angeschaut.
Dort werden die Eingänge ebenfalls nicht angezeigt!
Egal welchen Zustand sie haben. Die Eingangs LED der DI zeigen aber den jeweiligen Zustand korrekt an.
Was mache ich falsch?

Das Programm ist in C++ geschrieben.


14
Allgemeine Diskussionen / Re: BrickDaemon startet nicht...
« on: December 16, 2018, 22:04:45 »
Das ist ein nur bei Windows 10 auftretender Fehler.
Der Deamon selber läuft schon. Kann aber den virtuellen Port nicht zur Verfügung stellen.
Es hilft nach dem Windows Start den Dienst einfach mal zu beenden und neu zu starten. Irgend ein Dienst im System der gebraucht wird, startet zu spät.
Zum Dienstneustart infach folgendes machen.

Auf dem Desktop mit der Maus auf das Computericon für den PC gehen
-> rechte Maustaste
-> Verwalten anwählen
-> Punkt Dienste und Anwendungen -> Dienst auswählen
In der Dienstiste den Brickdeamon suchen und anklicken
-> Oben in der Symbolleiste das Symbol |> (für Dienst neu starten) anklicken
Der Dienst wird dann beendet und neu gestartet.
Dannach funktioniert alles wie gewünscht.

15
Allgemeine Diskussionen / Re: Red Brick Wlan
« on: December 09, 2018, 15:58:20 »
Da musst du schon etwas genauer werden mit deinen Infos.
WLan Stick e.t.c.
Ich hab mit WLan keine Probleme.

Pages: [1] 2 3 ... 31