Jump to content
theo

openhab Integration

Nächste Bricks/Bricklets mit openHAB Unterstützung  

23 members have voted

  1. 1. Nächste Bricks/Bricklets mit openHAB Unterstützung

    • Stepper
    • IMU
    • IMU 2.0
    • Accelerometer (fertig)
    • Analog In (fertig)
    • Analog In 2.0 (fertig)
    • Analog Out
    • Analog Out 2.0
    • GPS
    • Industrial Analog Out
    • Industrial Dual Analog In (fertig)
    • Laser Range Finder (fertig)
    • NFC/RFID
    • Color (fertig)


Recommended Posts

Nabend,

 

ich wollte heute endlich loslegen und openhab testen ... leider habe ich nach einer Weile wieder frustriert aufgegeben.

Ich finde einfach keinen Einstieg und komme mit der Anleitung nicht klar.

Verstehe mich nicht falsch, es hat nichts mit deinen Bindings zu tun, ich verstehe den grundsätzlichen Aufbau der .items und .sitemap nicht richtig.

openhab ansich habe ich auf dem pi zum laufen bekommen, aber ausser dem Demo bekomme ich nichts hin.

Früher hattest du mal unter "http://m1theo.org/" deine Wetterstation veröffentlicht, nur diese Seite ist down.

 

Daher jetzt meine große Bitte an dich:

Könntest du hier mal eine ganz einfache .items und .sitemap posten?

Z.Bsp. mit nur 2 x Bricklets: TemperatureBricklet und RemoteSwitchBricklet (A,B,C ist egal, einfach nen Schalter für on und einer für off)

 

Ich brauche irgendwie einen Anfang, ein ganz einfaches Beispiel aus der Praxis - deine Wetterstation mit Anzeige auf dem Smartphone über openhab wäre perfekt.

Dazu einfach die verschiedenen openhab Dateien posten und die Welt wäre für mich ein wenig schöner :)

Share this post


Link to post
Share on other sites

Servus derAngler,

 

ich kann gerne eine Konfiguration zusammenstellen. Einfacher wäre es wenn du deine Dateien postest und ich schau drüber. Was genau hast du denn versucht?

 

Gruß,

Theo

 

Share this post


Link to post
Share on other sites

Hallo,

 

ich muss zugeben das ich nicht einmal verstehe wie ich anfangen soll, von daher steht in meiner test.items und test.sitemap nocht gar nicht drin - wie auch wenn man nicht versteht was ich wie darein schreiben muss.

Von daher kann ich dir leider nicht meine Dateien posten - die gibt es noch nicht wirklich.

Deswegen hatte ich gefragt ob du nicht einfach die .items und die .sitemap zu deiner Wetterstation posten könntest, das würde mir schon sehr helfen denke ich.

 

Was ich für den Anfang erreichen will ist quasi 2 x Räume zu haben (Badezimmer + Aussen) in welchen mir jeweils die entsprechenden Sensordaten angezeigt werden (beispielhaft erstmal nur Temperatur und Luftfeuchtigkeit).

Share this post


Link to post
Share on other sites

Hallo derAngler,

 

OK, ich verstehe.

Also ich gehe mal davon aus, dass du die Installation auf dem Pi mit dem apt-repo gemacht hast. Wenn nicht, dann empfehle ich dir das (vorher am Besten händische Installationen löschen). Die Doku dazu findest du hier:

https://github.com/openhab/openhab/wiki/Apt-Repository

 

Installation:

Werde root.

Installiere java:

apt-get update
apt-get install oracle-java7-jdk
update-java-alternatives -s jdk-7-oracle-armhf

 

Registiere das openHAB apt-Repository:

echo "deb http://repository-openhab.forge.cloudbees.com/release/1.4.0/apt-repo/ /" > /etc/apt/sources.list.d/openhab.list
apt-get update

 

Installiere openHAB und das Tinkerforge Binding:

apt-get install openhab-runtime openhab-addon-binding-tinkerforge

 

Jetzt brauchst du eine openhab.cfg. Darin muss erstmal nur das Gerät konfiguriert werden, auf dem der brickd läuft. Du legst eine Datei /etc/openhab/configurations/openhab.cfg an (muss vom Benutzer openhab gelesen werden können, wie alle weiteren Dateien auch) und schreibst eine Zeile rein, in der Folgendes steht (die IP-Addresse musst du für dich passend machen):

tinkerforge:hosts=127.0.0.1

 

Nun zur items Datei /etc/openhab/configurations/items/test.items. Achtung die Benennung ist wichtig: die Erweiterung muss "items" sein, den Namen "test" musst du dann auch für die sitemap und Web-URL verwenden. In die Datei schreibst du folgende Zeilen, allerdings musst du uid=XYZ durch die uids deiner Bricklets ersetzen.

Number Luftfeuchte                 "Luftfeuchte [%.1f %%]"  { tinkerforge="uid=XYZ" }
Number Temperatur                 "Temperatur [%.1f Cel]"  { tinkerforge="uid=XYZ" }

 

Zum Schluß noch eine sitemap Datei /etc/openhab/configurations/sitemaps/test.sitemap. Da schreibst du Folgendes rein:

sitemap Wetter label="Tinkerforge Weather Station"
{
  Frame {
        Text item=Luftfeuchte
        Text item=Temperatur
        }
}

 

openHAB starten:

/etc/init.d/openhab start

Beim Pi musst du durchaus einige Minuten warten bis der Server wirklich oben ist.

 

Mit dem Browser auf die deine openHAB Seite navigieren. IP oder Rechnernamen in der URL musst du entsprechend anpassen.

http://localhost:8080/openhab.app?sitemap=test

 

Du kannst dir noch die Android oder IOS-App holen und starten.

 

Solltest du später - was ich hoffe - einen SNAPSHOT des Bindings testen wollen, dann einfach openHAB stoppen. Dann /opt/openhab/addons/org.openhab.binding.tinkerforge* loeschen und durch das SNAPSHOT jar-File vom Download ersetzen. openHAB Server wieder starten und warten.

 

Wenn ich nichts vergessen habe, war es das schon.

 

Gruß,

Theo

 

PS: Alles was auf meinem Blog war, findest du noch ausführlicher im openHAB Wiki https://github.com/openhab/openhab/wiki/Tinkerforge-Binding . Ich bin gerade auch dabei einen neuen Blog aufzusetzen, das wird aber noch etwas dauern bis der fertig ist.

 

 

Share this post


Link to post
Share on other sites

So, zum Wochenausklang nochmals zwei neue Bricklets: Bricklet Tilt und Bricklet VoltageCurrent!

 

Dowloads:

http://m1theo.org/org.openhab.binding.tinkerforge-1.5.0-SNAPSHOT-4-VoltageCurrent-etal.jar

http://m1theo.org/openhab-addon-binding-tinkerforge-1.5.0-SNAPSHOT-4-VoltageCurrent-etal.deb

 

Die Konfiguration für diese und alle anderen neuen Bricklets findet ihr jetzt hier:

https://github.com/theoweiss/openhab/wiki

 

Der Snapshot enthält noch einen Bugfix für eine Regression vom letzten Snapshot. Er betrifft das Konfigurations-Management der openhab.cfg für threshold- und callback-Werte einiger Bricklets.

Ausserdem werden jetzt doch wieder alle Bricklet regelmäßig abgefragt, da sonst durch den zeitverzögerten Start des WebInterfaces Werte, die sich nur selten ändern sehr lange unintialized bleiben. Damit werde ich mich später nochmals intensiver beschäftigen.

 

@derAngler: bist du mittlerweile erfolgreicher gewesen?

 

Gruß,

Theo

Share this post


Link to post
Share on other sites

Hallo,

 

ersteinmal vielen Dank Theo, mit deinem Posting habe ich es geschafft :)

Also ja, ich bin weitergekommen, momentan habe ich nur nicht genug Zeit.

Also sammel ich ersteinmal etwas Erfahrung und Fragen und melde mich dann wieder.

Share this post


Link to post
Share on other sites

So,

 

ich kam jetzt endlich dazu mit intensiver mit openHAB zu beschäftigen und will dann mal einen Zwischenbericht dazu abliefern.

 

Wie schon gesagt muss ich mich herzlich bei dir bedanken Theo, nicht nur das du die Bindings geschrieben hast, nein mit deinem Beispiel und deiner Schritt für Schritt Anleitung habe ich es dann sogar geschafft openHAB in Verbindung mit TF zum laufen zu bekommen.

Danke :)

 

Derzeit habe ich folgende TF-Module in Verbindung mit openHAB am laufen:

TemperatureBricklet, HumidityBricklet, BarometerBricklet,AmbientLightBricklet und das RemoteSwitchBricklet.

Dafür nutze ich deine RemoteSwitch-Beta-Bindings.

 

Wann kommen eigentlich deine neuen Bindings mit Beispielen auf die Seite von openHAB?

 

Zunächst einmal funktioniert alles - wunderbar und prima Arbeit von dir  :)

 

Beim RemoteSwitchBricklet habe ich allerdings manchmal Probleme damit, das er sich den "Zustand" des Switch nicht merkt.

Will heißen ich schalte per openHAB-WebUI eine Steckdose auf ON und gehe dann ein paar Stunden später wieder auf die openHAB-WebUI, dann ist der Switch wieder auf OFF, obwohl in Wirklichkeit die Lampe an ist und der Switch somit auf ON gestellt sein müsste.

Das sorgt dafür das man nicht sicher sein kann ob der switch (bzw. die Lampe) auf on oder off steht, das führt wiederum dazu das man öfters "zweimal" auf off klicken muss.

D.h. in Wirklichkeit ist die Lampe an, openHAB zeigt mir sie aber aus an. Beim ersten drücken sendet openhab dann den ON-Befehl (unnötig da ja schon an), beim zweiten drücken dann den erwünschten OFF-Befehl.

Das ist ärgerlich aber kein Beinbruch.

 

Ich hoffe das dies nur ein kleiner Fehler ist den du schnell bereinigen kannst.

 

Außerdem wäre es eine gute Idee die Abfrage-Frequenz bei den Sensoren einstellen zu können. Ähnlich wie ich auch bei TF direkt die Zeit für die Callbacks einstellen kann.

 

Als nächstes würde ich gerne noch beim RemoteSwitch die "Sende-Rate" einstellen, sprich wie oft er das on/off-Signal hintereinander sendet.

Im BrickViewer steht das z.Bsp. standartmäßig auf 5

 

Aber ansonsten habe ich das Gefühl das deine Bindings klasse funktionieren.

Ich werde demnächst noch das MotionDetectionBricklet testen und in Zukunft, sofern als Binding verfügbar, das LEDStripBricklet.

 

Ansonsten habe ich zwar noch einige Probleme mit openHAB ansich und der Konfiguration, das hat aber nicht mit deinen Bindings zu tun.

Share this post


Link to post
Share on other sites

Ich habe dann doch noch einen Fehler gefunden.

Und zwar beim RemoteSwitch - Typ C.

 

Hiermit schalte ich eine Pflanzenlampe bei Sonneaufgang ein und bei Sonnenuntergang wieder aus.

 

Dafür nutze ich eine Schaltsteckdose die ich über Typ C ansprechen kann.

 

Das ausschalten klappt per openHAB-Regel ohne Probleme, nur das einschalten klappt dann nicht mehr automatisch.

Laut openHAB-log müsste sich die Lampe aber wieder eingeschaltet haben - hat sich aber leider nicht.

 

Per "Hand" über ein Switch in der Sitemap kann ich die Lampe anschalten, nur per Rules scheint es nicht zu funktionieren.

 

Ich habe das jetzt 3 Tage lang getestet.

Die Lampe geht jeden Abend zum Sonnenuntergang automatisch aus, aber niemals zum Sonnenaufgang an.

Ich muss die Lampe jeden morgen per WebUI anschalten.

 

Siehe events.log

....
2014-06-01 20:56:49 - Sunrise_Time state updated to 2014-06-01T05:19:00
2014-06-01 20:56:49 - Sunset_Time state updated to 2014-06-01T21:29:00
....
2014-06-01 21:29:00 - Sunset_Event state updated to ON
2014-06-01 21:29:00 - Sunset_Event state updated to OFF
2014-06-01 21:29:05 - PflanzenLampe state updated to OFF
2014-06-01 21:29:05 - PflanzenLampe received command OFF
....
2014-06-02 05:18:00 - Sunrise_Event state updated to ON
2014-06-02 05:18:00 - Sunrise_Event state updated to OFF
....
2014-06-02 05:18:05 - PflanzenLampe received command ON
2014-06-02 05:18:05 - PflanzenLampe state updated to ON
.....

 

hier meine rules:

rule "Sunrise"
when
    Item Sunrise_Event received update ON
then
    sendCommand(PflanzenLampe, ON)
end

rule "Sunset"
when
    Item Sunset_Event received update ON
then
    sendCommand(PflanzenLampe, OFF)
end

 

und meine items:

Switch 	KuechenLampe												{tinkerforge="uid=jMj, subid=kitchen"}
Switch 	PflanzenLampe           									{tinkerforge="uid=jMj, subid=plants"}

 

und meine openhab.cfg:

tinkerforge:rs1.uid=jMj
tinkerforge:rs1.type=bricklet_remote_switch
tinkerforge:rs1.typeBDevices=kitchen
tinkerforge:rs1.typeCDevices=plants

tinkerforge:rs_kitchen.uid=jMj
tinkerforge:rs_kitchen.subid=kitchen
tinkerforge:rs_kitchen.type=remote_switch_b
tinkerforge:rs_kitchen.address=50
tinkerforge:rs_kitchen.unit=0

tinkerforge:rs_plants.uid=jMj
tinkerforge:rs_plants.subid=plants
tinkerforge:rs_plants.type=remote_switch_c
tinkerforge:rs_plants.systemCode=A
tinkerforge:rs_plants.deviceCode=1

 

Ich habe das Gefühl das bei Sonnenaufgang der Befehl nur 1 x gesendet wird, besser wäre aber 5x.

Dazu habe ich aber schon gestern etwas geschrieben.

Share this post


Link to post
Share on other sites

Erst einmal schnell eine kurze Antwort mehr später, da ich gleich weg muss.

Repeats sind schon konfigurierbar, du kannst sie so setzen:

tinkerforge:rs_plants.repeats=5

Ich glaube ich hatte das bisher vergessen zu schreiben.

 

 

Share this post


Link to post
Share on other sites

Danke, habe die Steckdose jetzt so umgestellt das openHAB 5x sendet und siehe da, heute morgen war die Pflanze auch automatisch an.

 

Ich werde das jetzt noch einmal die nächsten 2 Tage beobachten, aber ich glaube das Problem ist beseitigt.

Share this post


Link to post
Share on other sites
Beim ersten drücken sendet openhab dann den ON-Befehl (unnötig da ja schon an), beim zweiten drücken dann den erwünschten OFF-Befehl.

 

Um dies zu verhindern, kann man auch statt einem Standard Switch auch zwei Buttons benutzen, diese können beliebig beschriftet werden, z.B. mit on und off.

 

In der Sitemap dies definieren:

Switch item=YourItem mappings=[ON = "on", OFF = "off"]

 

 

Share this post


Link to post
Share on other sites

@derAngler Hast du deinen Stack mit WiFi angebunden? Reconnects würden das Verhalten mit dem Zurückstellen auf OFF erklären. Oder schaltest du zwischendurch ohne Verwendung von openHAB, also mit der original Fernbedienung? Mit dem Remote Switch Bricklet kann man nämlich den Zustand der Steckdose nicht abfragen. Deshalb wird als Ausgangszustand immer OFF angenommen, bzw. Umschaltvorgänge ausserhalb von openhab werden nicht registriert.

 

Die neuen Bindings werden bis 15.Juni auf der openHAB Seite dokumentiert sein, da am 15. openHAB 1.5 released wird.

 

@Stefan guter Tipp.

 

Da openHAB 1.5 bald released wird, wäre es sehr hilfreich wenn ihr eure bestehenden Setups mit dem aktuellen Binding testen würdet, um eventuelle Regressions zu finden. Ihr könnt dazu das Binding aus dem CI herunterladen:

https://openhab.ci.cloudbees.com/job/openHAB/ws/bundles/binding/org.openhab.binding.tinkerforge/target/org.openhab.binding.tinkerforge-1.5.0-SNAPSHOT.jar

Share this post


Link to post
Share on other sites

Zu früh gefreut :(

 

Heute morgen war die Pflanzenlampe wieder aus, was eine Enttäuschung.

Verstehe das Ganze einfach nicht, das ausschalten abends klappt ohne Probleme, auch das Einschalten per UI funktioniert jedes mal ... nur das automatische Einschalten klappt nicht.

Von 5 Tagen war das Licht nur an einem morgen an - ich verstehe es nicht.

 

An openhab und den Astro-Binding kann es laut openhab.log nicht liegen, dort wird der Switch korrekt ausgelöst.

 

Bin so langsam am verzweifeln ...

 

 

@Theo:

Indirekt ja, habe meinen Stack mit einem Raspberry Pi verbunden und dieser ist über WLAN am Netzwerk.

Allerdings habe ich keine WLAN-Reconnects im Log gefunden, gehe also davon aus das der Pi im Netz bleibt und es somit nicht daran liegen kann.

Eine Fernbedienung oder Handschalter nutze ich nicht, zum ein-/ausschalten nutze ich ausschließlich openHAB (bei beiden Lampen).

Das der RemoteSwitch den Zustand nicht abfragt ist mir klar, deswegen schalte ich ja auch nur mit openHAB.

 

@stefan

Ja, 2 x Buttons sind natürlich auch eine Lösung, aber nicht im Sinne des Erfinders wie man so schön sagt.

Gerade bei einer Lampe finde ich es schon besser, praktischer und nicht zuletzt schöner mit einem Schalter zu arbeiten anstatt mit 2 Knöpfen.

 

@theo

Die Binding werde ich am Wochenende mal testen.

Share this post


Link to post
Share on other sites

Ich habe jetzt mal im Code gewühlt und in dessen Historie. Bis April war im RemoteSwitchBricklet Code, der bei einem Reconnect zum Zurücksetzen des Zustands auf OFF geführt hat. Im aktuellen Binding ist das nicht mehr so. Also löst ein Update des Bindings u.U. dein Problem.

Läuft openHAB bei dir auch auf dem Pi oder nur der Brickd?

Share this post


Link to post
Share on other sites

Vor dem Release hab ich mich noch mal richtig reingehängt und weitere Bricklets eingebunden. Neu gibt es Unterstützung für Bricklet Segment Display 4x7, Bricklet Digital Out 4, Bricklet Hall Effect, Bricklet IO-4 und was das allerbeste ist: Bricklet LED Strip.

 

Die vorläufige Beschreibung der Konfiguration findet ihr wieder hier:

https://github.com/theoweiss/openhab/wiki

Die Doku ist noch sehr knapp, ich werde sie im Laufe der Woche vervollständigen. Gerne dürft ihr vorher hier nachfragen, wenn etwas unklar ist.

 

Den Download gibt es wieder aus dem CI, da die Änderungen schon in den Hauptzweig übernommen worden sind:

https://openhab.ci.cloudbees.com/job/openHAB/ws/bundles/binding/org.openhab.binding.tinkerforge/target/org.openhab.binding.tinkerforge-1.5.0-SNAPSHOT.jar

 

Bitte gebt mir Rückmeldung, auch im Erfolgsfall, wenn etwas nicht funktioniert dann sowieso.

 

Share this post


Link to post
Share on other sites

Hallo Theo,

 

das ist wirklich großartig. Ich nutze dein Binding schon eine Weile zusammen mit einem Temperature, Ambient Light und Quad Relay Bricklet zum Überwachen meines Servers Zuhause. Funktioniert sehr gut!

 

Ich bin wirklich gespannt auf die Unterstützung des LED Strip Bricklets, werde es so schnell wie möglich testen.

Gibt es irgendwo schon Dokumentation dazu? Habe in den (vorläufigen) Release Notes noch nichts gefunden.

 

Außerdem würde ich gern wissen, ob das PTC Bricklet demnächst eventuell auch unterstützt wird?

 

Gruß

Raimund

 

 

 

 

Share this post


Link to post
Share on other sites

Hallo Tho,

vielen Dank für die Mühen mit den TF Bindings für OpenHab.

Dank deiner Anleitungen habe ich es geschaft eine Testlampe per RemoteSwitch zu konfigurieren.

 

Was mir nicht klar ist ist die Config in der OpenHab.cfg

 

Wofür ist diese Section ?

tinkerforge:rs1.uid=jKw

tinkerforge:rs1.type=bricklet_remote_switch

tinkerforge:rs1.typeADevices=rslr1 rslr2

tinkerforge:rs1.typeBDevices=kitchen

tinkerforge:rs1.typeCDevices=floor

 

Steht doch alles hier, Die SubId wird oben deklariert, Wozu ist die ?

tinkerforge:rs_kitchen.uid=jKw

tinkerforge:rs_kitchen.subid=kitchen

tinkerforge:rs_kitchen.type=remote_switch_b

tinkerforge:rs_kitchen.address=344

tinkerforge:rs_kitchen.unit=9

 

lg

Jörg

 

Share this post


Link to post
Share on other sites

Hi Joerg,

 

im oberen Teil wird festgelegt welche sub devices am bricklet hängen, im unteren Teil wird das sub device konfiguriert. Den type musst du nochmals angeben, damit das Binding überprüfen kann ob du alles richtig konfiguriert hast.

 

Gruß,

Theo

Share this post


Link to post
Share on other sites

Hallo Theo,

ich habe ein kleines Problem mit dem IO16

 

openhub.cfg

#IO16

tinkerforge:io16.uid=gpy

tinkerforge:io16.type=bricklet_io16

tinkerforge:io16.debouncePeriod=100

 

#Port A

 

tinkerforge:io16ina0.uid=gpy

tinkerforge:io16ina0.subid=ina0

tinkerforge:io16ina0.type=iosensor

tinkerforge:io16ina0.pullUpResistorEnabled=true

 

.items

Contact ina0      "ina0 [schalter ist %s]"  {tinkerforge="name=io16ina0"}

 

.sitemap

Text item=ina0

 

 

Wenn ich nun den Schalter am IO16 schliesse, kann ich dies im Brickv sehen, aber in Openhab wird keine Änderung angezeigt.

Hier steht immer "schalter ist _"

 

Hast du hierzu einen Tip

 

Update

mit

Contact ina0      "ina0 [schalterl ist %s]"  {tinkerforge="uid=gpy, subid=ina0"}

geht es.

 

 

 

Share this post


Link to post
Share on other sites

Hi Jörg,

 

danke für die Rückmeldung. Sieht nach einem Bug aus. Werde ich mir leider erst nach dem Urlaub anschauen können.

 

Gruß,

Theo

 

Share this post


Link to post
Share on other sites

@theo @all

ich hab hier ein kleines problem.

meine config in auszügen

openhab.cfg

tinkerforge:hosts=192.168.4.7
tinkerforge:io16.uid=aE9
tinkerforge:io16.type=bricklet_io16
tinkerforge:io16.debouncePeriod=100

tinkerforge:outa0.uid=aE9
tinkerforge:outa0.type=io_actuator
tinkerforge:outa0.subid=outa0
tinkerforge:outa0.defaultState=false

 

sitemap.cfg

Frame label="Lichtschalter" {
                Switch item=outa0 label="Licht"
        }

 

items.cfg

Switch outa0                    "Licht" {tinkerforge="uid=aE9, subid=outa0"}

 

wenn ich im webif den schalter schalten will bekomme ich immer

 

logfile

21:38:57.220 INFO  runtime.busevents[:22] - outa0 received command OFF
21:38:57.232 DEBUG o.o.b.t.i.TinkerforgeBinding[:655] - received command OFF for item outa0
21:38:57.239 ERROR o.o.b.t.i.TinkerforgeBinding[:708] - COMMAND no tinkerforge device found for command for item uid: aE9 subId: outa0
21:38:59.350 INFO  runtime.busevents[:22] - outa0 received command ON
21:38:59.846 DEBUG o.o.b.t.i.TinkerforgeBinding[:655] - received command ON for item outa0
21:38:59.854 ERROR o.o.b.t.i.TinkerforgeBinding[:708] - COMMAND no tinkerforge device found for command for item uid: aE9 subId: outa0
21:39:02.612 INFO  runtime.busevents[:22] - outa0 received command OFF
21:39:02.624 DEBUG o.o.b.t.i.TinkerforgeBinding[:655] - received command OFF for item outa0
21:39:02.631 ERROR o.o.b.t.i.TinkerforgeBinding[:708] - COMMAND no tinkerforge device found for command for item uid: aE9 subId: outa0

 

Kann mir hier jemand weiterhelfen? Irgendwie steh ich auf dem Schlauch.

 

VG

Share this post


Link to post
Share on other sites

Hi Einstein,

 

deine Config sieht OK aus. Such mal im openhab.log ob beim Starten von openHAB das Bricklet erkannt wurde. Im Zweifel stoppst du openHAB, schiebst openhab.log zur Seite, startest wieder, wartest bis der Server oben ist, kopierst die Log-Datei und postest sie als Anhang. Dann kann ich mal drüber schauen.

 

Gruß,

Theo

Share this post


Link to post
Share on other sites

hallo theo

 

hier der log

 

21:59:59.008 INFO  o.o.c.internal.CoreActivator[:61]- openHAB runtime has been started (v1.5.0).
22:00:38.884 INFO  o.o.m.c.i.ModelRepositoryImpl[:79]- Loading model 'logging.persist'
22:00:41.120 INFO  o.o.m.c.i.ModelRepositoryImpl[:79]- Loading model 'rrd4j.persist'
22:00:41.942 INFO  o.o.m.c.i.ModelRepositoryImpl[:79]- Loading model 'testsite.items'
22:01:00.215 INFO  o.o.i.s.i.DiscoveryServiceImpl[:72]- mDNS service has been started
22:01:02.340 ERROR o.a.cpr.AtmosphereFramework[:2208]-
java.lang.ClassCastException: org.eclipse.osgi.framework.internal.core.BundleURLConnection cannot be cast to java.net.JarURLConnection
        at org.atmosphere.util.annotation.AnnotationDetector.detect(AnnotationDetector.java:324)
        at org.atmosphere.cpr.DefaultAnnotationProcessor.scanForAnnotation(DefaultAnnotationProcessor.java:148)
        at org.atmosphere.cpr.DefaultAnnotationProcessor.configure(DefaultAnnotationProcessor.java:134)
        at org.atmosphere.cpr.AtmosphereFramework.autoConfigureService(AtmosphereFramework.java:2170)
        at org.atmosphere.cpr.AtmosphereFramework.init(AtmosphereFramework.java:648)
        at org.atmosphere.cpr.AtmosphereFramework.init(AtmosphereFramework.java:561)
22:01:08.554 INFO  o.o.m.c.i.ModelRepositoryImpl[:79]- Loading model 'testsite.sitemap'
22:01:32.097 INFO  o.o.io.rest.RESTApplication[:143]- Started REST API at /rest
22:01:38.861 INFO  o.o.u.w.i.s.WebAppServlet[:79]- Started Classic UI at /openhab.app
22:02:06.304 INFO  o.o.m.c.i.ModelRepositoryImpl[:79]- Loading model 'testsite.rules'
22:02:19.558 WARN  o.o.c.p.e.PersistenceExtensions[:404]- There is no queryable persistence service registered with the name 'rrd4j'
22:02:19.588 ERROR o.o.m.r.i.engine.RuleEngine[:267]- Error during the execution of startup rule 'Update max and min temperatures from Temperature': cannot invoke method public abstract org.openhab.core.types.State org.openhab.core.persistence.HistoricItem.getState() on null
22:02:21.836 WARN  o.o.c.p.e.PersistenceExtensions[:404]- There is no queryable persistence service registered with the name 'rrd4j'
22:02:21.858 ERROR o.o.m.r.i.engine.RuleEngine[:267]- Error during the execution of startup rule 'Update max and min temperatures from Barometer': cannot invoke method public abstract org.openhab.core.types.State org.openhab.core.persistence.HistoricItem.getState() on null
22:02:22.714 INFO  o.o.b.f.i.FritzboxBinding[:96]- Fritzbox conditional deActivate: false
22:02:22.720 INFO  o.o.c.s.AbstractActiveService[:169]- FritzBox refresh Service has been started
22:02:24.303 DEBUG o.o.b.t.i.TinkerforgeActivator[:34]- Tinkerforge binding has been started.
22:02:24.349 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: uid=bNd
22:02:24.362 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: uid=aMN
22:02:24.369 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: uid=bNd
22:02:24.377 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: uid=aE9
22:02:24.384 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: subid=outa0
22:02:24.391 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: uid=d3Q
22:02:24.398 DEBUG o.o.b.t.i.TinkerforgeGenericBindingProvider[:81]- token: subid=backlight
22:02:27.335 DEBUG o.o.b.t.i.TinkerforgeBinding[:169]- TFINIT connectModel called
22:02:27.412 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value bar_dd.callbackPeriod : 10000
22:02:27.430 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value bar_dd.subid : temperature
22:02:27.437 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value bar_dd.threshold : 1000
22:02:27.447 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value bar_dd.type : barometer_temperature
22:02:27.463 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value bar_dd.uid : bNd
22:02:27.539 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value hosts : 192.168.4.7
22:02:27.558 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value io16.debouncePeriod : 100
22:02:27.564 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value io16.type : bricklet_io16
22:02:27.581 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value io16.uid : aE9
22:02:27.639 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value lcd_dd.type : bricklet_LCD20x4
22:02:27.648 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value lcd_dd.uid : d3Q
22:02:27.709 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value outa0.defaultState : false
22:02:27.716 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value outa0.subid : outa0
22:02:27.732 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value outa0.type : io_actuator
22:02:27.747 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value outa0.uid : aE9
22:02:27.809 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value service.pid : org.openhab.tinkerforge
22:02:27.815 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value temp_dd.callbackPeriod : 10000
22:02:27.967 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value temp_dd.threshold : 1000
22:02:27.997 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value temp_dd.type : bricklet_temperature
22:02:28.031 DEBUG o.o.b.t.i.c.ConfigurationHandler[:137]- CONFIG key:value temp_dd.uid : aMN
22:02:28.129 DEBUG o.o.b.t.i.c.ConfigurationHandler[:259]- CONFIG setting io_actuator config
22:02:28.177 DEBUG o.o.b.t.i.c.ConfigurationHandler[:457]- configuring feature: defaultState for uid aE9
22:02:28.212 DEBUG o.o.b.t.i.c.ConfigurationHandler[:469]- CONFIG found String value
22:02:28.230 DEBUG o.o.b.t.i.c.ConfigurationHandler[:394]- CONFIG setting no tfConfig device_type bricklet_LCD20x4
22:02:28.238 DEBUG o.o.b.t.i.c.ConfigurationHandler[:394]- CONFIG setting no tfConfig device_type barometer_temperature
22:02:29.678 INFO  o.o.c.s.AbstractActiveService[:169]- Exec Refresh Service has been started
22:02:31.508 INFO  o.o.c.s.AbstractActiveService[:169]- HTTP Refresh Service has been started
22:02:32.203 INFO  o.o.c.s.AbstractActiveService[:169]- NTP Refresh Service has been started
22:02:40.327 INFO  o.o.c.s.AbstractActiveService[:169]- SNMP Refresh Service has been started

 

Viele Grüße

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...