Jump to content
Kristian

Module ip_tables not found

Recommended Posts

Hallo zusammen,

 

ich möchte gerne auf meinem Red Brick ein Port öffnen. Offensichtlich muss ich dafür iptable nutzen. Leider gestaltest sich das schwierig. Das Programm ist zwar installiert, wenn ich allerdings versuche damit etwas zu machen kommt die Fehlermeldung: Mudule ip_tables not found. iptables v1.4.21: can't  initialize iptables table 'filter': Table does not exist (do you need to ismod?)

 

Eine Ethernet extension ist vorhanden und funktioniert auch...

 

Vielen Dank!

Share this post


Link to post
Share on other sites

Hallo Kristian,

 

wenn Du auf einem bestimmten Port Verbindungen annehmen möchtest ist meiner Meinung nach kein iptables erforderlich. Was macht das Programm denn genau?

 

--m0d

Share this post


Link to post
Share on other sites

Hallo m0d,

 

ich möchte auf dem Brick ein Programm laufen lassen das sich über das Netzwerk über einen Clien steuern lässt und auf einem Monitor Dinge anzeigt. Dieses Programm nutzt den Port 1099. Da es zu Problemen in der Kommunikation kam habe ich angenommen, dass das Port noch geschlossen ist.

 

Viele Grüße

Kristian

Share this post


Link to post
Share on other sites

Der Client läuft lokal im selben Netzwerk? Oder soll die Verbindung übers Internet gehen?

 

Wenn es im gleichen Netzwerk läuft sollte das Problemlos funktionieren. Falls es über das Internet geht musst du den Port 1099 auf deinem Router (Fritz Box?) zum RED Brick weiterleiten.

Share this post


Link to post
Share on other sites

Du kannst Dir z.B. mit dem Befehl

netstat -tnlp 

anzeigen lassen, welcher Prozess (PID) einen bestimmten Port geöffnet hat. Du kannst auch überprüfen, ob auf dem entsprechenden Port momentan ein Dienst/Programm "lauscht".

Share this post


Link to post
Share on other sites

Ich habe das Programm jetzt ein wenig umgeschrieben:

public static void main(String[] args) {
	port = Registry.REGISTRY_PORT;
	System.out.println("listening on port: " + port);
	//System.setProperty("java.rmi.server.hostname","192.168.0.106");
	    try {
	      LocateRegistry.createRegistry(port);
	    }	    
	    catch (RemoteException ex) {
	      System.out.println(ex.getMessage());
	    }
    try {
      Naming.rebind("Server", new bluePill());
    }
    catch (MalformedURLException ex) {
      System.out.println(ex.getMessage());
    }
    catch (RemoteException ex) {
      System.out.println(ex.getMessage());
    }
    JOptionPane.showMessageDialog(null, "Server gestartet!", String.valueOf(port), JOptionPane.INFORMATION_MESSAGE);
}

 

Es sollte sich jetzt eig. einen freien Port suchen und den nutzen (Jedenfalls ist es so gedacht...). Trotzdem bekomme ich noch die Fehlermeldung:

 

Port already in use:59472; nested exception is:

      java.net.BindException: Adress already in use

 

Wenn ich anschließend den Port mit lsof -i:59472 angucke wird nichts angezeigt...

 

Auch mit netstat -tnlp  wird der verwendete Port nicht als elegt angezeigt.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...