Jump to content
BOBmoraine

[Linux] Fehler bei apt-get upgrade

Recommended Posts

Moin,

ich wollte bei meinem RED mit OpenHAB noch das addon "rrd4j" nachinstallieren, doch ich kann nichtmal ein fehlerfreies "apt-get upgrade" machen, folgend die Ausgaben:

tf@TF_RED:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
perl : Depends: perl-base (= 5.20.2-3+deb8u1) but 5.20.2-3+deb8u2 is installed
        Recommends: rename but it is not installed
E: Unmet dependencies. Try using -f.

tf@TF_RED:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  perl perl-modules
Suggested packages:
  libb-lint-perl libcpanplus-dist-build-perl libcpanplus-perl
  libfile-checktree-perl liblog-message-simple-perl liblog-message-perl
  libobject-accessor-perl
Recommended packages:
  rename libarchive-extract-perl libmodule-pluggable-perl libpod-latex-perl
  libterm-ui-perl libtext-soundex-perl libcgi-pm-perl
  libpackage-constants-perl
The following packages will be upgraded:
  perl perl-modules
2 upgraded, 0 newly installed, 0 to remove and 274 not upgraded.
6 not fully installed or removed.
Need to get 0 B/4,622 kB of archives.
After this operation, 501 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 143407 files and directories currently installed.)
Preparing to unpack .../perl_5.20.2-3+deb8u2_armhf.deb ...
Unpacking perl (5.20.2-3+deb8u2) over (5.20.2-3+deb8u1) ...
dpkg: error processing archive /var/cache/apt/archives/perl_5.20.2-3+deb8u2_armhf.deb (--unpack):
trying to overwrite '/usr/bin/perldoc', which is also in package perl-doc 5.20.2-3+deb8u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
/var/cache/apt/archives/perl_5.20.2-3+deb8u2_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ich habe leider nicht so die Linuxkenntnisse, daher wollte ich fragen ob mir jemand helfen kann das zu "reparieren".

Die Linux-Version ist die vom "red_image_1_7_full.img".

Share this post


Link to post
Share on other sites

Danke, das wars!

Hier nochmal der Quote:

Da steht sich das perl Package mit einigen anderen Packages auf den Füssen. Ich denke, dass ist ein Bug im perl Package selbst.

 

In dieser Situation verweigert apt-get die Arbeit, weil es erst diese Problem beseitigt haben will.

 

Ich konnte das Problem reproduzieren und so auflösen:

 

sudo dpkg --purge cpanminus
sudo dpkg --purge liblocal-lib-perl
sudo dpkg --purge libmodule-build-perl
sudo dpkg --purge libjson-pp-perl
sudo dpkg --purge perl-doc
sudo apt-get -f install
sudo apt-get upgrade

 

Jetzt stehen sich systemd und systemd-shim im Weg:

 

sudo dpkg --purge systemd-shim
sudo apt-get -f install
sudo apt-get install systemd-shim
sudo apt-get upgrade

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...