Jump to content
urmel007

[Python] Sommerzeit auf dem RED Brick

Recommended Posts

Hallo,

 

ich habe auf dem RED Brick ein Problem mit dem Auslesen der Sommerzeit.

 

import time

lt = time.localtime() # Aktuelle, lokale Zeit als Tupel & Entpacken des Tupels

lt_y, lt_mo, lt_d, lt_h, lt_mi = lt[0:5]      # Datum & Zeit

lt_dst = lt[8]      #  Angabe der Sommerzeit: -1 = keine Angabe vom Betriebssystem 0 = Winterzeit    1 = Sommerzeit         

print(lt_dst)

 

Als Ergebnis wird auf zwei Notebooks mit Windows und ubuntu aktuell jeweils

ertartungsgemäß -1 ausgegeben. Auf dem RED Brick kommt immer (Sommer- wie Winterzeit) als Ergebnis 0.

 

Wo kann da der Fehler liegen oder muss die Sommerzeit "von Hand" aktiviert werden?

 

Ich bin Dankbar für jeden Hinweis.

 

Viele Grüße

Michael

Share this post


Link to post
Share on other sites

Warum ist -1 erwartungsgemäß? Ich würde erwarten, dass der PC weiss ob DST ist oder nicht.

 

Hier von meinem PC:

 

>>> import time
>>> time.localtime()
time.struct_time(tm_year=2016, tm_mon=4, tm_mday=7, tm_hour=9, tm_min=30, tm_sec=47, tm_wday=3, tm_yday=98, tm_isdst=1)

 

Hier von einem RED Brick, dessen Uhr ein paar Tage daneben ist:

 

>>> import time                                                                 
>>> time.localtime()                                                            
time.struct_time(tm_year=2016, tm_mon=4, tm_mday=4, tm_hour=14, tm_min=32, tm_sec=24, tm_wday=0, tm_yday=95, tm_isdst=1)

 

Was sagt denn date im Terminal dazu?

 

PC: Do 7. Apr 09:34:31 CEST 2016

RED Brick: Mon Apr  4 14:38:14 CEST 2016

 

Das S in CEST zeit Sommerzeit an.

 

Eigentlich sollte die Umstellung Winter-/Sommerzeit automatisch passieren, wenn du die Zeitzone richtige eingestellt hast.

Share this post


Link to post
Share on other sites

... sorry, erwartungsgemäß für Sommerzeit wäre 1 (das kommt auch auf den Notebooks). Auf dem RED Brick erscheint jedoch folgendes:

 

>>> import time

>>> time.localtime()

time.struct_time(tm_year=2016, tm_mon=4, tm_mday=7, tm_hour=20, tm_min=59, tm_sec=41, tm_wday=3, tm_yday=98, tm_isdst=0)

 

tm_isdst ist Sommer- wie Winterzeit immer 0.

 

date gibt folgendes aus:

Thu Apr  7 21:06:32 GMT-2 2016

 

Es sieht nach einem Zeitzonenproblem aus ? ???

 

 

Share this post


Link to post
Share on other sites

GMT-2? Wir haben hier eigentlich gerade GMT+2.

 

http://wwp.greenwichmeantime.com/time-zone/gmt-2/

 

Does GMT-2 observe Daylight Saving Time?
GMT-2 does not operate Daylight-Saving Time

 

Ist also alles korrekt. Du hast einfach auf dem RED Brick eine Zeitzone eingestellt, die kein DST kennt.

 

Du kannst über den Brick Viewer im RED Brick Settings Tab Uhrzeit und Zeitzone mit deinem PC synchronisieren. Dass sollte das Problem beheben.

Share this post


Link to post
Share on other sites

Habe die Lösung:

 

das Problem war wirklich die Zeitzone des RED Brick. Da ich

den RB ohne grafische Oberfläche betreibe habe ich auf der

Konsole mit "sudo dpkg-reconfigure tzdata" die Zeitzone

eingestellt.

Jetzt zeigt auch unter Python time.localtime() den Wert von

tm_isdst korrekt an.

 

Das verwirrende war und ist, dass der Brickviewer immer (vor und nach

der Korrektur der Zeitzone) für den RED Brick und lokal UTC +2 angezeigt

hat. Ein synchronize hat da auch nichts bewirkt.

 

Nochmal vielen Dank für die Unterstützung.

 

 

Share this post


Link to post
Share on other sites

Hallo,

 

ich schließe mich dem Thema einmal an. Ich habe meinen PC mit dem RED-Brick synchronisiert. Dabei wird aber nie die Timezone angepasst, so dass ich bei meinem Daten-Logger auf dem RED-Brick immer eine Zeit t = -2h (siehe Anhang) bekomme. Ich habe nichts in den Einstellungen gefunden, wo ich das Ändern kann. Gibt es etwas was ich übersehen habe?

 

Danke für Eure Hilfe

 

Grüße acki

RED_Brick_Time.thumb.png.d307e0a83ec35540267f2af6076ccd5c.png

Share this post


Link to post
Share on other sites

Moin,

Versuch es mal mit dieser Version. Ich habe das Zeitzonenhandling insgesamt überarbeitet, jetzt sollten auch echte Zeitzonen (anstatt von UTC-Offsets) angezeigt und gespeichert werden.

Erik

Share this post


Link to post
Share on other sites

Moin,

 

damit funktioniert es.

Habe den RED synchronisiert und jetzt wird im Log-File die richtige Zeit abgelegt.

 

Dankeschön

 

Grüße acki

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...