Jump to content

HAT Zero and Thermal sensor are not responding


Recommended Posts

Hi, 

I am using HAT zero Brick and Thermal sensor by FLIR. I am using these components since last 1 week or something and they were working fine until now. Now whenever I am trying to connect it via python script, I am just getting one response, did not receive response. I have also tried to connect it via brick viewer and there is not response at all. I have checked the host address, port address and UID, everything is correct. The shutter of the thermal sensor works some time. Tried attaching sensor at other ports B, and D, but the same response. What can be the problem here? 

thanks in advance. 

Ravi

Link to post
Share on other sites

Hi,

When you connect to the Pi with Brick Viewer, can you see the HAT Zero Brick in the setup tab? Is the brick viewer able to connect to the Pi at all?

In any case it could be useful, if you post the Brick Daemon log file (/var/log/brickd.log) here.

Link to post
Share on other sites

Hi,

When I am connecting the Brick Viewer with Pi, I am not able to see the HAT Zero Brick. How can I check if brick Viewer is able to connect to the Pi or not? Meanwhile I am sending you the log file. I also have the file called 'brickd.log.1', if you want I am happy to send you. 

Kind Regards,

Ravi

brickd.log

Link to post
Share on other sites

The log looks okay so far. If the Brick Viewer can't connect to the Pi, you should get a message box indicating the error. If no error is reported, then the connection succeeds but the Brick Daemon running on the Pi does not see any hardware. To verify this, you can stop the Brick Daemon with

sudo systemctl stop brickd

and then start a non-daemonized instance with debug logging:

sudo brickd --debug -all,+bricklet.c

If the HAT is detected, you will get output like this:

2020-06-08 14:27:57.143360 <D> <bricklet.c:182> Found product_id "0x085d" in device tree, using pre-configured HAT Zero Brick setup
2020-06-08 14:27:57.144827 <D> <bricklet.c:220> Bricklet found: spidev /dev/spidev0.0, driver 1, name gpio27 (num 27)

If this output is missing, the HAT is not detected.

 

Link to post
Share on other sites

I have tried this solution and got this (Could not open HAT product_id in device tree, not using pre-configured HAT Brick setup
) sort of error (please find it in attachment). I guess the configurations got changed by me at some Point. How can I use the pre-defined configurations? 

brick.png

Link to post
Share on other sites

Hard to say why you don't have the deive-tree, the easiest solution is probably to just configure it by hand, see here: https://www.tinkerforge.com/en/doc/Hardware/Bricks/HAT_Zero_Brick.html#compatibility-to-other-boards-and-images

Add the lines from the documentation to your /etc/brickd.conf and turn spi interface on with raspi-config.

Then the brickd doesn't have to configure anything by reading out the device-tree first and it should just work.

Link to post
Share on other sites

The default content is the same as if the brickd.conf file was empty. So to be sure, that nothing is misconfigured, you can replace everything.

Link to post
Share on other sites

I have tried, now I am getting "could not connect error". I have tried to check the config using "brickd --check-config" and got brick config error. I am also attaching the log file. 

brick_error.png

brick_config.png

brickd.log

Link to post
Share on other sites

The relevant error message in your brickd.log is

Quote

2020-06-09 15:13:17.249677 <E> <bricklet_stack_linux.c:100> Could not open /dev/spidev0.0: ENOENT (2)

You have to enable the SPI device by running

sudo raspi-config

and then selecting "Interfacing Options" and "SPI" and answering yes.

 

brickd --check-config does not work, because you are not running it with sudo, so it tries to check the non-existing user specific config file.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...