Jump to content
Sign in to follow this  
cl-

5 Hz Störsignal mit zwei Industrial Dual Analog v2 Bricklets

Recommended Posts

Hallo zusammen,

ich habe momentan zwei Industrial Dual Analog v2 Bricklets an einem Master Bricklet angeschlossen.
Testweise auch mit zwei Isolator Bricklets dazwischen (was jedoch das Störsignal nicht verändert).

Ich bekomme ein 5 Hz Störsignal auf die Leitung, auch wenn ich die Eingänge der IDAI v2 Bricklets offen lasse. Ich verwenden nur TF Bricklet Kabel.
Hierbei ist es egal, ob ich das Notebook mit oder ohne Netzteil laufen lasse.

Hattet ihr das Problem auch schon mal? Ein solches Signal kenne ich sonst nur von Wellengleichungen.
Habt ihr eine Idee, wo ich noch mal nachgucken sollte?

Cheers,
Claudio

2020-06-16 14_28_25-.png

Share this post


Link to post
Share on other sites

Ich nehme mal an, wenn du die Eingänge an den IDAI v2 Bricklets offen lässt, dann hast du da nicht noch irgendwelche Kabel an den Eingängen dran die als Antennen dienen könnten?

Wie groß ist den der Ausschlag der Störung? Sind das Millivolt oder Volt?

Abgesehen von dieser Störung messen die Bricklets aber auch die Signale die du eigentlich messen willst, oder?

Wenn du den Aufbau am Laptop hast ist das ja transportable. Tritt das Problem nur dort auf, wo der Aufbau gerade steht, oder tritt das Problem auch in anderer Umgebung, vor dem Haus, im Garten, etc, auf? Sprich ist das eine Störung durch die Umgebung? Du hast da nicht gerade zufällig eine Teslaspule in der Nähe, oder?

Share this post


Link to post
Share on other sites
Posted (edited)

Ich messe auch die Signale, die eigentlich zu messen wären. Lose Kabel sind nicht verbunden, die als Antennen dienen könnten.
Die Störungen treten ortsunabhängig auf ... egal ob im Garten, im Haus oder im Büro. Auch in einem 10 km entfernten Ort habe ich das Störsignal.

Wir messen das morgen mal mit dem Scope und geben Bescheid, sobald wir die Messergebnisse haben.

Edited by cl-

Share this post


Link to post
Share on other sites

Ist diese Störung auf alle 4 Kanälen (also 2 Bricklets mit jeweils 2 Kanälen) zu messen?

Was passiert, wenn du den IN+ und IN- Eingang eines Kanals direkt mit einander verbindest, anstatt offen zu lassen?

Share this post


Link to post
Share on other sites

Wir haben heute Messungen gemacht. Die Störung ist auf allen 2/4/6/8 angeschlossenen Kanälen messbar.

Grundsätzlich kann man sagen, dass es keinen Unterschied macht, ob man ein, zwei, drei oder vier Bricklets angeschlossen hat und ob man IN+ und IN- verbindet.

Das Scope hat folgende Ergebnisse geliefert:

  1. Ein IDAI v2 Bricklet: Störsignale um die 5 Hz mit einer Amplitude von bis zu 40 mV
  2. Zwei IDAI v2 Bricklets: Störsignale um die 2,5 Hz mit einer Amplitude von bis zu 80 mV
  3. Drei und vier IDAI v2 Bricklets: Hier ändert sich nicht mehr viel zu den Zahlen mit zwei Bricklets (siehe 2.)

Share this post


Link to post
Share on other sites

Wir haben das hier mal kurz getestet, können das aber so nicht nachstellen. Vermutlich ist es etwas speziell an deinem Aufbau.

Kannst du ein Foto vom Aufbau zeigen, so das ich hier verstehen kann wie das verdrahtet ist?

Eine Vermutung ist, dass die Störung über die Stromversorgung ins System kommt und sich bis aufs Messsignal durchschlägt. Da währe eigentlich die Erwartung, dass der DC/DC Wandler auf einem Isolator Bricklet das wegfiltern kann, das hat ja aber nach deiner Aussage nichts geholfen.

Daher die Frage, wie versorgst du den Aufbau mit Strom und hilft es den Aufbau anders mit  Strom zu versorgen?

Kannst du die Störung auch auf der 3,3V oder 5V Leitung des Bricklets messen, die auch auf dem grünen 8-Pol Stecker liegen?

Share this post


Link to post
Share on other sites

Wir haben verschiedene Spannungsversorgungen getestet, auch ein normaler PC.
Einen speziellen Aufbau haben wir nicht. Wir nutzen nur eure Bausteine.

Wir haben jedoch den Verdacht, dass es bei uns im System ein Masseproblem ist. Daher haben wir zum Testen den 0 ohm Widerstand (R1) des IDAI v2 Bricklets entfernt und den AGND Teil dann mit dem AGND des Master Bricks direkt verbunden.

Das hat dafür gesorgt, dass der Störpegel von 80 mV auf ca. 3 mV gesenkt werden konnte (was für uns erstmal ausreicht).
Das HF Rauschen wurde von 100 kHz auf 1 MHz erhöht.

Ich habe noch keine Antwort auf die Frage, wo die 2,5 Hz bzw. 5 Hz herkommen.
Wir schauen mal, ob wir noch mehr rausfinden können.

 

Vielen Dank aber schon mal an dieser Stelle für deine Hilfe!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...