Jump to content

Kommunikationsabbruch MQTT


ThomasH
 Share

Recommended Posts

Hallo zusammen,

meine WARP 1 verliert mehrmals am Tag Ihre MQTT-Kommunikation und ich brauche Hilfe bei der weiteren Fehlersuche.

IST-Stand:

  • WARP-1 Smart mit FW: V1.2.4-60f17413 und MQTT konfiguriert
  • Raspi mit Mosquitto MQTT Broker der mit zig anderen Komponenten seit Jahren zuverlässig funktioniert
  • UniFi U6 Lite Wifi

Bisherige Erkentnisse:

Auf der WARP sehe ich:

    55987456 Disconnected from MQTT: TCP_DISCONNECTED (0)
    55989101 Connecting to MQTT broker
    55989121 Connected to MQTT session=0 max payload size=14330

Im Mosquitto-Log sehe ich:

    1631520569: Client warp-U7X has exceeded timeout, disconnecting.
    1631520569: Socket error on client warp-U7X, disconnecting.
    1631520572: New connection from 192.168.28.30 on port 1883.1631520572: New client connected from 192.168.28.30 as warp-U7X (c1, k30).

Diskussion:

Mein erster Verdacht viel natürlich aufs WLAN, das UniFi Dashboard zeigt allerdings eine Wifi-Experience von 100%, die Signalstärke ist mit -76db vollkommen ausreichend, Paketverluste sind sehr gering (2%, für WLAN einandfrei). Dazu kommt die Tatsache dass MQTT über TCP ja eigentlich extrem robust ist was einzelne Aussetzer angehen würde.

Für mich sieht es so aus, als würde die WARP keine Updates senden, der Broker erkennt sie dann als stale und beendet die Verbindung. Im Fehlerfall hatte ich auch schon auf den Broker gelauscht und habe keine MQTT-Messages gesehen.

Meine Frage wäre jetzt, was kann ich auf der WARP tun, um den Fehler evtl. weiter einzugrenzen bzw. zu prüfen ob der MQTT-Prozess ok ist und ob die WARP die Pakete im Fehlerfall wirklich nicht sendet?

Danke für eure Hilfe!

Thomas

Link to comment
Share on other sites

Moin Thomas,

Teste bitte mal die Lastmanagement-Beta. Ich habe ein paar Fälle gehabt, bei denen sich der (alte) Webserver und der MQTT-Client auf den Füßen standen. MIt dem neuen Webserver sind die Probleme dann verschwunden. Achtung: Falls du den Login des Webinterfaces aktiviert hast, musst du u.U. deinen Browser nach dem Update neu starten, die Beta unterstützt den Loginprozess nicht.

Link to comment
Share on other sites

Moin,

das werde ich gerne machen. Ich habe gestern mit MQTT Explorer weiter debugged und für mich sieht es auch so aus als würde die WARP zu bestimmten Zeiten einfach keine updates senden, was dann ja für ein Problem mit einem der laufenden Prozesse sprechen würde.

Ich werde das Login deaktivieren, das Update einspielen und dann weiter beobachten.

Danke Dir.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...