Jump to content

Testing stepper brick


n8igall
 Share

Recommended Posts

Hallo,

 

ich habe einen Stepper-Brick + Analog Out Bricklet. Angschlossen funktioniert das Analog-Out-Bricklet sowohl mittels brickv als auch per selbst kompiliertem Programm (Linienlaser leuchtet bzw. geht an und aus wie gewollt). Wenn ich eine Spannung in das Stepper-Brick einspeise, dann wird das auch im Stepper Brick Reiter angezeigt.

 

Als Motor habe ich versucht einen Hybrid-Bipolar-Motor anzuschliessen (SY42STH47-1206A, 4V, 1.2 A). Ich bin absoluter Schrittmotorneuling. Soweit ich  verstanden habe, muesste das gehen, wenn ich die zwei "mittleren" Spulenkabel weglasse, oder? Nach erfolglosen Versuchen, habe ich mir ein Multimeter besorgt, in brickv eingestellt, dass nur 1 oder 2 Schritte pro Sekunde ausgefuehrt werden und dann versuchsweise in verschiedenen Kombinationen an den 4 Pins Spannung abgegriffen. Ergebnis: Egal wie ich abgreife, es lag immer keine Spannung an.

 

Meine Frage: Wird nur eine messbare Spannung geschaltet, wenn eine Last anliegt? Gibt es eine Moeglichkeit den Stepper-Brick zu testen (z.B. Selbsttest)? Der Brick wurde zwar nicht heiss, stinkt nicht und zweigt keine aeusserlichen Schaeden, aber man weiss ja nicht...

 

Danke,

 

N8igall

 

 

Link to comment
Share on other sites

Hybrid heißt hier, dass der Motor sowohl unipolar als auch bipolar angesteuert werden kann, deshalb die 6 statt 4 Litzen. Der Stepper-Brick zum Steuern eines Schrittmotors unterstützt nur bipolar und 2-Phasen.

Ev. hilft das hier weiter:

http://www.ostermann-net.de/electronic/schritt/sm_faq.htm#faq_anschluss

und

http://de.nanotec.com/faq_143_schrittmotor_anschl%C3%BCsse.html

 

1-2 Steps pro Sec. sind ev. etwas sehr langsam, und wird oft "übersehen", mal ruhig 25 oder mehr Schrittfrequenz eingeben.

Link to comment
Share on other sites

  • 2 weeks later...

Es hat wohl an der Spannungsversorgung gelegen, die vorige war zu niedrig (oder ist auf unter 8V eingebrochen). Mit einer anderen 12.5V Spannungsversorgung und eingestellten 800-1200mA im Brick Viewer hat der Motor schoen gesteppt :)

 

Danke. Die 4V in der Modell-Bezeichnung reichen definitiv nicht aus.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...