Jump to content

Bezeichnung der Files erzeugt Unuebersichtlichkeit


Loetkolben
 Share

Recommended Posts

Hallo zusammen,

 

ich habe mir letztens 2 mal selbst die Karten gelegt, als ich Files runtergeladen habe. :selbstaerger: Da die 3. Stelle auch 2 Ziffern enthalten kann sind die Files (im Filesystem) nicht sortiert. Die 1.0.9 ist also nicht die aktuelleste Version. Die versteckt sich irgendwo "mitten drin". Noch sieht es uebersichtlich aus, aber wenn man > 30 Files vorhanden sind, vestecken sich die 2.0.2, 2.0.3 und 2.0.4 irgendwo mittendrin. Fuer das Suchen einer speziellen Version ist das hinderlich.

 

Hier ein Beispiel der 1.x.x. Reihe:

 

brickd-1.0.0_all.deb                               08-Dec-2011 10:19               58098
brickd-1.0.10_all.deb                              16-Oct-2012 07:53               75450
brickd-1.0.11_all.deb                              26-Oct-2012 14:54               76410
brickd-1.0.1_all.deb                               02-Mar-2012 14:08               58208
brickd-1.0.2_all.deb                               28-Mar-2012 19:03               60688
brickd-1.0.5_all.deb                               17-Apr-2012 14:36               68576
brickd-1.0.6_all.deb                               24-Apr-2012 16:39               68674
brickd-1.0.7_all.deb                               05-Jun-2012 16:49               69990
brickd-1.0.8_all.deb                               25-Jun-2012 13:40               70800
brickd-1.0.9_all.deb                               30-Jul-2012 10:53               74184

 

Koenntet ihr die Versionsnummer als xx.xx.xx ausgeben oder von mir aus auch als x.x.xx oder x.xx.xx. Like this:

 

brickd-1.0.00_all.deb                              08-Dec-2011 10:19               58098
brickd-1.0.01_all.deb                              02-Mar-2012 14:08               58208
brickd-1.0.02_all.deb                              28-Mar-2012 19:03               60688
brickd-1.0.05_all.deb                              17-Apr-2012 14:36               68576
brickd-1.0.06_all.deb                              24-Apr-2012 16:39               68674
brickd-1.0.07_all.deb                              05-Jun-2012 16:49               69990
brickd-1.0.08_all.deb                              25-Jun-2012 13:40               70800
brickd-1.0.09_all.deb                              30-Jul-2012 10:53               74184
brickd-1.0.10_all.deb                              16-Oct-2012 07:53               75450
brickd-1.0.11_all.deb                              26-Oct-2012 14:54               76410

 

Danke.

 

Der Loetkolben

 

 

 

Link to comment
Share on other sites

Tipp hierzu:

 

In anderen Projekten kenne ich auch eine Kennzeichnung eines Latest-Build:

 

Etwa:

brickd-latest_all.deb                              26-Oct-2012 14:54               76410
brickd-1.0.0_all.deb                               08-Dec-2011 10:19               58098
brickd-1.0.10_all.deb                              16-Oct-2012 07:53               75450
brickd-1.0.11_all.deb                              26-Oct-2012 14:54               76410

 

Der Vorteil ist, dass man sich nur eine URL merken muss und nciht erst URLs "basteln" muss um an die neueste Version zu kommen

Link to comment
Share on other sites

Hallo AuronX,

 

gibbet doch.  ;)  Here complete list:

brickd-1.0.0_all.deb                               08-Dec-2011 10:19               58098
brickd-1.0.10_all.deb                              16-Oct-2012 07:53               75450
brickd-1.0.11_all.deb                              26-Oct-2012 14:54               76410
brickd-1.0.1_all.deb                               02-Mar-2012 14:08               58208
brickd-1.0.2_all.deb                               28-Mar-2012 19:03               60688
brickd-1.0.5_all.deb                               17-Apr-2012 14:36               68576
brickd-1.0.6_all.deb                               24-Apr-2012 16:39               68674
brickd-1.0.7_all.deb                               05-Jun-2012 16:49               69990
brickd-1.0.8_all.deb                               25-Jun-2012 13:40               70800
brickd-1.0.9_all.deb                               30-Jul-2012 10:53               74184
brickd-2.0.0_amd64.deb                             22-Jan-2013 16:51               31552
brickd-2.0.0_armhf.deb                             22-Jan-2013 17:16               31892
brickd-2.0.0_i386.deb                              22-Jan-2013 16:53               30450
brickd-2.0.1_amd64.deb                             25-Jan-2013 18:04               32802
brickd-2.0.1_armhf.deb                             25-Jan-2013 18:21               33038
brickd-2.0.1_i386.deb                              25-Jan-2013 18:21               31674
brickd-2.0.2_amd64.deb                             07-Feb-2013 14:56               33646
brickd-2.0.2_armhf.deb                             07-Feb-2013 15:16               33776
brickd-2.0.2_i386.deb                              07-Feb-2013 15:03               32340
brickd-2.0.3_amd64.deb                             08-Feb-2013 11:45               33638
brickd-2.0.3_armhf.deb                             08-Feb-2013 11:57               33776
brickd-2.0.3_i386.deb                              08-Feb-2013 11:47               32338
brickd-2.0.4_amd64.deb                             03-Apr-2013 09:03               33898
brickd-2.0.4_armhf.deb                             03-Apr-2013 09:09               33958
brickd-2.0.4_i386.deb                              03-Apr-2013 09:05               32546
brickd_linux_latest_amd64.deb                      03-Apr-2013 09:43               33898
brickd_linux_latest_armhf.deb                      03-Apr-2013 09:43               33958
brickd_linux_latest_i386.deb                       03-Apr-2013 09:43               32546

 

Aendert aber nichts an der Tatsache, dass man bei der Suche nach letzen 1.x.x Version suchen muss.  ;)  Auch auf meinem Filesystem erzeugt das Unordnung.

 

Ich denke das ist ein Prio 5 Problemchen, aber in einer freien Minute kann man ja mal darueber nachdenken.  :)

 

Der Loetkolben

Link to comment
Share on other sites

Hallo AutonX,

 

das hing hiermit zusammen:  [brickd] Version v2 laesst sich nicht starten. Mit v1 Version kein Problem

 

Hier wollte/musste ich dann beim Fallback die letzte alte 1.x.x Version benutzen und habe dann die 1.0.9 anstelle der "oben" versteckten 1.0.11 Version genommen. Das hatte fuer mich keine weiteren Auswirkungen, aber es hat mich veranlasst diesen Beitrag zu schreiben.

Je mehr Versionen in Zukunft kommen und so besser sollte man sie verwalten/sortieren koennen. Sozusagen eine Investition in die Zukunft.  :)

 

Der Loetkolben

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...