Jump to content

[Chibi] Bugs...


Nic
 Share

Recommended Posts

Ich habe immer noch Probleme mit den Chibi-Ext.

 

Im bestehenden Funknetz von 3 Chibi-Slaves - im Master-Chibi wurde dazu als Slave-Adressen 1,2,3 hinterlegt - möchte ich einen 4. hinzufügen.

 

1) Doppelbelegung der Slave-Adresse

Um diesen 4.Empfänger mal schnell zu testen, habe ich als Adresse statt der 4, die 1 im Slave angegeben, also quasi doppelt belegt. Alle anderen 3 sind aber nicht in Betrieb. Trotzdem bekomme ich keine Verbindung zw. Master und Slave. Zumindest im BrickViewer nicht zu sehen.

 

Wenn ich mich recht erinnere, sah man aber den Empfangspegel des Master-Chibis bei ca. 39dBm im BrickV; war der Slave aber ausgeschaltet bleib dieser Wert bei 0. Warum sehe den Slave nicht, sondern erst wenn ich alle Slaves einschalte und dem 4. und neuen Chibi-Empf. die Adresse 4 vergebe ?

Gibt es hier ein Darstellungsproblem im BrickViewer ?

Werden die Slave-Adressen im Master-Chibi mit der Uid zusammen abgelegt, sodaß ein weiterer Slave, mit der gleichen Adresse abgelehnt wird ?

 

2) Uraltes Problem, ich hatte das auch hier im Forum seit April gemeldet und langsam wird mir das zu bunt :P:o??? beim Betrieb von 5 Slaves. Wenn eines der Slaves (aus der im Master-Chibi hinterlegten Liste) nicht eingschaltet ist, sind alle nachfolgenden der Liste nicht erreichbar. Soll heißen wenn ich nur den 4.Slave (Add.4) benutzen möchte, muss ich alle anderen von 1-3 einschalten. Ist das so gewollt ?

Ich möchte die Empfänger in versch.Situationen einsetzen können, manchmal benutze ich nur 2+3, oft aber nur 1+4, nur alleine 3 kann auch sein.

 

Master-FW 1.4.4, BrickD, BrickV auf aktuelle Version.

Link to comment
Share on other sites

Zu 1):

Wenn ich für die Master-Chibi-Adresse statt 0 eine 1 vergebe, geht das problemlos. Komisch ich dachte eine 0 als Master-Adresse wäre legitim.

Zu 2):

Geht auch mit dem o.g. Workaround weiterhin nicht, alle Bugfixes auch im Zusammenhang mit WIFI und/oder RS485 haben nichts bewirkt:

http://www.tinkerunity.org/forum/index.php/topic,715.msg4598.html#msg4598

 

Ich kann einen bestimmten Slave nur dann verbinden und kommunizieren, wenn die Slave-Liste im Master-Chibi entsprechend angepasst wird, d.h. alle Slaves, die nicht gebraucht werden, aus der Liste entf.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...