Jump to content

Bindings: Version, Requirements etc.


Recommended Posts

Statt unter VS2010, habe ich mal testweise unter VS2008 compiliert und ich bekomme einen Fehler und Hinweis auf nicht unterstütze Features in Vs2008.

Gibt es bei den Bindings Angaben zur unterstützten Version und ggf. Requirements zu den IDEs ?

vs2008.png.2e04a0a13d4e54d03789e0076a0cc5f3.png

Link to comment
Share on other sites

Optional Arguments gibt es erst ab C# 4.0, ich werde mal auf Github nen Patch dafür vorschlagen.

 

Den kannst du auch einfach selbst machen:

//das ist neu
public bool TryDequeue(out byte[] value) {
  return TryDequeue(value, Timeout.Infinite);
}

//beim parameter das "= foo" weglassen
public bool TryDequeue(out byte[] value, int timeout) {
//hier alles wie immer
}

 

LG

Jan

Link to comment
Share on other sites

Also die Klasse in der das Problem auftritt wurde nur gebaut um .NET 2.0 kompatibel zu bleiben. Also würde ich erstmal denken, dass das angestrebte Ziel alles >= .NET 2.0 ist. Alles unter 2.0 macht denke ich auch keinen Sinn.

Link to comment
Share on other sites

VS2008 unterstützt > net 2.0, also 3.5, trotzdem tritt dort der Fehler auf.

Die fehlenden Versionsangaben betr. auch Java und Phyton. Kein Mensch weiß, welche Entw.Umgebung er/sie mindestens zu nehmen hat, oder habe ich was übersehen ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...