Jump to content

Doncarlos

Members
  • Content Count

    33
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. Hi, also ich hab nun hier einen Raspi3 vor mir liegen und hatte bis gerade eben noch ein ähnliches Problem. Allerdings war dort schon nach 2-3 Sekunden nur noch Blödsinn gekommen. Nach etwas Suchen hat sich beim neuen Raspi wohl etwas mit einem internen Taktgeber geändert. Ich hab das so verstanden, dass wenn der aus dem gleichgewicht kommt, eben die Nachricht auch dahin ist.
  2. Hallo, etwas schlauer bin ich jetzt auch. Ein bestellter Optokoppler bringt die Anlage sofort zum abschalten=> bringt also nichts irgendwelche Fehlspannungen oder sowas konnte ich nun auch nicht messen; die Masse ist auch durchgehend bis zum RED Brick ein bestellter USB-COM Adapter bringt auch den Laptop in die Lage ohne Probleme die Signale zu lesen. An der Stelle bin ich raus, das scheint ein elektrisches Problem zu sein....
  3. Gleich das ganze Projekt auf einmal ist auch zuviel. Der Anfang ist Doku wälzen/fressen. Vielleicht bringt ihr dann das ein oder andere Beispiel ans Laufen und könnt dann euere Maschine konzipieren. Wie war das ? Man muss zuerst gehen können bevor man läuft oder sowas :-)
  4. Meine RS232 Signale werden über ein 1m Cat5e Kabel zum Adapter/RS232Bricklet geführt. Das Bricklet ist mit einem 10cm Kabel am Master befestigt. Der Master steckt direkt am RED Brick. Ich könnte anbieten gewisse Ereignisse und Sachen mitzuloggen und so den Langzeittest zu unterstützen. Was mir in meinen Logs aufgefallen ist, dass die Verbindung oft wegbricht; dank "robustem" Ansatz mit Enumerierungs Event etc ist das ja egal; Aber warum bricht die Verbindung überhaupt weg ? RED+Master+RS232 sind ja fest miteinander verbunden. Mhh.. bisher hatt eich nur den CPU/Speicher Verlauf meines eigenen Programs im Blick, vielleicht sollte ich auch mal einen Blick auf den Brickd werfen.
  5. Hi, das ist eine große Frage. Als erstes wäre aber unbedingt ein Java Tutorial wichtig. Ohne das wirds schwierig. Was soll die Maschine den können/machen ? Schöne Grüße
  6. @Flyingdoc: Konntest Du eine zeitliche Abhängigkeit erkennen? Passiert das erst mit längerer Laufzeit oder auch schon vorher ?
  7. Hi, also ich hatte nun ohne weitere Tests das Bricklet an der Anlage laufen. - einmal hatt sich die Anlage aufgehängt - ein anderes mal sind nach 2 Tagen Laufzeit mit korrekten Daten wieder Schrottdaten gekommen. Allerdings anders schrottig; so ca. jeder 5-10 te Buchstabe war dann ein Punkt und die Länge hat noch so lala gepasst. Interessant war da auch, dass der Brickv gar keine Details mehr zum Red Brick angezeigt hat, er hat nur noch ewig aktualisiert. Nach einem Reboot ging es wieder. 2 Tage Laufzeit scheint eine Schallmauer bei meinem Aufbau zu sein. Ich hoffe ich komme dieses WE zu den versprochenen Messungen und Tests. Mittlerweile liegt auch ein galvanischer Trenner und ein USB-COM Adapter zuhause rum mit denen ich weiter testen kann.
  8. Genauso defekt wie bisher beschrieben. Den Rest werde ich bei Gelegenheit ausprobieren/messen
  9. Hi, Aufbau "alter Laptop": - Netzteil des Laptops an Steckdose - Laptop - USB-Kabel liefert Strom an den Stack - Stack (RED+WLAN, Master, RS232) - RS232 Kabel - Heizung ==> Daten auslesen funktioniert in allen Varianten (Brickv, Programm auf dem RED Brick ...) Aufbau "neuer Laptop": - Laptop im Akku Betrieb - USB Kabel liefert Strom an den Stack - Stack (RED+WLAN, Master, RS232) - RS232 Kabel - Heizung ==> Daten kommen zerstört an (via USB Kabel am Brickv oder auch im Programm am RED) Aufbau RED-Standalone: - diverse USB Stecker-Netzteile - Stack (RED+WLAN, Master, RS232) - RS232 Kabel - Heizung => Daten auslesen funktioniert nicht (Brickv über WLAN, Programm auf dem Red ...); Laptop ist nur über WLAN verbunden Zum RS232 Kabel: Der Anschluss ist als RJ45 Stecker aus der Heizung herausgeführt und mittels eines dummen Adapters (keine Elektronik) auf RS232 gemünzt. Derzeit läuft mein Programm gut und stabil in der Konfiguration "alter Laptop", wobei der Laptop hier nur Strom über USB zur Verfügung stellt. Könnte das auch mit der Qualität/Stabilität der Spannung aus den Netzteilen zu tun haben ? Messgeräte hab ich genug, nur weiß ich gerade nicht was es zu messen gilt :-/ Dankeschön für die Unterstüzung!
  10. Hallo, also, heute bin ich ein bischen schlauer: - Nullmodem Kommunikation zwischen zwei Laptops geht ohne weiteres - Stapel am "neuen" Laptop an der Heizung produziert den bekannten Müll - Stapel am 5V Netzteil produziert auch nur Müll - Stapel am "alten" Laptop funktioniert wie gewollt Was ist der Unterschied ? Der Akku des alten Laptops ist defekt, er hing bei allen Versuchen am klassischen Netzteil mit 3 poligem Schukostecker. Das ganze ist beliebig oft reproduzierbar. Scheint also eher ein elektrisches Problem zu sein. Ich hab hier mehrere 5V Netzteile zur Verfügung, das klassische HandyLadegerät, eine Wandwartze mit mehr Bums von einem Tablet, alle haben das gleiche Problem. Was könnte da nun helfen ? Eine galvanische Trennung an der RS232 Schnittstelle ? Ein anderes Netzteil ? aber welches ? Noch was zum GPIO Anschluss: In der Doku steht, der Anschluss wäre für Profis verwendbar. Aber nach dem was ich jetzt lese, gibt es selbst für Profis nicht mal eine theoretische(!) Chance (wegen nicht verfügbarem Kabel) das Ding zu nutzen. Das ist schon doof. Wenn das nicht geht, sollte das auch in der Doku gar nicht erwähnt sein.Software krieg ich hin, Hardware nicht...
  11. Nach etwas suchen glaube ich verstanden zu haben, dass es das Kabel nicht nur hier nicht, sondern nirgends gibt.... Das ist schade. Ist ja seltsam, dass es Stecker gibt, für die es keine Kabel zu kaufen gibt. Ein Kabel wäre nett. Ein kleines Platinchen dazu wäre noch netter. Gibt es da Planungen? Wisst ihr zumindest wann es irgendwo so ein Kabel gibt ?
  12. Das Design ist doch nett bzw. mir vollkommen egal ;-)
  13. Hi, ich hab da noch eine Zwischenfrage. Ich bin beim RED Brick über dessen GPIO Schnittstelle und dessen UART Pins gestolpert. Die Pins können doch auch RS232, richtig ? Ja, mir ist bewusst, dass ich dann ausserhalb der Brick-Welt bin. Das wäre mir durchaus auch recht. Sind diese Pins dann ähnlich wie beim Raspberry zu behandeln ? Soweit ich das sehe braucht dieser ja noch einen Pegelwandler (MAX323IC) on top. Dankeschön und schöne Grüße BTW: Ich hab die Threds gefunden, in denen es um ein Kabel/Board für den GPIO Port geht. Alleine schon weil es dort die Spannung nochmal abzugreifen gibt wäre ich auch für so ein Kabel.
×
×
  • Create New...