Jump to content

LCD 20x4 V1.2 Probleme mit Brickviewer Updates


Loetkolben
 Share

Recommended Posts

Hallo zusammen,

 

ich habe hier ein LCD 20x4 mit der FW 2.0.5 gehabt. Der Brickviewer 2.0.5 hat mir das update auf die 2.0.6 nicht angezeigt (Latest 0.0.0). Das konnte ich noch nachvollziehen, da die 2.0.5 wohl eine dieser "Mixversionen" war.

 

Das manuelle angestossene Update auf die 2.0.6 V1.2 verlief problemlos, ABER es wird immer noch (Latest 0.0.0) angezeigt. Siehe Attachment. Koenntet ihr das bitte korrigieren? Liegt das an den Verzeichnissen oder muss der Brickviewer da upgedated werden?

 

Der Loetkolben

brickv205.JPG.f19b5b277cb849dbec0aef6c0bb9bc0f.JPG

Link to comment
Share on other sites

Das wird mit dem nächsten Brick Viewer Update gefixt, im GIT ist der Fix schon drin.

 

Die beiden LCD Versionen haben den gleichen Device Identifier (d.h. sie nutzen die gleichen API Bindings). Das kann der aktuelle Brick Viewer noch nicht abbilden (die nächste Version kann es dann).

Link to comment
Share on other sites

Wird das in Zukunft auch so bleiben?

 

Ja, sonst müssten wir entweder die API duplizieren (mit allem drum und dran, Dokumentation etc) oder den Generatoren beibringen das ein "Device" unterschiedliche Device Identifier haben kann (das wäre eine Monster-Aufgabe).

 

Da ist es viel einfacher Behandlung dafür in den Brick Viewer einzubauen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...