Jump to content

RED C++ QT Version anheben


Recommended Posts

Ich habe das mal kurz getestet, so sollte es gehen:

 

Am einfachsten ist es wenn dein RED Brick ein Internetverbindung hat. Dann folgenden Schritte ausführen auf dem RED Brick:

 

sudo vim /etc/apt/sources.list

 

Oder mit irgendeinem anderen Editor /etc/apt/sources.list bearbeiten und folgende Zeile anhängen:

 

deb [arch=armhf] http://ftp.debian.org/debian wheezy-backports main contrib non-free
deb-src http://ftp.debian.org/debian wheezy-backports main contrib non-free

 

Dann diese drei Befehle ausführen:

 

sudo apt-get update
sudo apt-get install qtchooser
sudo apt-get install qt5-default

 

Am Ende hast du dann Qt4 durch Qt5 ersetzt. Das wird dir dann auch brickv deinstallieren, da der Qt4 braucht. Das sollte aber kein Problem sein.

 

Link to comment
Share on other sites

  • 1 year later...

Hallo photron.

 

Ich versuche gerade wieder einmal die QT Version auf die aktuelle anzuheben.

Get aber nicht. Hier mal das was mir das Linux als Meldung ausgibt.

 

Vielleicht kannst du mir einen Tipp geben. ;D

 

tf@red-brick:~$ sudo apt-get install qtchooser
[sudo] password for tf:
Reading package lists... Done
Building dependency tree
Reading state information... Done
qtchooser is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 401 not upgraded.
tf@red-brick:~$ sudo apt-get install qt5-default
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
qt5-default : Depends: qtbase5-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
tf@red-brick:~$

Link to comment
Share on other sites

Die Frage ist warum qtbase5-dev nicht installiert wird.

 

Versucht mal dies:

 

sudo apt-get install qtbase5-dev

 

Wenn apt-get da auch wieder so was sagt wie:

 

qt5-default : Depends: qtbase5-dev but it is not going to be installed

 

Dann versuch die Kette weiter abzusteigen und das Package zu installieren, was nicht installiert wird, bis du eine andere Meldung bekommst die dann hoffentlich aufschlussreicher ist.

 

Link to comment
Share on other sites

Folgender Fehler kommt.

 

root@red-brick:/home/tf# sudo apt-get install qtbase5-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
qtbase5-dev : Depends: libgles2-mesa-dev but it is not going to be installed or
                        libgles2-dev but it is not installable
E: Unable to correct problems, you have held broken packages.

Link to comment
Share on other sites

Beim Versuch das libgles2-mesa zu installieren kommt folgender Fehler.

 

sudo apt-get install libgles2-mesa-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgles2-mesa-dev : Depends: libgles2-mesa (= 10.3.2-1+deb8u1) but 2:1.0-1 is to be installed
                     Depends: libegl1-mesa-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Link to comment
Share on other sites

  • 1 month later...

Hallo proton,

 

ich immer noch. ;D

Ich versuche immer noch die QT Verion anzuheben.

Funktioniert leider nicht. Bekomme immer noch die Fehlermeldung.

 

root@red-brick:/home/tf# apt-get install qtbase5-dev

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

qtbase5-dev : Depends: libgles2-mesa-dev but it is not going to be installed or

                        libgles2-dev but it is not installable

E: Unable to correct problems, you have held broken packages.

 

sudo apt-get update läuft ohne Fehlermeldung durch.

Es ist das 1.7er Image.

Link to comment
Share on other sites

Okay, ich denke ich hab's. Ich kann zumindest Qt5 installieren und ein OpenGL Beispiel kompilieren und laufen lassen.

 

Folgendes habe ich getan:

 

[*]Frisches 1.8er Image auf SD Karte gespielt

[*]Die angehängten Packages heruntergeladen und auf den RED Brick übertragen

[*]sudo dpkg -i libegl1-mesa_2-10.3.2-1_armhf.deb

[*]sudo dpkg -i libegl1-mesa-dev_2-10.3.2-1_armhf.deb

[*]sudo dpkg -i libgles1-mesa_2-10.3.2-1_armhf.deb

[*]sudo dpkg -i libgles2-mesa_2-10.3.2-1_armhf.deb

[*]sudo dpkg -i libgles2-mesa-dev_2-10.3.2-1_armhf.deb

[*]sudo apt-get update

[*]sudo apt-get install qt5-default

Jetzt sollte Qt5 installiert sein und funktionieren.

libegl1-mesa_2-10.3.2-1_armhf.deb

libegl1-mesa-dev_2-10.3.2-1_armhf.deb

libgles1-mesa_2-10.3.2-1_armhf.deb

libgles2-mesa_2-10.3.2-1_armhf.deb

libgles2-mesa-dev_2-10.3.2-1_armhf.deb

Link to comment
Share on other sites

Ein riesiges Dankeschön für eure Hilfe.

Das Installieren funktioniert. Eine Frage aber nocht. Bekomme ich über die Konsole herraus, welche QT Version es genau installiert hat?

Ich brauche nämlich die QSerialPort Bib. Und die ist laut Meldung beim Compilieren nicht dabei. Ist erst ab QT 5.1 enthalten.

Hab schon den Install Pfad gesucht und nur QT4 gefunden.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...