Jump to content
frem

openhab2 using 2 masterbricks

Recommended Posts

Hi,

 

I've got a setup with two master bricks with wifi extension and Remote Switch Bricklet connected to each.

 

The problem is, that I always get the following error:

"COMMAND no tinkerforge device found for command for item uid: EGJ subId: OG_R_Schlafh"

 

I get this error for all devices with uid EGJ

 

Also deleted /var/lib/openhab2/config/org/openhab/tinkerforge.config to clear the cache, but that did not help...

 

Any idea, why this is happening?

Below is my tinkerforge.cfg

 

Thanks and best regards

Burkhard

 

tinkerforge:hosts=192.168.0.133:4223 192.168.0.75:4223

tinkerforge:ars1.uid=jMm
tinkerforge:ars1.type=bricklet_remote_switch
tinkerforge:ars1.typeCDevices=EG_L_WZ EG_L_Flur EG_R_WZ EG_R_EZ EG_R_KU

tinkerforge:brs2.uid=EGJ
tinkerforge:brs2.type=bricklet_remote_switch
tinkerforge:brs2.typeCDevices=OG_R_GZR OG_R_GZL OG_L_Schlaf OG_R_Schlafv OG_R_Schlafh

### Erdgeschoss
#Licht
tinkerforge:rs_EG_L_WZ.uid=jMm
tinkerforge:rs_EG_L_WZ.subid=EG_L_WZ
tinkerforge:rs_EG_L_WZ.type=remote_switch_c
tinkerforge:rs_EG_L_WZ.systemCode=O
tinkerforge:rs_EG_L_WZ.deviceCode=1

tinkerforge:rs_EG_L_Flur.uid=jMm
tinkerforge:rs_EG_L_Flur.subid=EG_L_Flur
tinkerforge:rs_EG_L_Flur.type=remote_switch_c
tinkerforge:rs_EG_L_Flur.systemCode=O
tinkerforge:rs_EG_L_Flur.deviceCode=9

# Rolladen
tinkerforge:rs_EG_R_WZ.uid=jMm
tinkerforge:rs_EG_R_WZ.subid=EG_R_WZ
tinkerforge:rs_EG_R_WZ.type=remote_switch_c
tinkerforge:rs_EG_R_WZ.systemCode=O
tinkerforge:rs_EG_R_WZ.deviceCode=10

tinkerforge:rs_EG_R_EZ.uid=jMm
tinkerforge:rs_EG_R_EZ.subid=EG_R_EZ
tinkerforge:rs_EG_R_EZ.type=remote_switch_c
tinkerforge:rs_EG_R_EZ.systemCode=O
tinkerforge:rs_EG_R_EZ.deviceCode=11

tinkerforge:rs_EG_R_KU.uid=jMm
tinkerforge:rs_EG_R_KU.subid=EG_R_KU
tinkerforge:rs_EG_R_KU.type=remote_switch_c
tinkerforge:rs_EG_R_KU.systemCode=O
tinkerforge:rs_EG_R_KU.deviceCode=3

## Obergeschoss
#Licht
tinkerforge:rs_OG_L_Schlaf.uid=EGJ
tinkerforge:rs_OG_L_Schlaf.subid=OG_L_Schlaf
tinkerforge:rs_OG_L_Schlaf.type=remote_switch_c
tinkerforge:rs_OG_L_Schlaf.systemCode=O
tinkerforge:rs_OG_L_Schlaf.deviceCode=5

#Rolladen
tinkerforge:rs_OG_R_GZL.uid=EGJ
tinkerforge:rs_OG_R_GZL.subid=OG_R_GZL
tinkerforge:rs_OG_R_GZL.type=remote_switch_c
tinkerforge:rs_OG_R_GZL.systemCode=O
tinkerforge:rs_OG_R_GZL.deviceCode=14

tinkerforge:rs_OG_R_GZR.uid=EGJ
tinkerforge:rs_OG_R_GZR.subid=OG_R_GZR
tinkerforge:rs_OG_R_GZR.type=remote_switch_c
tinkerforge:rs_OG_R_GZR.systemCode=O
tinkerforge:rs_OG_R_GZR.deviceCode=15

tinkerforge:rs_OG_R_Schlafv.uid=EGJ
tinkerforge:rs_OG_R_Schlafv.subid=OG_R_Schlafv
tinkerforge:rs_OG_R_Schlafv.type=remote_switch_c
tinkerforge:rs_OG_R_Schlafv.systemCode=O
tinkerforge:rs_OG_R_Schlafv.deviceCode=13

tinkerforge:rs_OG_R_Schlafh.uid=EGJ
tinkerforge:rs_OG_R_Schlafh.subid=OG_R_Schlafh
tinkerforge:rs_OG_R_Schlafh.type=remote_switch_c
tinkerforge:rs_OG_R_Schlafh.systemCode=O
tinkerforge:rs_OG_R_Schlafh.deviceCode=6

 

Share this post


Link to post
Share on other sites

Hallo Burkhard,

 

schau doch mal im Log ob dein EGJ Bricklet erkannt wurde oder ob es Fehlermeldungen gab.

 

Gruß,

Theo

 

Share this post


Link to post
Share on other sites

Hi Theo,

 

erstmal vielen Dank für deinen Tip. Ich habe mal das logging für tinkerforge auf debug gesetzt und einen openhab restart gemacht.

Ich sehe im Log, dass die config korrekt geparsed wird, aber ich sehe nur die folgende Zeile für das bricklet jMm, eine ähnliche Zeile für EGJ sehe ich nicht:

2019-05-08 20:13:02.274 [DEBUG] [kerforge.internal.TinkerforgeBinding] - TFINIT adding/enabling device jMm with config: org.openhab.binding.tinkerforge.internal.model.impl.BrickletRemoteSwitchConfigurationImpl@1cdd1fe (typeADevices: null, typeBDevices: null, typeCDevices: EG_L_WZ EG_L_Flur EG_R_WZ EG_R_EZ EG_R_KU)

 

 

Ich habe das log angehängt...ich habe einige exceptions beim Start von openhab die mir aber nicht nach dem selben Problem aussehen...hängt es vielleicht doch damit zusammen?

 

Gruß

Burkhard

openhab.log

Share this post


Link to post
Share on other sites

Hallo Burkhard,

 

könnte eine race condition sein. Laut Log werden beide Master Bricks erkannt und auch beide Remote Switch Bricklets, aber nur auf das jMm Bricklet wird das "enable" aufgerufen.

Das Auftauchen der Bricks/Bricklets und die Verfügbarkeit der Config sind asynchron, das muss das Binding handeln, hier könnte ein Bug sein. Du könntest versuchen OH zu starten wenn nur einer oder keiner der Master Bricks online sind und dann die Bricks erst nach Beendeten OH Startup anschalten. Das ist aber eine wilde Vermutung, ich hab nicht in den Code geschaut, da dieser EOL ist und ich nichts mehr fixen kann. Im besten Fall finden wir einen Workaround.

Ein natives OH2 TF-Binding ist in Arbeit aber das RemoteSwitch Bricklet wird derzeit noch nicht unterstützt. Das wird kommen, kann aber noch ein paar Monate dauern.

 

Gruß,

Theo

 

 

Share this post


Link to post
Share on other sites

Hallo,

 

ich habe das Problem gefunden. Ich habe nicht gewusst, dass RemoteSwitch 2.0 nicht kompatibel mit dem Openhab binding ist. Beim experimentieren mit dem deaktivierten Masterbrick habe ich ich dies durch Zufall festgestellt.

Der Bricklet wird vom openhab Plugin deshalb scheinbar nicht richtig erkannt.

 

Gruss

Burkhard

Share this post


Link to post
Share on other sites

Ja klar, das RemoteSwitch 2.0 wird nicht unterstützt da musst du leider auf das neue Binding warten.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...