Jump to content

Warp2 baut keine Verbindung zu MQTT Broker auf


PatrickM
 Share

Recommended Posts

Hallo zusammen,

irgendwie schaffe ich es nicht, meine Warp2 Smart mit meinem Mosquitto MQTT Broker zu verbinden. Dieser läuft auf einem separaten RaspberryPi und kann von anderen Clients angesprochen werden.

In der Warp2 Web-GUI wird bei MQTT-Status "Getrennt" angezeigt und im Ereignis-Log erscheint regelmäßig "Connecting to MQTT broker".

Kann mir jemand einen Tipp geben? Anbei noch das Ereignis-Log und der Debug-Report.

PS: Ich weiß nicht, ob das relevant ist, aber aktuell betreibe ich die Warp2 noch testweise 1-phasig angeschlossen auf meiner Werkbank liegend ohne verbundenes Auto.

Vielen Dank schon mal, ich wäre über jeden Hinweis dankbar.

Patrick

event-log-2021-10-06T06-58-59-394Z.txt debug-report-2021-10-06T06-58-56-525Z.json

Link to comment
Share on other sites

1 hour ago, Krystman said:

Du hast nicht auch zufällig den Deckel mit abgezogenem Button auf der Werkbank liegen beim testen, oder? ;-)

:D Die Idee hatte ich auch, aber dann würden im Log nicht die ganzen Verbindungsversuche aufschlagen.

Ich wühle mich gleich nochmal durch die MQTT-Bibliothek, in der Hoffnung herauszufinden, wo es bei dir hakt. Schonmal als Teaser: Jedes "Connecting to MQTT broker" sollte danach einen Fehler und/oder ein "Disconnected" mit Fehlercode erzeugen (das sind in der Firmware Callbacks aus der MQTT-Bibliothek). Da das nicht passiert, muss irgendetwas in der Bibliothek verquer sein. Auffällig ist, dass die Box relativ lange braucht, um einen IP zu beziehen:

5407        Ethernet connected
8376        Had to configure softAP ip 1 times.
10377       Soft AP started.
10377           SSID: warp2-WFk
10377           hostname: warp2-WFk
10730           IP: 10.0.0.1
10849       Connecting to MQTT broker
12568       Ethernet MAC: A8:03:2A:31:66:2F, IPv4: 192.168.12.24, Full Duplex, 100 Mbps
12569       Ethernet got IP address: 192.168.12.24.
12580       Network connected. Stopping soft AP
70861       Connecting to MQTT broker

Das dauert so lange, dass der erste Verbindungsversuch passiert, wenn die LAN-Verbindung noch nicht besteht. Eventuell kommt da das Routing durcheinander und versucht über den Soft-AP zu gehen, obwohl der ja gestoppt ist.

Ich melde mich nochmal, wenn ich mehr weiß.

Link to comment
Share on other sites

Du hast mich auf eine Idee gebracht: Ich habe die Box jetzt per WLAN ins Netz gehangen, und siehe da, die Verbindung zum MQTT Broker wird aufgebaut (event-log-2021-10-06T13-30-53-438 -  Nur WLAN.txt)

Aus Interesse habe ich zusätzlich den LAN-Stecker wieder eingesteckt. Die Web-Gui Box war dann (wie zu erwarten) über beide IP-Adressen (LAN und WLAN) zu erreichen und die Verbindung wurde zum Broker wurde wieder aufgebaut. (event-log-2021-10-06T13-39-17-660Z - LAN und WLAN.txt)

Nun habe ich das WLAN wieder abgeschaltet und die Verbindung zum Broker schlägt wieder fehl (event-log-2021-10-06T13-44-40-366Z - Nur LAN.txt) - Aber nun wird ein Fehler des mDNS responder "Error setting up mDNS responder!" ins Log geschrieben, den habe ich vorher nicht gesehen.

Edit: Ich habe beim letzten Versuch zusätzlich den WLAN-Access-Point von "Nur Fallback" auf "Deaktiviert" gesetzt.

Vielleicht hilft Dir das bei der Suche.

 

event-log-2021-10-06T13-44-40-366Z - Nur LAN.txt event-log-2021-10-06T13-39-17-660Z - LAN und WLAN.txt event-log-2021-10-06T13-30-53-438 - Nur WLAN.txt

Edited by PatrickM
Link to comment
Share on other sites

18 hours ago, PatrickM said:

Nun klappt es auch über die reine LAN-Verbindung ohne parallele WLAN-Verbindung: Ich habe die IP-Konfiguration der LAN-Verbindung auf statische IP umgestellt. Damit scheint sich die Verbindung schneller aufzubauen.

Aus meiner Sicht bestätigt sich damit Deine o.g. Vermutung. 

Das deckt sich soweit mit den Tests, die ich hier gemacht habe.

Soweit du mit statischen IPs leben kannst, würde ich da erstmal nicht mehr Zeit investieren. Ich habe sowieso vor in nächster Zeit die ganze MQTT-Implementierung durch eine andere zu ersetzen, deshalb würde es sich nicht lohnen das weiter zu debuggen, solange MQTT grundlegend funktioniert.

19 hours ago, PatrickM said:

Aber nun wird ein Fehler des mDNS responder "Error setting up mDNS responder!" ins Log geschrieben, den habe ich vorher nicht gesehen.

Das ist ein bekanntes Problem, ich bin aber bisher noch nicht dazu gekommen es zu fixen.

Link to comment
Share on other sites

vor 3 Stunden schrieb rtrbt:

Soweit du mit statischen IPs leben kannst, würde ich da erstmal nicht mehr Zeit investieren.

Ist für mich völlig OK, die WB bekäme über den DHCP auch immer die selbe IP, deswegen macht es für mich keinen Unterschied.

Vielen Dank für die schnelle Analyse

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...