Jump to content

Update RED Image auf aktuelle Debian Version + QT und OpenGL


Recommended Posts

Hallo. Nach langer Zeit habe ich mal wieder eine Frage.

Mein HUD Projekt habe ich wieder aufleben lassen. Das Programm habe ich auf OpenGL umgestellt.

Nun bin ich dabei das RED Image auf die aktuelle Debian Version anzuheben.

Das Debian ist soweit fertig. Nur hapert es noch bei der QT Installation.

Vielleicht könntet ihr mich hier unterstützen. Wenn ich QT instllieren möchte schmeisst er noch Fehler aus.

 

sh-5.1# apt-get install qt5-default
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libqt5gui5 : Depends: libegl1 but it is not going to be installed
 libqt5webkit5 : Depends: libegl1 but it is not going to be installed
 qt5-default : Depends: qtbase5-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Wenn ich nun apt --fix-broken install mache kommt folgende Meldung

 

sh-5.1# apt --fix-broken install
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libegl1
The following NEW packages will be installed:
  libegl1
0 upgraded, 1 newly installed, 0 to remove and 423 not upgraded.
103 not fully installed or removed.
Need to get 0 B/29.5 kB of archives.
After this operation, 76.8 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 195335 files and directories currently installed.)
Preparing to unpack .../libegl1_1.3.2-1_armhf.deb ...
Unpacking libegl1:armhf (1.3.2-1) ...
dpkg: error processing archive /var/cache/apt/archives/libegl1_1.3.2-1_armhf.deb (--unpack):
 trying to overwrite '/usr/lib/arm-linux-gnueabihf/libEGL.so.1', which is also in package libegl1-mesa 2:10.3.2-1
Errors were encountered while processing:
 /var/cache/apt/archives/libegl1_1.3.2-1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Da ich nun noch lange kein Linux Spezi bin frage ich ob mir jemand hilfreich unter die Arme greifen kann.

Das Programm an sich ist zu 60 % fertig und alle Anzeigen und Menüs laufen.

Ausserdem will ich versuchen die den Desktop nicht zu laden sondern das ganze ohne diesen laufen zu lassen. Dazu müsste ich nur noch rausfinden welche Bibliothek ich dazu laden muss. Die Umstellung auf OpenGL hat ja schon am PC logischer weise zur massiven Leistungssteigerung geführt.

 

An der Optik tüftle ich noch. Das Bild muss ja im Focus auf unendlich gestellt werden. So ist es zumindestens bei den HUD in den Militärmaschinen.

AUssage von jemanden der da öfters mitfliegt. 😏

Ich muss mir noch die Linsen für ein Kollimator Modul besorgen, das die Lichstrahlen parralel zueinander ausrichtet und dadurch den Focus auf Uendlich ausrichtet.

Edited by FlyingDoc
Link to comment
Share on other sites

Da stehen sich die Pakete libegl1 und libegl1-mesa auf den Füssen. Beide beinhalten /usr/lib/arm-linux-gnueabihf/libEGL.so.1, dadurch müssen die beiden Pakete eigentlich also Conflicting/Replacing markiert sein, dass scheint aber nicht der Fall zu ein. Daher klappt es nicht das apt/dpkg das selbst auflösen.

Qt hängt hier von libegl1 ab. Aus irgendeinem Grund ist aber bereits libegl1-mesa installiert. Versuch mal über "sudo apt remove libegl1-mesa" das paKet zu deinstallieren, damit dir apt anzeigt wer von libegl1-mesa abhängt und dann mit deinstalliert würde.

Link to comment
Share on other sites

Das kommt dann als Ausgabe

sh-5.1# sudo apt remove libegl1-mesa
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libegl1-mesa-dev : Depends: libegl1-mesa (= 2:10.3.2-1) but it is not going to be installed
 libqt5gui5 : Depends: libegl1 but it is not going to be installed
 libqt5webkit5 : Depends: libegl1 but it is not going to be installed
 libwebkitgtk-1.0-0 : Depends: libegl1-mesa (>= 7.8.1) but it is not going to be installed or
                               libegl1-x11
                      Recommends: gstreamer1.0-plugins-base (>= 1.0.3) but it is not going to be installed
                      Recommends: gstreamer1.0-plugins-good but it is not going to be installed
 xserver-xorg-core : Depends: libegl1-mesa but it is not going to be installed or
                              libegl1 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

 

Link to comment
Share on other sites

Okay, du solltest libegl1-mesa und libegl1-mesa-dev ohne Probleme einfach deinstallieren können. Für die aktuelle Debian Version sagt die Beschreibung des libegl1-mesa Paketes: Dieses Übergangspaket kann gefahrlos entfernt werden.

Nur hast du gerade apt in die Ecke gedrängt und es lässt dich jetzt wahrscheinlich libegl1-mesa nicht deinstallieren, weil du mit den Qt Paketen da so halb hängst.

Hast du das auf einem frischen Image veruscht und kannst einfach von vorne anfangen, oder musst du das jetzt retten? Ansonsten ist es villeicht das einfachste du fängst mit eibnem frischen Image an und deinistallierst zu erst libegl1-mesa.

  • Like 1
Link to comment
Share on other sites

Hab einen früheren Stand des Image eingespielt. Jetzt bekomme ich folgenede Meldungen.

sh-5.1# apt remove libegl1-mesa
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-core : Breaks: libgl1-mesa-dri (< 18.0.5) but 13.0.6-1+b2 is to be installed
                     Recommends: default-logind or
                                 logind
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
sh-5.1# apt remove libegl1-mesa-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'libegl1-mesa-dev' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 468 not upgraded.
sh-5.1#

                                                       

Es ist also nur noch  libegl1-mesa installiert.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...