Jump to content

ESP32-Brick - keine WLAN Verbindung


Recommended Posts

ESP32-Brick kann keine Verbindung zum lokalen WLAN herstellen. Der WLAN Access Point funktioniert. Die Netzwerksuche funktioniert noch richtig.

Der Router ist eine Fritzbox 7590, mit WPA + WPA 2.

Ich habe den WLAN-Access-Point des ESP32-Brick auf Fallback gestellt. Auch das Flashen der neuesten Firmware 2.0.1 hat nichts geholfen.

Der Debug-Report zeigt unter anderem :

6,182  Wifi failed to connect to RICNET: Access Point not found. Is the reception too poor or the SSID incorrect? (201)

Der Empfang ist perfekt und die SSID ist auch korrekt. Hat jemand eine Idee ?

 

 

debug-report-esp32-ZiB-2022-05-20T13-54-23-270.txt

Link to comment
Share on other sites

  • 3 weeks later...

Moin,

Sorry dein Thread ist irgendwie untergegangen. Wenn du nach WLANs scannst, taucht dein Netz dann auf? Hast du eventuell Repeater mit dem selben Netzwerknamen und der Brick versucht sich aus irgendwelchen Gründen zu dem Repeater zu verbinden? (Das kontrolliert das BSSID-Lock) Du kannst dir die Liste der gefundenen WLANs unter http://10.0.0.1/wifi/scan_results runterladen.

Link to comment
Share on other sites

Es gibt keinen Repeater. Der WLAN-Scan zeigt mein Netzwerk an ich wähle es aus und gebe das Passwort ein. Der Router verwendet WPA und WPA 2.

Es kommt aber keine Verbindung zustande. Der Debug-Report zeigt unter anderem :

6,182  Wifi failed to connect to RICNET: Access Point not found. Is the reception too poor or the SSID incorrect? (201)

In der Zwischenzeit habe ich mit folgendermaßen eine Verbindung zustande gekriegt :

Ich habe die Router Security temporär abgeschaltet, der ESP32-Brick konnte sich dann verbinden.

Dann habe ich die Security (WPA + WPA 2) wieder aktiviert, und der ESP32-Brick kann sich seither auch mit WPA/WPA 2 verbinden.

So sollte es natürlich nicht sein. Aber zumindest habe ich den ESP32-Brick jetzt im Netzwerk.

 

Link to comment
Share on other sites

10 hours ago, ChristianRiedl said:

Dann habe ich die Security (WPA + WPA 2) wieder aktiviert, und der ESP32-Brick kann sich seither auch mit WPA/WPA 2 verbinden.

So sollte es natürlich nicht sein. Aber zumindest habe ich den ESP32-Brick jetzt im Netzwerk.

Stimmt, das sollte so nicht sein, ist auch nicht der Normalzustand: Bei der 7590 die wir hier im Netz haben funktioniert die Verbindung problemlos. Eventuell hat das Umkonfigurieren bei deiner Fritzbox den WLAN-Stack neugestartet und das hat was auch immer schiefgelaufen ist repariert.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...