Jump to content

LED Strip blinkt beim Raspi


dan

Recommended Posts

Hey liebe Community,

 

vielleicht könnt ihr mir helfen. Bisher hat mein Stack immer super funktioniert. Habe einen Master-Brick mit einem LED-Strip Bricklet aber bisher nur am Laptop angeschlossen.

 

Da ich das ganze aber in meinem neu renoviertem Zimmer ein bisschen mobiler haben wollte habe ich versucht das ganze über mein Raspberry Pi zu steuern. Die Installation des Brick Deamon hat ohne Probleme funktioniert. Auch das erste verbinden vom Brick Viewer auf meinem Laptop hat ohne Probleme geklappt. Erst als ich dann versucht habe die Farbe der LED's über den Brick Viewer zu ändern haben erst die ersten 5 LED's wie verrückt zu blinken begonnen während die anderen die gewünschte Farbe gezeigt haben. Nach wenigen Sekunden haben dann alle wie in der Disko angefangen zu blinken.

 

Ich konnte mir das nicht erklären, hat vielleicht einer von euch einen Rat für mich?

 

Grüße

Dan

Link to comment
Share on other sites

Hallo Dan,

 

ist der Zustand nach einem Neustart des Raspberrys immer noch da?

Wie versorgst du die LEDs?

Welche Version vom Raspberry Pi hast du? Die ersten hatten Probleme mit der 5V Stromversorgung über USB. Du könntest mal probieren zwischen Raspberry und dem Master Brick einen aktiven (mit eigenen 5V Netzteil) USB Hub zwischenzuschalten.

 

Grüße

Link to comment
Share on other sites

Ich habe das Raspi ganz normal mit einem USB-Netzteil angeschlossen und an den ersten USB-Port des Raspis den Master-Brick mit einem USB Kabel angeschlossen. An das LED-Bricklet habe ich das von euch versandte 5V Netzteil angeschlossen.

 

Ja nach dem Neustart des Raspi's ist der Zustand wieder genau wie zuvor. Wie meinst du das mit dem Zwischenschalten ?

 

// Edit

Ich habe rev-b des Raspi.

 

Grüße

Dan

Link to comment
Share on other sites

Hallo Dan,

 

gemeint ist damit, dass du an dein Raspberry Pi einen aktiven USB-Hub an den USB-Anschluss anschießen sollst und dann den Master-Brick dort anschließt.

 

Ein netter nebeneffekt ist, wenn du einen aktiven Hub verwendest kannst du dir die Stromversorgung des Raspberrys sparen. ;-)

Achte aber darauf, dass der Hub ein Netzteil mit > 1A hat.

 

Viele Grüße,

Nemo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...