Jump to content

Probleme mit (Leistung?) Stepperbrick


mruniversum
 Share

Recommended Posts

Hallo zusammen,

 

ich suche Hilfe bez. eines Problems mit einer Schrittmotorsteuerung bei einem Bekannten.

Ein Schrittmotor treibt einen Schlitten an, der als Längenanschlag für eine Säge dient, das dazugehörige Programm habe ich zur Verfügung gestellt.

 

Es ist aufgefallen, dass der Motor bei einer Fahrt plötzlich für eine Sekunde stoppt, dann weiter fährt, wieder stoppt usw. Um Fehler in der Mechanik auszuschließen, wurde der Motor ausgebaut. Nach dem Einschalten des Stepperbricks hat der Motor erstmal leicht hochfrequent gepfiffen (evtl nicht perfekter Decaywert), Die Achse war stabilisiert, man konnte also die Motorachse nicht drehen. Nach einer gewissen Zeit hat der Motor dann wieder rhytmisch angefangen das Pfeiffen zu unterbrechen, auch konnte in der Zeit die Achse gedreht werden.

Durch Zufall fanden wir heraus, dass der Kühlkörper vom Stepperbrick sehr heiß wird, nach einer Behandlung mit Kältespray hörte die Unterbrechung des Pfeiffens auf, und der Haltemoment vom Motor war wieder intakt.

 

Also scheint es so, als ob der Stepperbrick überhitzt, also zu schwach für den Motor ist...?

 

Testweise wurde der max. Strom von 2000mA auf 1600mA zurückgedreht. Damit lief der Motor den ersten Tests nach zu Urteilen durch. Wird jetzt allerdings die Geschwindigkeit erhöht, fängt das Problem wieder an.

 

Mit der aktuellen Geschwindigkeit fährt der Schlitten mit ca 30 Sek / Meter, was eindeutig zu langsam ist auf einer Länge von 2 Metern

 

Wir haben mit 1/8 bis Vollschritten sowie mehreren mechanischen Untersetzungen experimentiert, leider ohne Erfolg.

 

Gibt es Möglichkeiten, den Motor noch mehr Strom / Spannung zur Verfügung zu stellen? Oder ist der Stepperbrick für das Projekt evtl zu klein? (Das wäre ein Desaster). Würde es Sinn machen die Kühlung des Stepperbricks zu verbessern? Oder gibt es evtl noch Parameter um noch mehr Leistung rauszuholen?

 

Der Motor ist ein SM 2861-5055 mit 3Nm.

 

Danke schonmal im voraus für alle Ideen und Antworten.

motor1.thumb.jpg.bbeae87141be0c57e056064f58e63994.jpg

motor2.thumb.jpg.334e5405fd5e62c142ab2cff9f231aad.jpg

SM2861-5055.pdf

Link to comment
Share on other sites

Sorry, aber wenn ich mir die Dimensionen und Massen vorstelle, die da bewegt werden sollen, vermute ich spontan, der Motor ist mit 2A und den (theoretisch) erreichbaren Haltemoment von 3Nm unterdimensioniert. Und die Schnecke an der Antriebswelle scheint ohne große Übersetzung an die Abtriebswelle das Moment weiterzugeben.

Das Moment wird bei Microschritt bzw. höherer Drehzahl geringer. Für den optimalen Wert sind immer die Leistungskurven der Datenblätter hilfreich. Ich hoffe mal das Motorwellenende ist noch mit einem Kugellager gesichert.

Es fehlt auch die Angabe der verwendeten Spannung.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...