Jump to content

HUAWEI E3531 Mobile Broadband UMTS Stick wird nicht erkannt


Birnchen
 Share

Recommended Posts

Hallo das Birnchen meldet sich mal wieder :)

 

ich habe von Lidl Connect den HUAWEI E3531 Mobile Broadband Stick.

Wenn ich diesen an den Red Brick anschließe wird er als "eth0 : Wired" erkannt.

Ich kann zwar im "Network" Tab des Bricks dadurch eine Verbindung aufbauen, allerdings ist diese nicht erreichbar. Im "Mobile Internet" Tab steht weiterhin "no modem available...".

 

Es wäre super wenn mir jemand erklären könnte, wie ich diesen zum Laufen bringe, da ich mir nicht unbedingt den HUAWEI Stick aus dem Store zusätzlich kaufen möchte, da ich diesen ja bereits bezahlt habe und der Meinung bin wenn ein HUAWEI geht, geht auch ein anderer.

 

Danke schonmal für eine Antwort.

 

LG

 

Birnchen

Link to comment
Share on other sites

Guest piwo

huawei ist nicht huawei - sorry ...

ist so, ob uns das passt oder nicht.

 

deswegen verkauft tinkerforge auch eine stick "der geht".

den kauf ich auch. dann "gehts" auch ...

 

no better message ...

Link to comment
Share on other sites

Dann funktioniert doch alles.

 

Zauberwort heisst: "Carrier Grade NAT". Alle Handys/Surfsticks gehen ueber (eine) IPv4 Adresse ins Internet. Das ist Standard.

 

Loesung heisst VPN Tunnel auf eigenen Server mit (Rueckwaerts-) Weiterleitung der Ports auf den RED Brick.

 

Edit: Welche IP hast du vom Provider bekommen und welche oeffentliche IP ist sichtbar? (google: my ip)

 

 

Der Loetkolben

Link to comment
Share on other sites

Hallo Loetkolben,

 

also laut Red Brick habe ich die IP: 192.168.8.100, laut my ip 109.43.3.87.

Und ja soweit funktioniert auch meine Software schriebt ordnungsgemäß in die Datenbank alles rein. Allerdings sobald ich einen wlan stick anstecke und den Access Point aktiviere, ist Network gesperrt und keine Verbindung merh da. Brauche ja aber den Zugriff von außen um auf die Webcam zugreifen zu können...

 

LG

Birnchen

Link to comment
Share on other sites

Ka woher die kommt,die ip vom Brick kann es nicht sein, da ja keine WLan Verbindung in dem falle zu meinem Router entsteht. Die bekommt er angeblich vom DHCP des Providers. Ob ich ne andere ip im Internet habe weis ich grade nciht, werde ich ggf bei dem nächstem reeboot (ca in 5 - 10 minuten) mal nachsehen :) ich geh aber davon aus, da ich ja immer eine neue IP vom provider bekomme wenn ich online gehe.

 

Gibt es beim Redbrick auch eine Möglichkeit Client und Accesspoint gleichzeitig zu sein wie beim wlan 2.0 brick??

 

Problem ist auch, hab zwar jetzt Accesspoint und UMTS Stick am laufen, sobald ich aber restarte den Brick, muss ich erst display einstecken, wlan stick abziehen umts stick abziehen, umts stick anstecken über wicd die wired Verbindung verbinden, damit ich das Internet habe und dann den wlan stick wieder anschließen um die Accespoint Verbindung zu starten im Brick.... total nervig. Wenn ich beide sticks dran lasse und wicd starte zeigt er nur die wlan Verbindungen an, aber kein wired mehr.... aktuell zum Debuggen zwar noch eine Lösung, aber für den live betrieb muss da ne andere Lösung her :D

 

LG

 

Birnchen

 

(mittlerweile sehr verzweifelt^^)

Link to comment
Share on other sites

Hallo,

 

Die bekommt er angeblich vom DHCP des Providers.

 

Die "192.168.8.100" bekommt er ganz sicher nicht vom Provider. Dies ist eine Adresse, die für private LANs reserviert ist und gelangt niemals ins "Internet" (und kommt auch nicht von dort). Wo hast du denn die Adresse abgefragt? Wenn dein RED-Brick keine WLAN-Verbindung hatte, dann kannst du ja dort auch keine IP-Adresse abfragen. Über die UMTS-Verbindung auf dem RED-Brick?

Die "109.43.3.87" ist die Adresse, die du von deinem Provider (Vodafone) erhalten hast.

Link to comment
Share on other sites

Die "109.43.3.87" ist die Adresse, die du von deinem Provider (Vodafone) erhalten hast.

 

Obacht. Zu klaeren ist noch, ob auf der WAN (Mobilfunk) Schnittstelle NAT eingesetzt wird *1. Dann wird meistens dem Stick/Handy eine 10er Adresse vom Provider zugewiesen.

 

Eine 192.168er Adresse, so stimme ich Equinox zu, wird es sicher nicht sein. Nochmals die Nachfrage: Aendert sich die "my ip" Adresse bei jeder Einwahl oder bleibt die gleich?

 

Der Loetkolben

 

*1 Kann ja nach Provider oder Tarif unterschiedlich sein.

Link to comment
Share on other sites

Hallo,

 

Obacht. Zu klaeren ist noch, ob auf der WAN (Mobilfunk) Schnittstelle NAT eingesetzt wird. Dann wird meistens dem Stick/Handy eine 10er Adresse vom Provider zugewiesen.

 

Hmmm, ich dachte bei "Carrier Grade NAT" muss die Adresse mit 100 beginnen bzw. irgendwo zwischen 100.64.0.1 und 100.127.255.254 liegen?! Es sei denn Vodafone hält sich nicht daran, was ich nicht glaube. Und ich glaube auch nicht, dass Vodafone gleich 2 IP-Adressen (für IPv4) zuweist.

Link to comment
Share on other sites

War mir so nicht bekannt, da bei meinen (aelteren) Beobachtungen immer eine 10er Adresse vergeben wurde.

Hast aber Recht.  ;)

 

Infos zur Umstellung von privaten Adressen auf den reservierten Adressereich unter:

Wikipedia CarrierGradeNAT Adressbereich

 

^= 100.64.0.0/10

 

Warten wir auf ein paar Infos um das ans laufen zu bekommen.

 

 

Der Loetkolben

Link to comment
Share on other sites

So,

 

sorry für die verspätete Antwort.

Hab die letzten Tage versucht mit usb mode switch und diversen anderen tricks den stick vom cd Laufwerk (ja im Linux wird er als cdrom erkannt) in den Modem mode zu bekommen. Der sch*** Stick ist hartnäckig und scheint keinen Modem mode zu besitzen... Laut Linux Meldung nicht möglich. Aber egal, ich habe mir den stick von Tinkerforge bestellt in der Hoffnung das es dan einfacher geht, der kommt heute im Büro an und ich kann ihn morgen zusammen mit der anderen Hardware abholen. Danach setze ich eine IP Camera dahinter und gebe diese frei das ich über das Internet drauf zugreifen kann, so ist das Internet Problem, sowie das Problem mit der 100% Auslastung des Bricks beim vlc Streamer mit der Logitech gelöst und ich kann vorerst das ganze als Prototyp hinstellen und weiterarbeiten :D

 

So nun zu euren fragen, weil wäre klassen wenn die Probleme trotzdem noch gelöst werden könnten, das ich den Lidl Stick auch benutzen kann.

 

Also ja ich bekomme jedesmal eine neue IP vom Provider.

Equinox, die IP 192.168.8.100 zeigt mir der Red Brick in den lan Einstellungen an wenn ich über diese eine Verbindung aufbaue. Allerdings bekomme ich trotzdem dan eine andere über meinen Provider. Internet funktioniert dan auch soweit, also mit Monitor auf der GUI kann ich dann Goggle aufmachen und mein Programm verbindet sich auch mit dem Internet.

 

Ich denke mal die ganzen Probleme kommen von zwei quellen:

1. der stick wird im linix als CD-Rom Laufwerk erkannt und nicht als wlan oder Modem.

 

2. Der stick wird als Ethernet-wired Verbindung angezeigt im Red Brick und im wicd GUI.

 

Danke für die Hilfreichen Antworten und eure mühe :)

 

LG

 

Birnchen

 

 

Link to comment
Share on other sites

So ihr Lieben,

 

also ich habe nun den UMTS Stick von TF und er funzt :D meine software verbindet sich zwar komischerweise nicht mit dem ins internet, aber das ist was anders. Wichtig ist grade eher, wie kann ich jetzt auf die Bricks per internet mich verbinden?? IP Adresse habe ich, allerdings keine verbinden möglich... Klar Linux SPerrt ja erstmal warschienlich alles^^ Aber um jetzt mit dem Brick Viewer die Bricks von Extern zu prüfen, resetten udn co, brauche ich natürlich die Verbindung, ggf auch um in die Console per Putty zu kommen. Kann mir einer kurz sagen wie das geht, also welche einstellungen ich machen muss?? reicht mir ggf auch einfach nur tipps wonach ich googln muss umd ie richtigen befehle und settings zu finden :)

 

Danke auch

 

LG

 

Birnchen

Link to comment
Share on other sites

Hi,

 

das Problem kann hier an mehreren Stellen liegen.

[*]Carrier-grade NAT

Der Internet Provider verwendet für viele Verbindungen die gleiche IP, und jeder Kunde erhält einen anderen Port. Wenn die IP Adresse im Bereich 100.64.0.0/10 liegt ist dies bei Dir der Fall.

Ein einfacher Verbindungsaufbau zum Brick Daemon von außen (also nicht über localhost oder LAN) wird dann immer scheitern.

[*]Firewall beim Provider

Wenn Dein Provider jeder Verbindung eine eigene IP zuweist ist es gut möglich, dass er eingehende Verbindungen auf zu "unüblichen Ports" auf diese IP sperrt.

Versuch mal, den Web Server Service im Brick Viewer zu aktivieren, und diesen dann über die öffentliche IP Adresse aufzurufen.

[*]Firewall im Red Brick Image

Mir wäre nicht bekannt, dass bei dem Red Brick Image eine Firewall Policy konfiguriert ist. Herausfinden kannst Du dies mit dem Befehl sudo iptables -L

Das Ergebnis sollte dann so ausssehen, wenn keine Firewall Regeln definiert sind:

Chain INPUT (policy ACCEPT)

target    prot opt source              destination       

 

Chain FORWARD (policy ACCEPT)

target    prot opt source              destination       

 

Chain OUTPUT (policy ACCEPT)

target    prot opt source              destination       

 

Vermutlich ist es entweder Fall eins oder zwei. Dann kann ich Dir leider nicht weiterhelfen.

 

Gruß

  Bernhard

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...