Jump to content
jgmischke

IMU 2 - Messergebnisse passen nicht überein

Recommended Posts

Ich benutze das IMU 2 für eine Teleskopsteuerung.

 

Dabei habe ich folgendes Problem:

 

Anzeige des Gravitationsvektor mit dem brickv ( neueste Version )  :

Der Z-Ẃert ( Brick liegt fest auf dem flachen Tisch ) wackelt so zwischen 9.8X und 10.1X m/s hin und her.

 

Anzeige des gleichen Vektors in C, Ausgabe mit Curses:

 

Alle Daten verändern sich überhaupt NICHT. ( So wie man es jetzt auch erwarten würde). Schwankungen wenn überhaupt nur immer um +/- 1 der letzten Stelle. Z Achse also auf 980.

 

Woran liegen die Schwankungen im brickv

 

Share this post


Link to post
Share on other sites

Kann ich hier nicht nachstellen. Mein IMU Brick 2.0 hier auf dem Tisch, zeigt einen absolute stabilen Gravitiy Vector.

 

Hast du die aktuelle Firmware 2.0.14 auf dem Brick?

 

Hast du Brick Viewer und den C Programm gleichzeigt laufen und sieht da die Unterscheide in den Werten, oder lässt du die nacheinander laufen?

Share this post


Link to post
Share on other sites

Peinlich peinlich.

 

Wer lesen kann ist im Vorteil. Ich hab runtersrollen müssen, DA ist dann auch der Grav Vektor.

 

Und da wackelt NIX: Gewackelt hat get_acceleration, da aber eben auch unter beiden Programmen gleich.

 

Sorry!!!!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...