Jump to content

Red-Brick Mobile-Verbindung funktioniert nicht stabil


Recommended Posts

Ich möchte von meiner mobilen Messstation aus regelmäßigr Messdaten an meine Emailadresse senden.Das VB.net-Programm läuft ohne Fehlermeldung auf dem Red-brick. Wenn ich den Red-Brick aktiviere kommt manchmal ein Email bei mir an, aber  dann tut sich nichts mehr. Ich verwende das HSUPA-Modem (bei Tinkerforge gekauft). Mein Internetanbieter verwendet O2-Netzwerk. Telefonie und Datenübertragung funktionieren vom Handy aus gut. Mein Programm funktioniert auf dem Laptop über das Wlan einwandfrei.Liegt das Problem an der Internetverbindung?

Ich möchte natürlich nur auf Verdacht nicht den Anbieter wechseln. Vielleicht kann mir hier jemand weiterhelfen.

Link to post
Share on other sites

Hallo Backdraft,

erstmal danke für deine Hinweise.

Also, das Programm funktioniert am Laptop (dort allerdings über Wlan) einwandfrei. Das Programm müsste also einwandfrei funktionieren.

Nach dem Übertragen des Programms auf den Red-Brick, funktioniert die Datenübertragung auf meine Email auch 1 -3 mal. Danach tut sich nichts mehr. Also an meinem Provider kann es kaum liegen. Könnte es sein, dass sich die Übertragungsgeschwindigkeit meinenes Surfsticks HSUPA 7.2 mit meinem Programm nicht verträgt?

 

 

 

Link to post
Share on other sites

Hallo,

nun überwache ich in meinem Programm bei einigen Funktionen den Programmablauf. die Ergebnisse werden in das "OMSlogfile.txt" geschrieben, das sich im Progammverzeichnis "/OMS/bin"befindet. Mir gelingt es allerdings nicht, den Inhalt der Datei darzustellen. Mit dem Konsolenbefehl "TYPE OMSlogfile.txt" lässt sich die Datei nicht öffnen.

 

Messdaten-xxxxxxxxx-2019-10-15-23-4.txt         

Messdaten-xxxxxxxxx-2019-10-15-23-7.txt         

OMSlogfile.txt                                   

OnboardMonitoringProgram.exe                     

Überschreitungen-xxxxxxxxx-2019-10-15-23-4.txt   

Überschreitungen-xxxxxxxxx-2019-10-15-23-7.txt   

tf@red-brick:~/programs/OMS/bin$     

 

Link to post
Share on other sites

Hallo Backdraft,

danke für deine Hinweise! Leider muss ich feststellen,dass die Emails von meinem Programm nicht gesendet werden. Warum? Weiß ich noch nicht. Das Programm funktioniert auf mmeinem Laptop einwandfrei, allerdings über Wlan und Kabelnetz. Aber jetzt weiß ich wenigstens an welcher Stelle ich weiter suchen muss. Vermutlich gibt es ein zeitliches Problem im Programmablauf, denn manchmal funktioniert es ja. An der Hardware, am Provider und an den Zugangsdaten kann es also nicht liegen. Ich melde mich wieder wenn ich den Fall gelöst habe.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...