Jump to content

Anmeldung an Warp1 nach FW Update 1.3.0 nicht mehr möglich


int5749
 Share

Recommended Posts

Hallo zusammen,

ich habe gerade unsere Warp1 mit der neuen Firmware 1.3.0 gesegnet und nun akzeptiert diese mein Benutzerkennwort nicht mehr :-/

Erreichbar ist die Box, MQTT läuft auch, "nur" kann ich mich nicht mehr anmelden. Ein zurücksetzen habe ich bisher vermieden, da ich  nciht wieder alles neu einstellen möchte.

Hat noch jemand einen Tipp??

Viele Grüße

Link to comment
Share on other sites

Das sollte natürlich nicht passieren. Mit welchem Browser (und welcher Version) hast du das getestet? Von welcher Firmware-Version bist du auf die 1.3.0 gegangen? Ich würde das gerne hier reproduzieren, damit ich einen eventuellen Bug fixen kann.

Notfalls retten kannst du das ohne Reset, indem du per MQTT den Login deaktivierst: https://www.warp-charger.com/api.html#reference-authentication

Link to comment
Share on other sites

vor einer Stunde schrieb rtrbt:

Das sollte natürlich nicht passieren.

Das hätte ich auch erwartet 😉

 

vor einer Stunde schrieb rtrbt:

Mit welchem Browser (und welcher Version) hast du das getestet?

Firefox Version 94 unter Windows 10

vor 1 Stunde schrieb rtrbt:

Von welcher Firmware-Version bist du auf die 1.3.0 gegangen?

warp_firmware_1_2_4_60f17413

 

vor 1 Stunde schrieb rtrbt:

Notfalls retten kannst du das ohne Reset, indem du per MQTT den Login deaktivierst:

Dies hatte ich schon probiert, aber keine Auswirkung :-/ obwohl der Befehlt angenommen wurde obwohl:

{"enable_auth":false,"username":"User4711","password":null}

 

Aber ich habe gerade dann noch einmal mit dem Edge getestet und mit diesen konnte ich mich ohne Probleme anmelden. Strange

Das Problem mit dem FF besteht aber nach wie vor.

Link to comment
Share on other sites

3 minutes ago, int5749 said:

Das Problem mit dem FF besteht aber nach wie vor.

Hilft es den Firefox neuzustarten?

Ich teste hier mal das selbe, vielleicht kann ichs reproduzieren.

3 minutes ago, int5749 said:

Dies hatte ich schon probiert, aber keine Auswirkung :-/

Hast du danach neugestartet? Das ist eine Konfigurationsänderung ;)

Link to comment
Share on other sites

vor 14 Minuten schrieb rtrbt:

Hilft es den Firefox neuzustarten?

Bei mir nicht, habe schon einen neuen FF gestartet, ohne Erfolg.

Auch ein löschen der gesamten Cookies und Cache im FF bringen keine Besserung

Auch hatte ich den Eintrag aus dem Passwort Manager des FF gelöscht und somit neu eingegeben.

 

vor 14 Minuten schrieb rtrbt:

Hast du danach neugestartet? Das ist eine Konfigurationsänderung ;)

Oups, nö ;-) denn dazu hätte ich ja wieder in die Garage zu den LS gehen müssen. Oder geht dies auch per MQTT?? Denn anmelden ging ja nicht ;-)

Da ich aber derzeit über den Edge drauf komme, würde ich Deine Versuche noch abwarten

Edited by int5749
Link to comment
Share on other sites

Okay, ich kann das Problem hier nachstellen: Das Update von 1.2.4 auf 1.3.0 wechselt ja unter anderem den ganzen Webserver aus. Der neue Webserver hatte keinen Support für die Login-Variante die wir benutzen, deshalb hatte ich das nachimplementiert. Dabei habe ich aber die Realm von asyncesp auf esp32-lib geändert. Firefox versteht jetzt nicht, dass er sich auf die neue Realm einloggen muss. Interessanterweise hat Firefox die neue Realm bei mir aber akzeptiert, als ich ihn neugestartet habe.

Wenn du über Edge noch das Webinterface erreichst, kannst du den Login deaktivieren, neustarten, dann einmal mit Firefox draufgehen (damit er vergisst, dass man sich einloggen muss), dann Firefox neustarten und den Login wieder aktivieren. Ich würde erwarten, dass das dann wieder funktioniert.

Unabhängig davon kommt in Version 1.3.1 ein Fix dafür: Der Webserver akzeptiert dann einfach sowohl die alte, als auch die neue realm.

Danke für's melden!

Link to comment
Share on other sites

vor 5 Stunden schrieb rtrbt:

Danke für's melden!

Nicht dafür, viel mehr einen Dank für das schnelle untersuchen und herstellen eines Fixes.

 

Mittlerweile konnte ich das "Problem" lösen, indem ich den ganzen Rechner neu gestartet habe. Ich habe immer mehrere Instanzen von FF mit einigen Fenstern laufen. Evtl. hatten die noch etwas im Cache. Nach dem Restart werden bei mir alle zuvor geöffneten Fenster von FF und Edge direkt wieder geöffnet, aber ja eigentlich auch alle dann neu gestartet. Im Anschluß konnte ich dann auch mit dem FF wieder auf das Web Interface.

Schon seltsam, war das Verhalten: Es wurde ja scheinbar das PW abgelehnt, dies wurde rot umrandet.

Link to comment
Share on other sites

Bei mir identischer Effekt mit Edge. Richtiges Passwort loopte wieder zur Anmeldung, falsches blinkte noch ein wenig. :D

Da ein anderer Browser ging, konnte ich auf die Wallbox zugreifen (nachdem ich erst MQTT probiert hatte - es fehlt ein "reset to factory settings" mit änderbarem Passwort...) und danach dann wieder Edge verwenden.

 

Link to comment
Share on other sites

On 11/19/2021 at 7:42 PM, int5749 said:

Ich habe immer mehrere Instanzen von FF mit einigen Fenstern laufen.

Das ist eine gute Erklärung, der Firefox cacht das in der Tat, bis er einmal komplett neustartet.

On 11/19/2021 at 7:42 PM, int5749 said:

Schon seltsam, war das Verhalten: Es wurde ja scheinbar das PW abgelehnt, dies wurde rot umrandet.

Jain, die Loginseite fragt den Server nur, ob der komplette Satz Login-Daten korrekt ist, die Rückmeldung ist dann aber immer "falsches Passwort".

On 11/19/2021 at 11:24 PM, jensstark said:

Bei mir identischer Effekt mit Edge. Richtiges Passwort loopte wieder zur Anmeldung, falsches blinkte noch ein wenig. :D

Hm dass ein richtiges Passwort wieder die Anmeldeseite lädt ist interessant: Das heißt, dass Edge scheinbar für jede Unter-URL einen eigenen Cache hat und dann mit der neuen Realm die Login-Daten geprüft hat, aber für die Hauptseite wieder die alte verwendet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...