Author Topic: RED Brick Image 1.10 Test  (Read 3099 times)

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
RED Brick Image 1.10 Test
« on: July 14, 2017, 19:51:17 »
Wir arbeiten sein einer Weile an einem größeren Software Update für den RED Brick. Das Update umfasst im wesentlichen Kernel 4.12 und Debian 9.

Das bedeutet:

  • Unterstützung für mehr WLAN USB Sticks
  • Unterstützung des Access Point Modus für mehr WLAN USB Sticks
  • Unterstützung für Bluetooth LE/4
  • Aktualisierte Software: Node.js 8, Nagios 4, Octave 4, ...
  • Und mehr
Es gibt aber auch noch offene Baustellen:

  • Bisher keine 3D/OpenGL Hardwarebeschleunigung
Wir stellen euch heute die erste Testversion des neuen Images zum Testen. Dazu gehört auch eine neue Brick Viewer Version. Wir freuen uns auf euer Feedback.

http://download.tinkerforge.com/red_110alpha1/
« Last Edit: August 18, 2017, 17:02:56 by photron »

duaw

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #1 on: July 16, 2017, 12:23:16 »
Hallo,

da muss ich mir erst mal eine neue SD-Card besorgen: Die 8.07 GB des Image liegen bei mir knapp über der Grenze meiner "8 GB" Karte ... Ich kann das nicht mit meinem Vorzugstool "etcher" (https://etcher.io) schreiben.

Also die vorsichtige Frage: Openhab2 dabei?

Und: Gibt es einen geplanten Zeitpunkt / Zeitraum für die Veröffentlichung?

Gruß, Uwe


PS Warum postet ihr solche Lebenszeichen eigentlich nicht (auch) im Blog? Das sieht dann weniger tot aus.

Nic

  • Hero Member
  • *****
  • Posts: 1.418
  • Pano.photogr. - Just for fun: Delphi, C#...
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #2 on: July 16, 2017, 17:59:11 »
Hammer! Prima, dass der RED ein Upgrade erhält. ;D

Der WLAN Dualband Adapter Asus USB-N53 funktioniert schonmal und sogar auf 5Ghz(!).
Im Gegensatz zum Raspberry/Raspbian kann ich eine Putty Verbindung zum Red nur über IP öffnen, Hostname red-brick geht nicht.

Einen leistungsschwächeren Dualband TL-WDN3200 von TP-Link bekomme ich nicht dazu sich mit dem Router zu verbinden. Im BrickV wird zwar ein Interface Name wlx<Mac-Add> angegeben und man kann einen Scan starten aber es wird nix gefunden.

Ist das init.d weiterhin nutzbar oder nur noch sytemd?
Welchen Desktop haben wir zu erwarten?

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #3 on: July 19, 2017, 11:43:48 »
da muss ich mir erst mal eine neue SD-Card besorgen: Die 8.07 GB des Image liegen bei mir knapp über der Grenze meiner "8 GB" Karte ... Ich kann das nicht mit meinem Vorzugstool "etcher" (https://etcher.io) schreiben.

Die zu große Image Größe ist ein Bug, wird in der nächsten Testversion behoben sein.

Also die vorsichtige Frage: Openhab2 dabei?

OpenHAB2 müssen wir uns ansehen. Hast du das schon mit Tinkerforge im Einsatz?

Der WLAN Dualband Adapter Asus USB-N53 funktioniert schonmal und sogar auf 5Ghz(!).
Im Gegensatz zum Raspberry/Raspbian kann ich eine Putty Verbindung zum Red nur über IP öffnen, Hostname red-brick geht nicht.

Einen leistungsschwächeren Dualband TL-WDN3200 von TP-Link bekomme ich nicht dazu sich mit dem Router zu verbinden. Im BrickV wird zwar ein Interface Name wlx<Mac-Add> angegeben und man kann einen Scan starten aber es wird nix gefunden.

Schauen wir uns an.

Ist das init.d weiterhin nutzbar oder nur noch sytemd?

systemd hat Abwärtskompatibilität zu init.d Scripten. Die systemd Tools sind im allgemeinen aber mächtiger als die alten init.d Tools. Worum genau geht es dir?

Welchen Desktop haben wir zu erwarten?

Weiterhin LXDE, da gibt es keine Änderung.

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #4 on: July 20, 2017, 17:07:28 »
duaw, nach ein paar ersten Tests sieht es so aus also ob das mit openHAB2 was werden könnte.

Nic, das Hostname-Problem war ein Bug, ist gefixt.

Der TP-Link TL-WDN3200 funktioniert aber an einem anderen Rechner an der gleichen Stelle? Sprich, das ist nicht einfach nur ein generelles Empfangsproblem des Sticks, sondern tritt nur im Zusammenhang mit dem RED Brick auf?

Nic

  • Hero Member
  • *****
  • Posts: 1.418
  • Pano.photogr. - Just for fun: Delphi, C#...
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #5 on: July 21, 2017, 12:28:34 »
Ich kann den TP-Link TL-WDN3200 problemlos z.B. auf dem aktuellen Raspbian und einem Raspi 3 bzw. Zero u.a. auch auf 5Ghz benutzen.
Unter Win/Ubuntu noch nicht getestet.

Gib bitte mal an, welche Abfragen ich auf dem Red machen kann, solange der WDn3200 angesteckt ist, damit ihr zwecks Fehlersuche einfacher habt.
« Last Edit: July 21, 2017, 12:34:59 by Nic »

iia

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #6 on: July 21, 2017, 16:52:18 »
Hi Nic,

After doing a scan from Brickv with the particular WiFi card can you provide us with the following data:

1. dmesg output
2. Content of /var/log/syslog
3. Content of /var/log/wicd/wicd.log

If you execute the command,
Code: [Select]
sudo iwlist scan on RED Brick command line what output do you get ?

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #7 on: July 24, 2017, 13:47:12 »
Ich kann den TP-Link TL-WDN3200 problemlos z.B. auf dem aktuellen Raspbian und einem Raspi 3 bzw. Zero u.a. auch auf 5Ghz benutzen.

Funktionierte der Stick mit Image 1.9?

Nic

  • Hero Member
  • *****
  • Posts: 1.418
  • Pano.photogr. - Just for fun: Delphi, C#...
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #8 on: July 24, 2017, 15:06:49 »
Den WDN3200 hatte ich in der Vergangenheit nur auf dem Image 1.7 getestet.

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #9 on: July 24, 2017, 17:02:26 »
Lass mich anders fragen: Hat der WDN3200 je am RED Brick funktioniert? Sprich, hat 1.10 das jetzt kaputt gemacht, oder war das schon immer kaputt?

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #10 on: August 18, 2017, 17:07:14 »
Lass mich anders fragen: Hat der WDN3200 je am RED Brick funktioniert? Sprich, hat 1.10 das jetzt kaputt gemacht, oder war das schon immer kaputt?

Antwort über PM war, das es vorher auch noch nicht funktioniert hat.

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #11 on: August 18, 2017, 18:58:18 »
Okay, hier jetzt Alpha 2, mit folgenden Änderungen:

  • Netzwerk Verwaltung auf Network Manager umgestellt, dadurch spürbar kürzere Wartezeit in Brick Viewer bei der Netzwerkkonfiguration. Einzig die Verbindung zu versteckten WLAN Netzen funktioniert aktuell noch nicht
  • OpenHAB auf Version 2 aktualisiert
  • Image jetzt nicht mehr zu nah an der 8GB Grenze
Nic, teste bitte, ob der TL-WDN3200 WLAN Stick jetzt besser funktioniert.

http://download.tinkerforge.com/red_110alpha2/

Edit: Das Image ist jetzt hochgeladen.
« Last Edit: August 19, 2017, 19:31:20 by borg »

Nic

  • Hero Member
  • *****
  • Posts: 1.418
  • Pano.photogr. - Just for fun: Delphi, C#...
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #12 on: August 28, 2017, 13:56:59 »
Die Alpha 2 hätte ich doch fast übersehen nach so langer Abstinenz ;)
Packt doch solche Ankündigungen in den Blog oder ins Topic "Veröffentlichungen".
Den WDN3200 teste ich heute abend und ev. noch ein paar andere Sticks.

Nic

  • Hero Member
  • *****
  • Posts: 1.418
  • Pano.photogr. - Just for fun: Delphi, C#...
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #13 on: August 28, 2017, 21:58:42 »
Unter Lubuntu 16.04.3 wird der WDN3200 sofort erkannt.
Verbindung zum AP ist jetzt wesentlich schneller :), WPA Key wird allerdings nicht gespeichert, ich muss den jedesmal neu eingeben.
Nach Dialog "Configuration saved" dauert es 4-5 sec bis zur Verbindung, dann sollte da zwischenzeitlich aber statt "Disconnected" besser "Connecting...." im Status zu lesen sein.

TP-Link WDN4200 funktioniert nicht. Stick wird im Interface zwar gezeigt, listed aber nur die stärksten APs in umittelbarer Nähe, kann sich nicht mit gewähltem AP verbinden, Status zeigt keinen Fehler nur Disconnected.

Aber der Asus USB-N53 lässt sich wie der WDN3200 auf 2 bzw 5Ghz problemlos verbinden.
« Last Edit: August 29, 2017, 16:00:50 by Nic »

photron

  • Administrator
  • Hero Member
  • *****
  • Posts: 2.375
    • View Profile
Re: RED Brick Image 1.10 Test
« Reply #14 on: September 04, 2017, 15:20:25 »
Nic, das Password-Speicher-Problem haben wir behoben.

Die 5 Sekunden Verzögerung können wir nachstellen und arbeiten daran, dass zu verbessern.

Das ist kein Typo, dass du da vom TP-Link WDN4200 und TP-Link WDN3200 schreibst? Der 3200 der vorher nicht ging, funktioniert jetzt, aber der 4200 funktioniert weiterhin nicht?

Funktioniert der TP-Link WDN4200 denn unter Ubuntu?