Jump to content

Servobrick Einschaltimpuls


remotecontrol
 Share

Recommended Posts

Hallo,

 

mein "Fernziel" ist es, ein RC Funktionsmodell mittels WLAN über mein Android Tablet zu steuern. Prinzipiell kann ich schon alle notwendigen Bricks / Bricklets übers Tablet mit spezifischen GUI Controls steuern: Servos, DC Brick, Relais ...

 

Beim Servo habe ich aber noch ein Einschaltproblem:

 

wenn der Stack an die Stromversorgung angeschlossen wird, macht mein Testservo eine kurze Drehung in eine bestimmte Richtung, bei jedem Einschaltvorgang etwa um den gleichen Winkel in die gleiche Richtung unabhängig von der aktuellen Stellung. D. g. 2x einschalten dreht das Servo dann 2x um einige Grad.

 

Starte ich dann meine Anwendung, welche das Servo initial erstmal auf "0" stellt, geht es in die korrekte 0-Stellung zurück.

 

Kann das am Servo liegen oder ist es möglich / tatsächlich so, dass das Servo Brick einen Einschaltimpuls gibt? Oder kann ich den per Software verhindern. Allerdings passiert das ja, bevor die Software Zugriff auf den Stack bekommt.

 

Beim Servo ist das nicht dramatisch. Wenn ich aber einen Fahrtregler anschließen würde, wäre das nicht so gut, wenn das Modell gleich Power gibt.

 

Viele Grüße

Link to comment
Share on other sites

Hallo remotecontrol,

 

einige Servos reagieren mit einem kleinen Verstellen, wenn sie Strom bekommen.

Gib doch einfach mal 5-6Volt auf die Leitung des Servos (schwarz/braun=Masse, rot=4,8V-6V, weiß/orange/gelb=Impuls). Wenn Sie dann auch zucken, liegts daran.

 

ciao

nrg007

Link to comment
Share on other sites

Hallo, ist bei meinen Servos auch so. Stört mich nur jetzt bei meiner Kamerasteuerung nicht so.

 

Wenn du einen Fahrtregler dahinter hängst, gibst du doch "nur" die "Steuerleitung" (Impulse) an diesen weiter. So könntest du den Motor doch erst an den Strom anschließen (Relais), wenn der Servobrick seine "Zuckungen" hinter sich hat.

Link to comment
Share on other sites

Ich hab die Steuerung gerade an ein erstes Fahrzeug gehängt: das Lenkservo zuckt beim Einschalten auch. Der Fahrtregler dieses (billigen) Modells scheint aber träger zu sein und das Fahrzeug macht beim Einschalten keine Bewegung vorwärts. Für das Modell also ausreichend.

 

Aber gut zu wissen, dass es kein Einzelfall ist.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...