Jump to content

Temperature IR Bricklet - Erfahrungsaustausch


Recommended Posts

hallo, ich hab immer wieder Probleme mit dem TempIR Bricklet.

Wie habt ihr das Bricklet im Einsatz

(was wird gemessen, temperaturschwankungen, welches Bricklet-Kabel (Länge und (un)geschirmt, Callbacks oder Direktabfrage, Programmiersprache)...

 

Ich messe meinen Heizkörper in 10cm Entfernung mit PHP-Callbacks.

Bricklet Kabel 50cm ungeschirmt -> verursacht Probleme - bei 6cm gehts)

Danke

Link to comment
Share on other sites

  • 1 month later...

Hallo !

 

Ich habe/hatte zur berührungslosen Temperaturkompensation einer Wägezelle ebenso eine Temperature-IR-Bricklet bzw. seit einigen Tagen ein Temperature- IR-V2 Bricklet im Einsatz.

 

Das Temperature-IR-Bricklet V1 sporadisch immer wieder mit schweren Hängern. Temperaturen meist im dreistelligen Bereich weit über der tatsächlichen Temperatur eingefroren. Resets am Brick/Bricklet helfen in der Regel nicht. Nach Resets teils keine Verbindung zum Stapel (über Ethernet) mehr möglich. Sehr oft hilft komplettes Trennen des Stapels von der Versorgungsspannung. Manchmal half auch nur Neuflashen der Bricks (Master 2.1 und Stepper).

 

Deswegen baute ich vor einem Jahr auf PTC-Bricklet um - was bis letzte Woche ohne Ausfälle durchlief.

 

Voller Erwartung auf den beseitigen Bug in Firmware 2.4.7 baute ich auf ein Temperature-IR-Bricklet V2 um. Und siehe da - der Fehler tritt wieder auf. Heute Morgen frohren die Temperaturen des Bricklet bei 698 (Object) bzw. -100 Ambient ein. Mehrmaliges Reseten brachte keine Abhilfe. Erst nach mehrmaligem Ändern es Emissionsfaktors im Brickviewer fingen sich die Temperaturwerte wieder.

 

Was kann das sein ???

 

Viele Grüße aus Unterfranken.

 

André

 

Link to comment
Share on other sites

Wir haben das Temperature IR 2.0 hier ausgiebig unter den unterschiedlichsten Bedingungen getestet. Ich konnte nie so einen Fehler erzeugen :o.

 

Gibt es irgendetwas womit du den Fehler reproduzieren kannst? Oder tritt es immer einfach so nach einiger Zeit auf?

Link to comment
Share on other sites

Auch bei mir hängt sich das Bricklet sporadisch auf.

Löse es auch durch nen Reset. Immer wenn die Werte vom Objekt(auch Heizkörper) und Umgebungstemperatur über zwei Messungen identisch sind, ist es ein Zeichen vom Hänger. Dann wird automatisch resettet und wieder gemessen. So gehts.

Nutze 15cm ungeschirmtes Kabel.

Link to comment
Share on other sites

hallo, das TempIR V1 ist aus meiner Sicht unbrauchbar weil total instabil.

Hat bei mir sehr oft den gesamten Stapel mitgerissen - oft aber auch "nur" das TempIR Bricklet.

 

Ich hab alles auf V2 umgebaut - seither laufen alle Stapel bei mir ohne Probleme seit Wochen!

Die anderen Bricks mit 10poligem Stecker machen fallweise/selten probleme  - sind aber alle über die Messwerte "erkennbar" und mit Master-Reset zu lösen...

Link to comment
Share on other sites

Hi,

 

Ich hatte damals mit dem IR-Bricklet-V1 auch Kabel geändert geschirmt und kürzer. Das hat immer nur momentan etwas gebracht. Auch alle möglichen Ports hatte ich durch. Master 2.1 / Stepper.

 

Beim IR-Bricklet-V1 hatte man eine 20% Chance das beim Neustart der Applikation (Windows 7, C#, der Hänger auftritt. Ich setze den Emissionsfaktor bei der Enumerierung auf (65000). Evtl. hat das etwas damit zu tun. Callbacks bei (5000)ms für Object und Ambient. Sonst alles Default.

 

@borg: Das V2 ist erst seit wenigen Tagen im Einsatz. Sobald ich ein reproduzierbares Muster habe melde ich mich.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...