Jump to content
Philippc

NFC Bricklet steckt im status "initialization" fest

Recommended Posts

Hallo,

 

Mein Stack ist ursprünglich 1x RED Brick, 2x NFC Bricklets und 1x LCD Display. Gestern haben beide NFC Bricklets plötzlich aufgehört NFC Tags zu lesen (Die Bricklets werden noch immer im Brickv angezeigt). Die einzige änderung war, dass ich die "MaxResponseTime" von 2000 auf 200 gesetzt habe, die lässt sich jedoch noch immer auslesen und befindet sich wieder auf 2000. Ich habe den NFC Bricklet schon in verschiedenen Konstelationen angesteckt, sowie den Master Brick neu geflashed und es auf mehreren Geräten ausprobiert, jedoch kein Erfolg. Der derzeitige Stack ist nur noch ein MasterBrick und ein NFCBrick aber auch so funktioniert es nicht. Hätte jemand hier vielleicht eine Idee woran das "feststecken" des Readers liegen könnte?

Share this post


Link to post
Share on other sites

Sehr komisch! Du könntest einmal testen auch das NFC Bricklet neu zu flashen, ich wüsste allerdings auch nicht was das ändern sollte.

 

Wenn das alles nichts bringt musst du die NFC Bricklets einschicken befürchte ich, wir würden uns das gerne ansehen. Vor allem wenn es ein Hardware-Defekt ist der erst nach einer Weile aufgetreten ist wäre das natürlich für uns interessant.

 

Melde dich diesbezüglich dann bitte bei info@tinkerforge.com, wir können die auch vorher bereits erst zwei neue NFC Bricklets schicken.

Share this post


Link to post
Share on other sites

Hallo,

 

gab es hierfür eine Lösung? Ich habe das gleiche Problem sobald ich einen anderen Tag Typ als Mifare Classic wähle.

 

Gruß,

Theo

Share this post


Link to post
Share on other sites

Hallo Borg,

 

Ich hatte mich beruflich vor einiger Zeit per Mail bei euch gemeldet, weil wir in unserer Firma für ein neues Produkt den gleichen Chip verwenden, wie ihr auf eurem Bricklet.

An der Stelle möchte ich kurz darauf hinweisen, dass es von NXP aktualisierte Unterlagen bezüglich der Chips gibt, die über die Softwareworkarounds die bisher z.B. über Distributoren verteilt worden sind hinausgehen.

Vielleicht möchtet ihr da ja nochmal einen Blick drauf werfen (falls noch nicht getan), da gerade der Initialpost nach dem "bekannten Problem" klingt.

Share this post


Link to post
Share on other sites

@ChrisCA: Klingt interessant, schaue ich mir an.

 

@theo: Ich kann mir nicht so recht erklären warum Mifare Classic funktioniert aber die anderen Typen nicht. Das kann ja dann zumindest kein Hardwaredefekt sein denke ich?

 

Also der State wechselt von Initialization auf Idle bei dir, richtig? Sonst könntest du Mifare Classic ja auch nicht nutzen. Aber von da nicht zu den anderen States wenn du versuchst einen anderen Tag-Typ zu lesen?

Share this post


Link to post
Share on other sites

Hallo Borg,

 

Also der State wechselt von Initialization auf Idle bei dir, richtig? Sonst könntest du Mifare Classic ja auch nicht nutzen. Aber von da nicht zu den anderen States wenn du versuchst einen anderen Tag-Typ zu lesen?

Ja ungefähr so. Es geht nur um erste Tests mit dem BrickViewer, eigenen Code habe ich noch nicht probiert. Ich habe hier einen Bildschirmmitschnitt, vielleicht hilft das: https://m1theo.de/ncloud/index.php/s/q6TAxBEM9on38q2

 

Gruß,

Theo

 

Share this post


Link to post
Share on other sites

Hallo Borg,

 

ich hab es jetzt mit eigenem Code getestet, das funktioniert. Es scheint also eher ein Bug im BrickViewer zu sein.

 

Gruß,

Theo

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...