Jump to content

Energy Monitor


Marco.K
 Share

Recommended Posts

Hallo zusammen,

 

ich habe ein Energy Monitor Bricklet zusammen mit einen Stromeandler 5A:1V im Einsatz. (ohne Spannungswandler)

 

Der Stromwandler hängt in der Leitung einer Solarpumpe, Ziel ist zu erkennen ob diese an/aus ist oder eventuell blockiert ist.

 

Schaue ich mir die Wavforms im Brick-Viewer an sehe ich auch ob die Pumpe an oder aus ist.

Der angezeigte Stromwert, zeigt aber immer nur den maximal gemessenen Wert und nicht den aktuellen Wert an. Egal ob Strom fließt oder nicht.

 

Aktuell zeigt er 0.43 A an, was genau der Angabe des Pumpenherstellers entspricht.

 

Ist das so korrekt oder funktioniert das nur nicht richtig weil kein Spannungswandler angeschlossen ist?

EnergyMonitor.png.09d69c2bdb76c456b6b41ebd5ecb9dbd.png

Link to comment
Share on other sites

Das klingt nach einem Bug, schaue ich mir an. Sollte auf jeden Fall funktionieren.

 

Edit: Ich sehe das Problem. Ich bestimme einen neuen Werte alle X Nulldurchgänge der Sinuskurve. Wenn ein Spannungswandler angeschlossen ist nutze ich dafür die Spannung, wenn nicht nutze ich dafür den Strom.

 

Wenn jetzt aber kein Strom mehr fließt gibt es gar keine Sinuskurve mehr und es wird kein neuer Wert mehr berechnet. An der Stelle brauche ich eine Art Fallback der Greift wenn ich für eine bestimmte Zeit keine Nulldurchgänge gesehen habe und den Strom dann einfach auf 0 setzt.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...