Jump to content

Red-Brick einfach nicht sichtbar im Brickv


BlackStingray
 Share

Recommended Posts

Laut Dokumentation (https://www.tinkerforge.com/de/doc/Hardware/Bricks/Master_Brick.html), sollte ein Stapel in der folgenden Kombination möglich sein (von unten nach Oben):

  • 1x Step-Down Power Supply, 1x RED Brick 1.0, 1x Master Brick 2.1, 1x Master Brick 3.1 und 1x Master Extensions Ethernet. 

Leider findet Brickv 2.4.21 diesen Stapel nicht in meinem Netzwerk, obwohl alles gut aussieht, wenn ich den Stapel an eine USB-Schnittstelle Anschließe. Ändere ich die Reihenfolge des Stapels, dann findet Brickv im Netzwerk (und am USB-Anschluss) nur alle angeschlossenen Bicklets an den Master-Bricks, die sich unterhalb des Red-Bricks befinden, aber den Red-Brick selber nicht. (Alle Updates wurden durchgeführt (an allen Bricks) und keine Einstellungen verändert). Was habe ich übersehen?

Link to comment
Share on other sites

Moin,

Zwei Gedanken dazu:

1. Wie versorgst du den Stapel per Strom? Also mit was speist du in die Step-Down Power Supply ein?

2. Wenn du den Stapel ohne eingestecktes USB-Kabel hochfährst (und ~ 30 Sekunden wartest, der RED-Brick braucht ja etwas zum booten), dann erreichst du den Stapel ja nicht. Was passiert, wenn du dann an den laufenden Stapel das USB-Kabel ansteckst und mit dem Brick Viewer auf localhost gehst? Taucht dann alles auf? Was gibt der RED Brick unter Settings -> Network (ist der erste Tab) als Network Status usw. aus? Hast du eventuell einfach das Problem, dass der RED-Brick auf einer anderen IP auftaucht als du das erwartest?

18 hours ago, BlackStingray said:

Ändere ich die Reihenfolge des Stapels, dann findet Brickv im Netzwerk (und am USB-Anschluss) nur alle angeschlossenen Bicklets an den Master-Bricks, die sich unterhalb des Red-Bricks befinden, aber den Red-Brick selber nicht.

Das ist soweit erwartet, der RED-Brick muss immer der unterste Brick im Stapel sein.

Link to comment
Share on other sites

Zu 1.) Der Brick "Step-Down Power Supply" hängt über dem Bricklet "Voltage/Current 2.0" an einem 24V (5A) Netzteil welches noch nicht wirklich unter Last steht. Außer dem Stapel hängt da noch nichts dran...

Zu 2.) Es ist im Brick Viewer der Komplette Stapel zu sehen und ich kann mir alles anschauen, nur der Anblick vom "RED Brick2, "Settings -> Network" ist irritierend! 

Current Network Status:
	Status:			Disconnected
	Interface:		-
	IP:			-
	Subnet Mask:		-
	Gateway:		-
	DNS:			-
	Hostname:		red-brick

Ich bin mir sicher den RED nicht abgeschaltet zu haben, denn die LED´s leuchten und die Status-LED blinkt rhytmisch...

Edited by BlackStingray
Link to comment
Share on other sites

Die Fragen von rtrbt haben mich auf eine Spur gesetzt. Und siehe da... Nachdem ich alle "Alten" Einträge aus meinem Netzwerk-Management-System zum Thema Tinkerforge entfernt hatte und den RED neu gebootet habe, sehe ich nun seit 19 Minuten den ganzen Stapel im Brick Viewer (über das LAN-Kabel).

Danke dass Ihr mir zugehört habt! Manchmal sieht man den Wald vor lauter Bäumen nicht. Nun können die eigentlichen Projekte angegangen werden... 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...