Jump to content

Error installing brickd


JonD

Recommended Posts

Hey, I installed brickd  using Raspberry 3 & 4 without problems. Now I use a Raspberry 5 (64bit) and got some errors during installation for the software. Which I solved using: 

  1. sudo apt-get install libusb-1.0-0 libudev1 procps
  2. wget https://download.tinkerforge.com/apt/$(. /etc/os-release; echo $ID)/tinkerforge.asc -q -O - | sudo tee /etc/apt/trusted.gpg.d/tinkerforge.asc > /dev/null
  3. echo "deb https://download.tinkerforge.com/apt/$(. /etc/os-release; echo $ID $VERSION_CODENAME) main" | sudo tee /etc/apt/sources.list.d/tinkerforge.list
  4. sudo apt update
  5. sudo apt install brickd

This results in an error, which can be solved by:  sudo apt --fix-broken install

The installation shows no further errors, but the brickd is not running. In the Logfile is written:

    2024-05-25 16:18:54.556720 <I> <main_linux.c:369> Brick Daemon 2.4.5 started (pid: 2954, daemonized: 1)
    2024-05-25 16:18:54.556735 <I> <main_linux.c:375> Running on Linux system (sysname: Linux, release: 6.6.20+rpt-rpi-2712, version: #1 SMP PREEMPT Debian 1:6.6.20-1+rpt1 (2024-03-07),                  machine: aarch64) libusb: warning [libusb_init] installing new context as implicit default
    2024-05-25 16:18:54.561928 <I> <bricklet.c:304> Found supported HAT product_id 0x085d in device tree, using default HAT Zero Brick config
    2024-05-25 16:18:54.561936 <I> <bricklet.c:345> Found Bricklet port A (spidev: /dev/spidev0.0, driver: gpio, name: gpio426, num: 426)
    2024-05-25 16:18:54.561957 <I> <bricklet_stack_linux.c:87> Using spidev backend for Bricklets (unsupported suffix 5 after 'Raspberry Pi' in /proc/device-tree/model)
    2024-05-25 16:18:54.561994 <E> <gpio_sysfs.c:77> Could not write to '/sys/class/gpio/export' to export GPIO 426: EINVAL (22)
    2024-05-25 16:18:54.561997 <E> <bricklet_stack_linux_spidev.c:78> Could not export gpio426: EINVAL (22)
    2024-05-25 16:18:54.562163 <I> <main_linux.c:563> Brick Daemon 2.4.5 stopped

I already flashed the hardware to the newest version.n error occur

Any idea what is wrong? 

Link to comment
Share on other sites

I cannot reproduce the "sudo apt --fix-broken install" here.

Where did you find that you should install the dependencies (sudo apt-get install libusb-1.0-0 libudev1 procps) by hand? This is not neccessary. Also libudev1 is not required anymore. There where a few places left that still mentioned libudev1, I updated them now.

Please try this brickd version, this should fix the GPIO problem.

brickd_2.4.6+snapshot~730b7d7_arm64.deb

Link to comment
Share on other sites

Thanks for your feedback.

To answer the question, where I found the installation information. I followed the recommendation under:

     https://www.tinkerforge.com/en/doc/Software/Brickd.html

I choose under "Installation" Linux

     https://www.tinkerforge.com/en/doc/Software/Brickd_Install_Linux.html#brickd-install-linux

Then under "APT Repository" I found First, set up our APT repository on your system according to this guide

     https://www.tinkerforge.com/en/doc/Software/APT_Repository.html#apt-repository

To solve the problem, first I reinstalled a new blank version for the Raspberry 5/64bit.  The I used your .deb-file with the command:

     sudo apt install ./brickd_2.4.6+snapshot~730b7d7_arm64.deb

It worked I only got an error at the end, here the result:

     N: Download is performed unsandboxed as root as file '/media/pi/SCAN/_Tinkerbell/Scripts/RaspBerry BaseInstall Tinker/brickd_2.4.6+snapshot~730b7d7_arm64.deb' couldn't be                  accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

The file /media/pi/SCAN/_Tinkerbell/Scripts/RaspBerry BaseInstall Tinker/brickd_2.4.6+snapshot~730b7d7_arm64.deb' has the rights: -rwxr-xr-x 

But the demon is running and brickv can connect.

Thanks for the help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...