Jump to content

missing library "special" when opening kicad project


Recommended Posts



for many hardware project in tinkerforge, when we open the schematics inside kicad we get a message saying that the library "special" is missing.


Actually, there was a problem in kicad solved on may 22nd regarding this library problem. See https://forum.kicad.info/t/the-following-libraries-were-not-found-special-solved/870/2 and http://bazaar.launchpad.net/~kicad-product-committers/kicad/product/revision/5678 (the file template/kicad.pro).


At least industrial-dual-0-20ma-bricklet and ac-current-bricklet project have this problem.


I attach a patch fixing the problem for ac-current-bricklet.






Link to comment
Share on other sites

  • 5 months later...



many thanks for the hint.

Actually this problem will occur in many of our projects.

I think the only problem is, that the special library is missing in newer kicad versions, so it has to be removed from the library configuration of any project. As far as I know there should not be missing any symbols when doing this.


This does not have a high priority for us, since it can easily be fixed by the user.


Kind regards,



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...