Jump to content
Sign in to follow this  
rwblinn

Not able to Flash Master Brick 2.0

Recommended Posts

Having an older Master Brick and wanted to update to latest firmware version. Updated several Masters, but this device does not work.

 

Put the Master Brick in bootloader mode (blue LEDs turned off), but the device is not recognized as serial device on:

a) Raspberry Pi 3B+ running latest brickd + brickv. When connecting via USB the RPi freezes. Plugging out, the RPi is back to normal.

b) PC running Stretch: no tty device, i.e. ttyACM0 listed.

c) PC running Windows 10 with latest brickd + brickv: No serial device found.

 

Tried to run brickv as root or admin, but did not help.

 

Any hints on how to flash the Master Brick appreciated

 

Share this post


Link to post
Share on other sites

But the Master Brick worked before you put it into bootloader mode?

 

Do you have anything connected to the Master Brick, apart from the USB cable? If yes, disconnect everything apart from the USB cable and try again.

 

Is the reset button stuck, keeping the Brick in reset? Or does the reset button feel normal?

Share this post


Link to post
Share on other sites

Both buttons feel OK and can be pressed and released.

 

The Master Brick worked fine prior setting in bootloader mode.

 

Tried again:

Connected to PC USB port, set bootloadermode, the Master Brick started to smell and is getting hot (can not touch anymore) ... immediate unplugged. Will not plugin anymore!

 

 

Share this post


Link to post
Share on other sites

Tried again:

Connected to PC USB port, set bootloadermode, the Master Brick started to smell and is getting hot (can not touch anymore) ... immediate unplugged. Will not plugin anymore!

There it seems you have a shortlink in your connection. Please check your 4 connections to the bricklets whether there is one pin bended and touching the neighbour pin. Unbend it and try it again.

I also had one case where I couldn't upgrade a master because of this fault.

Share this post


Link to post
Share on other sites

Thanks for the hint. Checked the pins - seems OK.

 

... but does not trust this master brick anymore ... and will order a new one.

Share this post


Link to post
Share on other sites

(Sorry for late reply) Indeed found total 4 pins bend in two slots. After unbending, the Master Brick is still not reacting. 2 pins look rather dark - think are burned.

Will not pursue with this Master Brick.

 

Many thanks for the hint. Appreciated.

Share this post


Link to post
Share on other sites

That's one of the reasons we are switching the Bricklet connector to a different connector that doesn't have this kind of free standing pins.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...