Jump to content

HAT Zero and Thermal sensor are not responding


Recommended Posts


I am using HAT zero Brick and Thermal sensor by FLIR. I am using these components since last 1 week or something and they were working fine until now. Now whenever I am trying to connect it via python script, I am just getting one response, did not receive response. I have also tried to connect it via brick viewer and there is not response at all. I have checked the host address, port address and UID, everything is correct. The shutter of the thermal sensor works some time. Tried attaching sensor at other ports B, and D, but the same response. What can be the problem here? 

thanks in advance. 


Link to comment
Share on other sites

The log looks okay so far. If the Brick Viewer can't connect to the Pi, you should get a message box indicating the error. If no error is reported, then the connection succeeds but the Brick Daemon running on the Pi does not see any hardware. To verify this, you can stop the Brick Daemon with

sudo systemctl stop brickd

and then start a non-daemonized instance with debug logging:

sudo brickd --debug -all,+bricklet.c

If the HAT is detected, you will get output like this:

2020-06-08 14:27:57.143360 <D> <bricklet.c:182> Found product_id "0x085d" in device tree, using pre-configured HAT Zero Brick setup
2020-06-08 14:27:57.144827 <D> <bricklet.c:220> Bricklet found: spidev /dev/spidev0.0, driver 1, name gpio27 (num 27)

If this output is missing, the HAT is not detected.


Link to comment
Share on other sites

Hard to say why you don't have the deive-tree, the easiest solution is probably to just configure it by hand, see here: https://www.tinkerforge.com/en/doc/Hardware/Bricks/HAT_Zero_Brick.html#compatibility-to-other-boards-and-images

Add the lines from the documentation to your /etc/brickd.conf and turn spi interface on with raspi-config.

Then the brickd doesn't have to configure anything by reading out the device-tree first and it should just work.

Link to comment
Share on other sites

The relevant error message in your brickd.log is


2020-06-09 15:13:17.249677 <E> <bricklet_stack_linux.c:100> Could not open /dev/spidev0.0: ENOENT (2)

You have to enable the SPI device by running

sudo raspi-config

and then selecting "Interfacing Options" and "SPI" and answering yes.


brickd --check-config does not work, because you are not running it with sudo, so it tries to check the non-existing user specific config file.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...