Jump to content

RED Brick Web Interface error 31


Recommended Posts

Hello all,

I have the following setup: Master Brick, Accelerometer 2.0, Ethernet Master Extension and the RED brick.

I have successfully configured the local-area network, assigned the IP address and a WebSocket port to my stack. Then I tried in-browser JavaScript ExampleCallback.html for the accelerometer on my local computer which works very well with the assigned IP and port (the RED Brick is not yet connected).
However, when I connect a RED brick to the stack and upload ExampleCallback.html with JavaScript binding to the RED brick to use it as a simple web interface I get an error 31 when I press start example. I am using the IP address of a RED brick, and a web socket port which I assigned earlier in the Brick Viewer ethernet extension tab. Also, when I try running the ExampleCallback.html on my local computer I get the same error when the RED brick is connected.

Does anybody have any suggestions on what I should try?

Link to comment
Share on other sites

Error 31 is "Timeout". The most common cause for this is that you used the wrong UID in the example.

Are you sure it's error 31? Error 13 is "Connection Failed" that could be caused by wrong IP address or port configuration. The RED Brick does not used the WebSocket port configured on the Ethernet Extension itself. For the RED Brick you need to configure the WebSocket port on the RED Brick itself: Brick Viewer > RED Brick > Settings > Brick Viewer > Web Socket Port.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...