Jump to content

Unspecified System Requirements for brickd/brickv and Language Bindings


JavaLaurence
 Share

Recommended Posts

Hi guys,

 

Current documentation remains silent on what TF software requires to operate. Especially the language bindings could do with some info like, for the Java bindings, "requires version Java 1.5 or later". (the generated binding is not compatible with 1.4 and earlier - believe it or not lots of people in the embedded world still use Java 1.1 ..)

 

HTH

 

  Laurence

 

Link to comment
Share on other sites

Definitely! There is version information for the languages here: http://www.tinkerforge.com/doc/Software/API_Bindings.html#java

 

But it is a little bit scattered there.

 

Operating systems: Windows: XP and above, Linux: you need libusb1, Mac OS X: We are currently working on that (see your other thread).

 

Where could i add it more centraly? Probably on the downloads page? http://www.tinkerforge.com/doc/Downloads.html

Link to comment
Share on other sites

Yes, on the Downloads page, in the Bindings and Examples section, you could add another column "Requirements" to the Language/Current Version/Changelog table.

 

It makes sense on the Downloads page because that's the only guaranteed place where people will pass through to access the software (due to, you know, the RTFM syndrome in our industry).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...