Jump to content

Consistent Product Naming


JavaLaurence
 Share

Recommended Posts

I'm probably not the first to remark this, but I noticed that most products are called after the physical property that they measure, e.g. current, distance, humidity, temperature. Whereas a minority is called after the measuring device itself: Barometer (measures AirPressure), LinearPoti (measures Resistance).

 

Obviously from a product naming point of view this isn't a big deal, but from an API design point of view, it is a shame, as consistency of semantics helps readability a lot. It also makes interoperability with third-party APIs dealing with measurement units a bit awkward.

 

 

Link to comment
Share on other sites

We try to choose a name that is most intuitive. ResistanceBricklet would not be intuitive for a Poti Bricklet, i think.

 

AirPressure Bricklet instead of Barometer Bricklet would be OK, but we thought that most people know that a barometer can measure height (which the Barometer Bricklet can too).

 

And for things like the Distance Bricklet it would be hard to use a name of the device: GP2Y0A41 Bricklet, ugh ;D.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...