Jump to content

Linux compatibility (CentOS)


Xenna
 Share

Recommended Posts

I just tried to install the brick daemon on my CentOS 5.8 system. Unfortunately I met with many problems.

 

I can't find a gudev-python rpm for it (why does a daemon need a desktop library anyway?)

I can't find an rpm for the libusb that is required, just something called 'libusb'.

At least the python-twisted stuff is there (by default).

 

When I try to run the daemon anyway I get:

 

./brickd_linux.py

Traceback (most recent call last):

  File "./brickd_linux.py", line 30, in ?

    from usb_notifier import USBNotifier

  File "/usr/src/Tinkerforge-brickd-1836e39/src/brickd/usb_notifier.py", line 30

    class USBNotifier():

                      ^

It would be nice if you could offer a little bit wider distribution support than just Debian. CentOS/RHEL/Fedora Core are widely used.

 

Has anyone tackled this problem before?

 

Link to comment
Share on other sites

python-gudev is needed for USB hotplug, you can use brickd without it (you have to plug in the Bricks before starting brickd in that case).

 

Regarding your traceback: Is that the complete traceback? It isn't saying anything.

 

Can you change the logging level to logging.DEBUG in config.py and then run brickd with ./brickd_linux nodaemon and post the outcome?

 

edit: I just did a quick search, it seems libusb1 and python-gudev is readily available as rpm:

http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libusb1

http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/python-gudev

 

there are also rpm's for CentOS 6 in the list (i can't see any for 5.8 unfortunately).

Link to comment
Share on other sites

I could do without the hotplug so that's no problem.

 

Done that, changed the config.py in the brickd/src directory, same result:

 

# ./brickd_linux.py nodaemon

Traceback (most recent call last):

  File "./brickd_linux.py", line 30, in ?

    from usb_notifier import USBNotifier

  File "/usr/src/Tinkerforge-brickd-1836e39/src/brickd/usb_notifier.py", line 30

    class USBNotifier():

                      ^

SyntaxError: invalid syntax

 

My Python knowledge is virtually non existent.

Perhaps the CentOS python version is not supported? Info:

 

Python 2.4.3 (#1, Feb 22 2012, 16:06:13)

[GCC 4.1.2 20080704 (Red Hat 4.1.2-52)] on linux2

 

Or perhaps I just don't have the right USB library installed...?

 

Link to comment
Share on other sites

No idea what is going on there. There is no way to install python 2.4 on any of the systems i have here (other then compiling it from source), but there is nothing that could be considered a syntax error in any python version at that location.

Link to comment
Share on other sites

I'll try installing one of those libusb1 rpm's, I'll report back if I get it to work.

 

I guess it wouldn't be a big problem to upgrade to CentOS 6, which apparently comes with Python 2.6 if I can't get it to work otherwise.

Link to comment
Share on other sites

Update:

- I couldn't install libusb1 from these rpms

- Instead I installed Virtualbox on a Windows machine

- I loaded up the Centos 6.2 image from here: http://virtualboxes.org/images/centos/

- Installed the USB drivers for Virtualbox

- Changed networking to bridged

- Added the Master Brick to the USB filters

 

And then it all went smoothly:

- yum update

- libusb1 was already installed

- yum install python-twisted

- yum install python-gudev

- ./brickd_linux.py

 

I was able to run brickv on the windows box and control my bricks via the brickd on the centos 6.2 VM.

 

So it seems upgrading my server to CentOS 6.2 would seem the way to go... (it's good to know this in advance that it's going to work before going through all the hassle of upgrading my server)

 

There is no way to install python 2.4 on any of the systems i have here (other then compiling it from source)

 

Install Virtualbox and mount the Centos 5.8 image on http://virtualboxes.org/images/centos/ . You'll be up in 5 minutes. Many other system images available. Great for testing!

 

Link to comment
Share on other sites

  • 2 weeks later...

I upgraded to CentOS 6.2 and (most) everything is working fine (except from my RAID5 setup that suddenly developed a split personality, but that's for a different forum.

 

Brickd is humming away nicely. I would appreciate an RPM eventually, though, to make things 'official'.

 

Link to comment
Share on other sites

  • 1 month later...

CentOS 5.x works as well, but python24 is not ideal, there are some additional dependencies, such as ctypes.

I added python26(std repo) and installed twisted and libusb1 from source. brickd runs fine on CentOS 5.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...